• Announcements

    • xper

      MSFN Sponsorship and AdBlockers!   07/10/2016

      Dear members, MSFN is made available via subscriptions, donations and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, become a site sponsor and ads will be disabled automatically and by subscribing you get other sponsor benefits.
dead0

Windows 7 Ultimate/Server 2008 R2 Enterprise SP1 Batch Removal

124 posts in this topic

Since I am using Windows 7 Home Premium, should I delete the following line from the dism batch file:

dism.exe /image:d:\s3 /remove-package /packagename:Microsoft-Windows-HomePremiumEdition-wrapper~31bf3856ad364e35~amd64~~6.1.7601.17514

Since I am not using Ultimate, should I add a line like:

dism.exe /image:d:\s3 /remove-package /packagename:Microsoft-Windows-UltimateEdition-wrapper~31bf3856ad364e35~amd64~~6.1.7601.17514

Thx

Hmmm. Removing "UltimateEdition-wrapper" failed and caused all packages after it to fail also....

Anyone know why, since I am on Windows 7 HP.....

0

Share this post


Link to post
Share on other sites

You can use:

Dism /Image:C:\Mounted_Folder /Get-Packages >C:\Packages.txt

Using Dism.exe inside = C:\Windows\System32\Dism.exe

Frist, it's needed to mount the image.

And look at the file Packages.txt, to know the Packages inside your Windows 7!

For information, you can also find all Packages and updates installed (.cat and .mum files) on your computer, inside: C:\Windows\servicing\Packages

*Edit: post updated

Edited by myselfidem
0

Share this post


Link to post
Share on other sites

Does removing these wrapper packages break anything??

i.e. since I am using a Home Premium disk, is it ok for me to remove the package via dism: Microsoft-Windows-HomePremiumEdition-wrapper~31bf3856ad364e35~amd64~~6.1.7601.17514

Edited by theKramer
0

Share this post


Link to post
Share on other sites

I think it's better to keep this Package!

With your Windows 7 HOMEPREMIUM 64-bit disk you must remove some lines inside: 7dismx64.bat, because some Packages doesn't exist for Windows 7 Homepremium!

Check with your Packages.txt!

Edited by myselfidem
0

Share this post


Link to post
Share on other sites

You can use:

Dism /Image:C:\Mounted_Folder /Get-Packages >C:\Packages.txt

Using Dism.exe inside = C:\Windows\System32\Dism.exe

Frist, it's needed to mount the image.

And look at the file Packages.txt, to know the Packages inside your Windows 7!

Hi. Me again.

I created the file Packages.txt, and I found that it contains packages with 6.1.7601.17514 (SP1 packages) and also 6.1.7600.16385 (non SP1 packages). I presume this is because I upgraded my non SP1 Windows 7 image with SP1 via RT7Lite.

Some of the non-SP1 packages have the following state:

State : Install Pending and others have the state:

State : Uninstall Pending

Should I remove both or just ignore the non SP1 packages?

Also, do I need to specify both en-us packages and those that do not contain en-us into my dism7x64.bat file for removal, or will dism automatically remove both?

Thx.

Edited by theKramer
0

Share this post


Link to post
Share on other sites

You can use:

Dism /Image:C:\Mounted_Folder /Get-Packages >C:\Packages.txt

Using Dism.exe inside = C:\Windows\System32\Dism.exe

Frist, it's needed to mount the image.

And look at the file Packages.txt, to know the Packages inside your Windows 7!

Hi. Me again.

I created the file Packages.txt, and I found that it contains packages with 6.1.7601.17514 (SP1 packages) and also 6.1.7600.16385 (non SP1 packages). I presume this is because I upgraded my non SP1 Windows 7 image with SP1 via RT7Lite.

Some of the non-SP1 packages have the following state:

State : Install Pending and others have the state:

State : Uninstall Pending

Should I remove both or just ignore the non SP1 packages?

Also, do I need to specify both en-us packages and those that do not contain en-us into my dism7x64.bat file for removal, or will dism automatically remove both?

Thx.

I'm also wondering about the install pending and uninstall pending. Apparently from reading over at technet these are delt with at install time. But does that mean we have extra crap in our image waiting to be deleted? That is what I am not sure about. Dism cleanup does not fix this. That only works for deleting sp1 files from the winsxs directory. Kinda frustrating that those are shown that way.

As for the packages with EN-us and ones without. It appears if you remove the EN-us one the regular one will also be removed. If you put both in your remove bat DISM will say the second none language one is not a valid package. So it appears they are tied together. Why they show as different packages is beyond me. Why does MS have a lang part for every packages and not 1 big lang pack. That would make sense.

Hope that helps.

0

Share this post


Link to post
Share on other sites

I don't use RT Se7en Lite to integrate SP1, but I use sysprep method and imagex.exe to capture my new install.wim image with SP1 installed:

You can watch the videos:

http://www.wincert.net/forum/index.php/topic/7384-video-windows-7-aikopk-deployment-101-updated/

Packages inside my image using sysprep to integrate SP1 (IE9 was installed after on the mounted image Offline):

Outil Gestion et maintenance des images de d‚ploiement

Version : 6.1.7600.16385

Version de l'imageÿ: 6.1.7601.17514

Liste des packagesÿ:

Identit‚ du package : Microsoft-Hyper-V-Common-Drivers-Package~31bf3856ad364e35~x86~~6.1.7601.17514

tat : Install‚

Type de version : Feature Pack

Heure d'installation : 12/03/2011 11:50

etc...

Identit‚ du package : Microsoft-Windows-InternetExplorer-Package~31bf3856ad364e35~x86~en-US~9.4.8112.16421

tat : Installation en attente

Type de version : Language Pack

Heure d'installation : 26/03/2011 10:02

Identit‚ du package : Microsoft-Windows-InternetExplorer-Optional-Package~31bf3856ad364e35~x86~fr-FR~8.0.7601.17514

tat : D‚sinstallation en attente

Type de version : Language Pack

Heure d'installation : 12/03/2011 11:50

Identit‚ du package : Microsoft-Windows-InternetExplorer-Optional-Package~31bf3856ad364e35~x86~fr-FR~9.4.8112.16421

tat : Installation en attente

Type de version : Language Pack

Heure d'installation : 26/03/2011 10:02

etc...

Identit‚ du package : Package_1_for_KB976902~31bf3856ad364e35~x86~~6.1.1.17514

tat : Install‚

Type de version : Update

Heure d'installation : 12/03/2011 11:16

Identit‚ du package : Package_for_KB976902_RTM~31bf3856ad364e35~x86~~6.1.1.17514

tat : Install‚

Type de version : Update

Heure d'installation : 12/03/2011 11:16

Identit‚ du package : Package_for_KB976902~31bf3856ad364e35~x86~~6.1.1.17514

tat : Install‚

Type de version : Update

Heure d'installation : 12/03/2011 11:16

Identit‚ du package : Package_for_KB976932~31bf3856ad364e35~x86~~6.1.1.17514

tat : Install‚

Type de version : Service Pack

Heure d'installation : 12/03/2011 11:39

The full Packages List is only given with install_wim_tweak.exe

Anyway I don't use this method, doesn't work for me...I use this one:

http://www.msfn.org/...64-bit-updated/

Edited by myselfidem
0

Share this post


Link to post
Share on other sites

Should I remove both or just ignore the non SP1 packages?

Also, do I need to specify both en-us packages and those that do not contain en-us into my dism7x64.bat file for removal, or will dism automatically remove both?

YES! But...

After testing integrated SP1 with Se7en_UA you can remove FIRST Packages with 6.1.7601.17514 (SP1) and AFTER the same Packages 6.1.7600.16385!

*Edit:post updated

Edited by myselfidem
0

Share this post


Link to post
Share on other sites

NO!

After testing integrated SP1 with Se7en_UA it's ONLY needed to remove Packages with 6.1.7601.17514 (SP1)!

I will reintegrate SP1 with Se7en_UA instead of RT7lite. Have read of some issues with RT7lite, in general, so I think it would be better to slipstream again.

Thanks a lot for for your help.

0

Share this post


Link to post
Share on other sites

Yes, I think it's better to use Se7en_UA to integrate SP1, and you will see all Packages amd64~~6.1.7600.16385 and amd64~~6.1.7601.17514.

You can remove Packages amd64~~6.1.7601.17514 FIRST and AFTER the same Packages for amd64~~6.1.7600.16385

Extract Output command window. After removing the Packages 6.1.7601.17514...removed THE SAME Packages 6.1.7600.16385 (example: Windows 7 x86).

SP1 integrated with Se7en_UA!

---------------------------------------------------------------------------------------

Outil Gestion et maintenance des images de déploiement

Version : 6.1.7600.16385

Version de l'image : 6.1.7601.17514

Traitement de 1 sur 1 - Suppression du package Microsoft-Hyper-V-Common-Drivers-Package~31bf3856ad364e35~x86~~6.1.7600.16385

[==========================100.0%==========================]

L'opération a réussi.

Outil Gestion et maintenance des images de déploiement

Version : 6.1.7600.16385

Version de l'image : 6.1.7601.17514

Traitement de 1 sur 1 - Suppression du package Microsoft-Hyper-V-Guest-Integration-Drivers-Package~31bf3856ad364e35~x86~~6.1.7600.16385

[==========================100.0%==========================]

L'opération a réussi.

Outil Gestion et maintenance des images de déploiement

Version : 6.1.7600.16385

Version de l'image : 6.1.7601.17514

Traitement de 1 sur 1 - Suppression du package Microsoft-Windows-Anytime-Upgrade-Results-Package~31bf3856ad364e35~x86~~6.1.7600.16385

[==========================100.0%==========================]

L'opération a réussi.

etc...

--------------------------------------------------------------------------------

Edited by myselfidem
0

Share this post


Link to post
Share on other sites

Question would this work on Windows Embbeded Standard 7.This reaches Max file space of 4 gb.

Media Center WMP,Aero basicly everything and you can even remove winsxs ;)

0

Share this post


Link to post
Share on other sites

Could please somebody uploads the final guide for Win 7 x64 (without SP1)? (all links are down and offline)

Without this guide is this topic not helpful, because dead0 write only about first step...but what is next?

Thank you.

Edited by Dimtrij
0

Share this post


Link to post
Share on other sites

Could please somebody uploads the final guide for Win 7 x64 (without SP1)? (all links are down and offline)

I'll make a new pdf with all the instructions if you still need it.

0

Share this post


Link to post
Share on other sites

I'll make a new pdf with all the instructions if you still need it.

I would appreciate that very much (in my case Win7+sp1). Can I ask you for that? Thanks a lot.

0

Share this post


Link to post
Share on other sites

For those that read dead0's guide, at which point was it safe to integrate updates?

I want to integrate .msu updates with dism but vlite crashes when used with an updated 7 source.

0

Share this post


Link to post
Share on other sites

platform is windows 7 SP1 x64, target is the same

I have an Error: 0x800f0830 when trying to execute the DISM batch

installed windows 7 AIK KB3AIK_EN.iso

mounted the image with gimagex.exe x64 from amd64 directory

enable read and write and commit changes

mounting worked successfully

Microsoft Windows [Version 6.1.7601]

Copyright © 2009 Microsoft Corporation. All rights reserved.

J:\W7SP1DEAD0\sources>dism7x64.bat

J:\W7SP1DEAD0\sources>dism.exe /image:i:\dead0mount /remove-package /packagename

:Microsoft-Hyper-V-Common-Drivers-Package~31bf3856ad364e35~amd64~~6.1.7601.17514

Deployment Image Servicing and Management tool

Version: 6.1.7601.17514

Image Version: 6.1.7600.16385

Processing 1 of 1 -

Microsoft-Hyper-V-Common-Drivers-Package: The specified image is no longer servi

ceable.

Unmount the image and discard your changes. Mount the original image to try the

operation again.

Error: 0x800f0830

Error: 0x800f0830

DISM failed. No operation was performed.

For more information, review the log file.

The DISM log file can be found at C:\Windows\Logs\DISM\dism.log

J:\W7SP1DEAD0\sources>dism.exe /image:i:\dead0mount /remove-package /packagename

:Microsoft-Hyper-V-Guest-Integration-Drivers-Package~31bf3856ad364e35~amd64~~6.1

.7601.17514

Deployment Image Servicing and Management tool

Version: 6.1.7601.17514

Image Version: 6.1.7600.16385

Processing 1 of 1 -

Microsoft-Hyper-V-Guest-Integration-Drivers-Package: The specified image is no l

onger serviceable.

Unmount the image and discard your changes. Mount the original image to try the

operation again.

Error: 0x800f0830

Error: 0x800f0830

DISM failed. No operation was performed.

For more information, review the log file.

The DISM log file can be found at C:\Windows\Logs\DISM\dism.log

J:\W7SP1DEAD0\sources>dism.exe /image:i:\dead0mount /remove-package /packagename

:Microsoft-Windows-Anytime-Upgrade-Results-Package~31bf3856ad364e35~amd64~~6.1.7

601.17514

Deployment Image Servicing and Management tool

Version: 6.1.7601.17514

Image Version: 6.1.7600.16385

An error occurred trying to open - Microsoft-Windows-Anytime-Upgrade-Results-Pac

kage~31bf3856ad364e35~amd64~~6.1.7601.17514 Error: 0x800f0805

The specified package is not valid Windows package.

Error: 0x800f0805

The specified package is not valid Windows package.

The DISM log file can be found at C:\Windows\Logs\DISM\dism.log

J:\W7SP1DEAD0\sources>dism.exe /image:i:\dead0mount /remove-package /packagename

:Microsoft-Windows-Backup-Package~31bf3856ad364e35~amd64~~6.1.7601.17514

Deployment Image Servicing and Management tool

Version: 6.1.7601.17514

Image Version: 6.1.7600.16385

Processing 1 of 1 -

Microsoft-Windows-Backup-Package: The specified image is no longer serviceable.

Unmount the image and discard your changes. Mount the original image to try the

operation again.

Error: 0x800f0830

Error: 0x800f0830

DISM failed. No operation was performed.

For more information, review the log file.

The DISM log file can be found at C:\Windows\Logs\DISM\dism.log

J:\W7SP1DEAD0\sources>dism.exe /image:i:\dead0mount /remove-package /packagename

:Microsoft-Windows-BLB-Client-Package~31bf3856ad364e35~amd64~~6.1.7601.17514

Deployment Image Servicing and Management tool

Version: 6.1.7601.17514

Image Version: 6.1.7600.16385

Processing 1 of 1 -

Microsoft-Windows-BLB-Client-Package: The specified image is no longer serviceab

le.

Unmount the image and discard your changes. Mount the original image to try the

operation again.

Error: 0x800f0830

Error: 0x800f0830

DISM failed. No operation was performed.

For more information, review the log file.

The DISM log file can be found at C:\Windows\Logs\DISM\dism.log

J:\W7SP1DEAD0\sources>dism.exe /image:i:\dead0mount /remove-package /packagename

:Microsoft-Windows-BusinessScanning-Feature-Package~31bf3856ad364e35~amd64~~6.1.

7601.17514

Deployment Image Servicing and Management tool

Version: 6.1.7601.17514

Image Version: 6.1.7600.16385

Attempting to cancel the operation...

Error: 1223

Operation was incomplete because of a cancel request.

The DISM log file can be found at C:\Windows\Logs\DISM\dism.log

Terminate batch job (Y/N)? y

J:\W7SP1DEAD0\sources>

Update: Corrected by restarting process from the very beginning, the problem was with the image file gone through the process of apply>create before mount

the complete combined process for x64 SP1 is

install windows 7 AIK KB3AIK_EN.iso

copy the correct (x86 to x86 amd64 to amd64) version of gimagex.exe to%KB3AIK_EN.iso_destination_directory%\tools\%platform% and launch gimagex.exe

go to mount and select the install.wim image with gimagex.exe, make sure to select read and write and commit changes then press mount

download "install wim tweak" from http://www.msfn.org/board/topic/152688-win6x-registry-tweak/page__p__972077#entry972077p and put the exe somewhere you can find it

start a command prompt as administrator and execute the tweak exe, give the destination mount directory at the program's prompt

once the tweak.exe is finished, edit the dism bat (dism7x64.bat) and change the c:\s2 directory to your mount directory then copy the modified bat to the source directory (that is your copied windows ISO directory\sources) launch the dism bat (dism7x64.bat) (either from the same command prompt or a new one as administrator) from the sources directory under the main ISO directory, for example: c:\s1\sources

Update: now I have a different problem: vlite 1.2 crashes after the Cleaning step, I tried to not remove most of the components and it doesn't help, it's not a component-related crash, I did the apply/create with WAIK 1.1 after the DISM bat (dism7x64.bat)

Edited by monohouse
0

Share this post


Link to post
Share on other sites

I''ve a temporary pdf. Download

Hi there, can I ask for a re-upload?

Or - Can somebody provide some complete, updated instructions (and probably batches a.s.o) for W7U SP1 x86?

I've been trying to struggle through it for half a year, no real succes, going desperate.

Thanks a lot!

Edited by vhatp
0

Share this post


Link to post
Share on other sites

I contacted a friend of mine and asked him to remake his previously attached guide.

I verified the contents and the instruction are the same as dead0 (almost). Post here if you have trouble with the instructions.

I would like the mods to place this attachment to the first post of this thread if it would be possible.

dead0-7SP1-lite.pdf

0

Share this post


Link to post
Share on other sites

when following the latest guide you posted AlexCeed, the folder s2 isnt empty after the apply/capture process so it cant be used in the mount process. also the stuff that is in it cant be completely deleted. I'm having a hell of a time getting everything deleted.

0

Share this post


Link to post
Share on other sites

when following the latest guide you posted AlexCeed, the folder s2 isnt empty after the apply/capture process so it cant be used in the mount process. also the stuff that is in it cant be completely deleted. I'm having a hell of a time getting everything deleted.

You need subinacl.exe from micro s h i t. Then you type in the command line (replace ==PATH== with the path to your mounted souce):

subinacl.exe /noverbose /nostatistic /subdirectories ==PATH==\* /setowner=Administrators

After the above completes type in this one:

subinacl.exe /noverbose /nostatistic /subdirectories ==PATH==\* /grant=Administrators=f

And then try to delete the folder.

Edited by AlexCeed
0

Share this post


Link to post
Share on other sites

Problem in windows installation

error.jpg

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.