Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 



dbinca

After USB install, won't boot w/o usb

Recommended Posts

dbinca    0

ok, I made the HEX change and saved it. Made a menu.lst, there was none there cause I had renamed the old like you told me to b4. I rebooted and still the same.

Share this post


Link to post
Share on other sites

jaclaz    943

ok, I made the HEX change and saved it. Made a menu.lst, there was none there cause I had renamed the old like you told me to b4. I rebooted and still the same.

With all due respect I doubt it. :unsure:

Is it possible that there are TWO errors? :blink:

Do the following:

File->Disk->Open Drive

Choose \\.C:\ (\\.\PhysicalDrive0, partition 1)

Make sure you:

Load 0x1 sectors at the time

Start sector 0

Select All/Copy/Paste to new/Save as bootsector.dat

File->Disk->Open Drive

Choose \\.\PhysicalDrive0

Make sure you:

Load 0x1 sectors at the time

Start sector 0

Select All/Copy/Paste to new/Save as MBR.dat

Compress the two files into a zip and post the .zip.

jaclaz

Share this post


Link to post
Share on other sites
jaclaz    943

There is no apparent reason why the MBR and bootsector could not work. :wacko:

I mean, in the MBR there is one single 0C type partition, Active 0/128/1 -1024/254/63 8064/31219776 (the CHS and LBA are "balanced")

The partition starts on a fractional head (128) and this may be a problem :unsure: for the "title XP on internal HD MBR " BUT the bootsector has a "right geometry" of 255/63 (after the fix) and has a "right" 31219776 filesystem size., with the "right" sectors before 8064, which should allow the " title XP on internal HD bootsector" to work anyway.

You can try removing CHS check from the bootsector, i.e. change bytes at offset [0xE6], [0xE7], [0xE8] and [0xE9] to 0x90:

http://www.911cd.net/forums//index.php?showtopic=21702&st=129

i.e 0F824A00 to 90909090

I am attaching a pre-modified bootsector.

Try fixing the bootsector as per above and try again the three menu.lst entries.... (or tey typicg in the command line, I just reviewed them and they seem allright to me, but you never know)

When entering the commands:

The only other possibility I can think of is that (for whatever reason) one of the "other" sectors involved in the booting is missing or corrupted.

http://mirror.href.com/thestarman/asm/mbr/ntFAT32BR.htm

Do the following:

File->Disk->Open Drive

Choose \\.C:\ (\\.\PhysicalDrive0, partition 1)

Make sure you:

Load 0x10 sectors at the time

Start sector 0

Select All/Copy/Paste to new/Save as bootsectorall.dat

Compress the file into a zip and post the .zip.

As soon as I can find some time I will anyway test your MBR and bootsector in a VM to see if I can see anything I missed... :blink:

jaclaz

bootsect_mod.zip

Share this post


Link to post
Share on other sites
dbinca    0

It's a custom machine.

So, check this out, I went to open the drive again in the hex editor and it was back at 10? I pasted yours over, saved, closed and opened it again and it was still 10!

So wtf is that about? Is there something preventing it from saving?

Derek

Share this post


Link to post
Share on other sites
jaclaz    943

Hmmm. :unsure: cannot say.

XP has not this kind of protection (that you may have in Vista :ph34r: and later) some BIOS protection?

Make sure you know which drive letter the partition has, (it should be C:) and assuming you unzipped the bootsector_mod.dat to the same drive then run dsfi (part of the dsfok package:

http://members.ozemail.com.au/~nulifetv/freezip/freeware/

to copy the bootsector file to the drive like (open a command prompt, navigate to where you unzipped the DSFOK package and type):

dsfi \\.\C: 0 512 C:\bootsect_mod.dat

[ENTER]

Or check the hex editor settings, it is possible that it has a "read only or "fake-write" kind of setting.

The note by cdob about Lenovo was because this brand often has a "queer" BIOS that "sees" devices as having a 240 heads geometry, but since grub4dos (which should use the BIOS info) finds 255, this latter should be the "right" geometry.

jaclaz

Edited by jaclaz

Share this post


Link to post
Share on other sites
jaclaz    943

WOOHOO!!! It's working now after using dsfi!!

Thank you very much for all your help! :thumbup

You are welcome.

Please note how the bootsector you are now using has TWO fixes, the first one actually needed, the second one probably not.

Now that the DATA is OK, you could generate a new bootsector (with bootpart or by booting to Recovery Console and running bootfix or whatever), and have also the CODE "kosher" (the one you have now has disabled CHS addressing).

The above is not *needed* of course, what I would advice is to check the copy of the bootsector (Sector 6 on FAT32 volumes) is "in sync", you never know when (and IF ;)) you may need it :).

jaclaz

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×