Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account



Photo

Big problem with BlackWingCat's AHCI drivers for AMD

- - - - -

  • Please log in to reply
16 replies to this topic

#1
tomasz86

tomasz86

    www.windows2000.tk

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,516 posts
  • Joined 27-November 10
  • OS:none specified
  • Country: Country Flag
I have a Foxconn ML76-K 3.0 motherboard with AMD 760G chipset. I want to use BlackWingCat's drivers for AMD available here:

http://blog.livedoor...ves/844979.html

There are 4 versions available:

3.1.1540.25
3.1.1540.127
3.1.1548.155
3.2.1540.53

The problem is that when I install one of the last three, ie. 127, 155 or 53 the shutdown command does not work properly. The system seems to shut down but the PC does not power off - the screen goes off but fans are still working and I have to manually turn it off by long press of the power button.

On the other hand, 25 works but it's painfully slow. In terms of boot time 53 is definitely the fastest one and it's the one I want to use. When using 25 system boots almost 20-25 seconds slower than when using 53 :(

To summarise - I want to use 53 but shutdown/reboot does not work. 25 works properly but it's very slow in terms of boot time. Enhanced IDE instead of AHCI is fast in terms of booting time (almost the same as 53) but transfers are noticeably slower and instable compared to AHCI.

Are these drivers buggy? :huh: Are there maybe other drivers available for this chipset that work under Win2k?

Help please :angel

Edited by tomasz86, 03 April 2011 - 12:39 AM.

post-47483-1123010975.png



How to remove advertisement from MSFN

#2
allen2

allen2

    Not really Newbie

  • Member
  • PipPipPipPipPipPipPip
  • 1,804 posts
  • Joined 13-January 06
Did you tried the official XP drivers ?

#3
tomasz86

tomasz86

    www.windows2000.tk

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,516 posts
  • Joined 27-November 10
  • OS:none specified
  • Country: Country Flag
Yes, I tried installing the official drivers from AMD's homepage but system does not boot (BSOD) after having them installed.

post-47483-1123010975.png


#4
Colonel O'Neill

Colonel O'Neill

    Member

  • Member
  • PipPip
  • 255 posts
  • Joined 22-July 08
  • OS:none specified
  • Country: Country Flag
Strange, I have the exact same issue, but thought it was due to poor support of newer hardware in terms of Power Management.
T400: 7x86
X100e: 7x86, 2008R2 (in progress), 2000 (in progress).

#5
dencorso

dencorso

    Iuvat plus qui nihil obstat

  • Supervisor
  • 5,935 posts
  • Joined 07-April 07
  • OS:98SE
  • Country: Country Flag

Donator

This is just a longshot , but you might:

(i) Try disabling the following statements contained in ahcix86.inf (from v.3.2.1540.53) , by prepending a semicolon to them (here indicated in bold red)...

; HKR, Settings\CAM, CAMTimeOutValue, 0x00010001, 0x00000005
; HKR, Settings\CAM, EnableAN, 0x00010001, 0x00000001

Or you might delete those two values from the registry, after the driver is installed (but do save the key by exporting it, before deleting anything)... they should be at HKLM\SYSTEM\CurrentControlSet\services\ahcix86\Settings\CAM.

This page elsewhere may be relevant, too, even if indirectly.

(ii) Or, even easier, although less subtle, install v. 3.1.1540.25 (the one that works), then, manually, while booted from DOS or Linux, rename ahcix86.sys (v. 3.1.1540.25) to ahcix86.025 and add ahcix86.sys (v. 3.2.1540.53) to the same folder, which should be %windir%/SYSTEM32/DRIVERS, and then boot windows again and see what happens.

Either of these suggestions may just work, but may also mess things up. So do it at your own risk, or don't even try it.

#6
tomasz86

tomasz86

    www.windows2000.tk

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,516 posts
  • Joined 27-November 10
  • OS:none specified
  • Country: Country Flag
I tried all your suggestions and also did a manual install of all of these drivers but still the only one working is the slow one, ie. version 25. I even tried using the .inf file from 25 and the driver from 53 but the problem of not shutting down properly is still present.

I think the problem lies inside the driver (ahci86.sys) file, not in the .inf one or the system registry.

I really hope there is a solution :(

Still I will probably continue to use the 53 version and shut the PC down manually as it's just much faster than the older driver (25).

I would be really thankful if anyone with suitable knowledge could edit the newer drivers to work properly under Win2k. :unsure:

Edited by tomasz86, 03 April 2011 - 10:31 PM.

post-47483-1123010975.png


#7
Phenomic

Phenomic

    Member

  • Member
  • PipPip
  • 281 posts
  • Joined 31-July 09
  • OS:none specified
  • Country: Country Flag
I haven't tried AMD 760G but 3.2.1540.53 works fine with my 790GX/SB750 and 890GX/SB850

http://www.msfn.org/...0-motherboards/

My Asus 790GX had a power-off problem but I doubt yours is related to the AHCI driver. Hibernation (notoriously slow in win2k) is VERY fast too, about equal to XP.

#8
tomasz86

tomasz86

    www.windows2000.tk

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,516 posts
  • Joined 27-November 10
  • OS:none specified
  • Country: Country Flag
Mine has SB710 and I'm 100% sure that this issue is related to the AHCI driver as everything works perfectly when I switch back to the 3.1.1540.25 version of the driver.

Apart from the slow booting of course...

post-47483-1123010975.png


#9
Colonel O'Neill

Colonel O'Neill

    Member

  • Member
  • PipPip
  • 255 posts
  • Joined 22-July 08
  • OS:none specified
  • Country: Country Flag
Mine is an SB780... Seems like it's a SB7xx only issue?
T400: 7x86
X100e: 7x86, 2008R2 (in progress), 2000 (in progress).

#10
Phenomic

Phenomic

    Member

  • Member
  • PipPip
  • 281 posts
  • Joined 31-July 09
  • OS:none specified
  • Country: Country Flag

Mine has SB710 and I'm 100% sure that this issue is related to the AHCI driver as everything works perfectly when I switch back to the 3.1.1540.25 version of the driver.

Apart from the slow booting of course...


Not sure what you mean, by the time you get to power-off stage there's no OS or any drivers loaded.

#11
tomasz86

tomasz86

    www.windows2000.tk

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,516 posts
  • Joined 27-November 10
  • OS:none specified
  • Country: Country Flag
Yes but the OS doesn't shut down correctly because of these drivers so the computer also won't turn off.

post-47483-1123010975.png


#12
blackwingcat

blackwingcat

    Friend of MSFN

  • Member
  • PipPipPipPipPip
  • 864 posts
  • Joined 31-May 08
  • OS:Windows 2000 Professional
  • Country: Country Flag
Hi.
If there is some other version XP Driver as you want to try , then I'll migrate to Windows 2000.

I have a Foxconn ML76-K 3.0 motherboard with AMD 760G chipset. I want to use BlackWingCat's drivers for AMD available here:

http://blog.livedoor...ves/844979.html

There are 4 versions available:

3.1.1540.25
3.1.1540.127
3.1.1548.155
3.2.1540.53

The problem is that when I install one of the last three, ie. 127, 155 or 53 the shutdown command does not work properly. The system seems to shut down but the PC does not power off - the screen goes off but fans are still working and I have to manually turn it off by long press of the power button.

On the other hand, 25 works but it's painfully slow. In terms of boot time 53 is definitely the fastest one and it's the one I want to use. When using 25 system boots almost 20-25 seconds slower than when using 53 :(

To summarise - I want to use 53 but shutdown/reboot does not work. 25 works properly but it's very slow in terms of boot time. Enhanced IDE instead of AHCI is fast in terms of booting time (almost the same as 53) but transfers are noticeably slower and instable compared to AHCI.

Are these drivers buggy? :huh: Are there maybe other drivers available for this chipset that work under Win2k?

Help please :angel


+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
BlackWingCat =^^=
http://blog.livedoor.jp/blackwingcat/
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

#13
tomasz86

tomasz86

    www.windows2000.tk

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,516 posts
  • Joined 27-November 10
  • OS:none specified
  • Country: Country Flag
AMD says that the newest XP 32-bit driver for AMD SB7xx is 3.1.1540.127. You've already made a Win2k version of it and it doesn't work with my motherboard :no:

post-47483-1123010975.png


#14
blackwingcat

blackwingcat

    Friend of MSFN

  • Member
  • PipPipPipPipPip
  • 864 posts
  • Joined 31-May 08
  • OS:Windows 2000 Professional
  • Country: Country Flag
Did you try to use 3.1.1540.25's sys file and 3.1.1540.127's inf file ?

AMD says that the newest XP 32-bit driver for AMD SB7xx is 3.1.1540.127. You've already made a Win2k version of it and it doesn't work with my motherboard :no:


+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
BlackWingCat =^^=
http://blog.livedoor.jp/blackwingcat/
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

#15
tomasz86

tomasz86

    www.windows2000.tk

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,516 posts
  • Joined 27-November 10
  • OS:none specified
  • Country: Country Flag
Yes, I tried every combination possible and the only one working is the one containing 3.1.1540.25 sys file. The inf file doesn't seem to matter at all.

Anyway, I 'fixed' this problem by connecting all hard drives to the PCI-E SAS Controller so I don't need the AMD AHCI drivers anymore.

post-47483-1123010975.png


#16
blackwingcat

blackwingcat

    Friend of MSFN

  • Member
  • PipPipPipPipPip
  • 864 posts
  • Joined 31-May 08
  • OS:Windows 2000 Professional
  • Country: Country Flag
I created Another patches.
Please try Download4: ATI11.3 Set ati1103raid2k.cab (2011/4/22)

Yes, I tried every combination possible and the only one working is the one containing 3.1.1540.25 sys file. The inf file doesn't seem to matter at all.

Anyway, I 'fixed' this problem by connecting all hard drives to the PCI-E SAS Controller so I don't need the AMD AHCI drivers anymore.


+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
BlackWingCat =^^=
http://blog.livedoor.jp/blackwingcat/
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

#17
tomasz86

tomasz86

    www.windows2000.tk

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,516 posts
  • Joined 27-November 10
  • OS:none specified
  • Country: Country Flag
Some time ago I added additional SAS drives and had to connect the SATA HDD to the mainboard build-in controller once again. This time I used the new drivers and... booting is still slow :P although it doesn't freeze for a few seconds as before. I think I'll have to get used to it ;)

Edited by tomasz86, 04 July 2011 - 08:50 AM.

post-47483-1123010975.png





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users