Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 



Sign in to follow this  
gurdziev

ASP & COM+ in IIS7

Recommended Posts

gurdziev    0

Hello all,

I have a problem with an old VB6 COM+ component.

On server 2003 with IIS6 I have that piece of ASP code:

<%@ Language=VBScript %>

<%

dim obj

set obj = server.CreateObject("CPRCalendar.clsCalendar")

Response.Write obj.Display()

set obj = nothing

%>

And everything works fine - it is supposed to generate some HTML and to display it.

Now I'm trying to migrate it to server 2008 R2 x64.

Everything that is related to component services and file system permissions has been set identically to previous server.

But when I browse to this page, the error message I recieve is:

CPRCalendar error '800a000d'

Type mismatch

/ASPcalendar/calendar.asp, line 5

When I turn on the "Enable 32 bit applications" under the application pool advanced settings in IIS,

I recieve a blank page - nothing at all - even when I check the source (via browser "view source" option) - it's just blank!

the most problematic thing is that I don't even have a source code of this VB6 DLL...

Any ideas on what can be checked in order to resolve this situation?

Many thanks in advance.

Share this post


Link to post
Share on other sites

gurdziev    0

What resolved the issue is this one:

• Component Services -> Computers -> My Computer -> COM+ Applications

• Open a COM+ Application object.

• Open Components.

• Right-click on a class and select Properties.

• Under "Advanced" there is a check box for "Allow IIS intrinsic properties".

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×