• Announcements

    • xper

      MSFN Sponsorship and AdBlockers!   07/10/2016

      Dear members, MSFN is made available via subscriptions, donations and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, become a site sponsor and ads will be disabled automatically and by subscribing you get other sponsor benefits.
behdadsoft

problem with Default input Language

14 posts in this topic

I have Windows 7 Ultimate. After installing Windows first language is French, not English.Why should Alt and shift keys to change the language Windows.

I know in windows how this problem can be solved, but I want this problem to be solved before installing Windows.

for add language I used RT7Lite 1.7.0 (Or in other words my Default input Language is French.)

36748354159685609192.jpg

0

Share this post


Link to post
Share on other sites

You have customized Windows 7 SP0 or SP1?

Could you attach your Autounattend.xml file, please!

0

Share this post


Link to post
Share on other sites

Thanks.

I'm just a service pack from one of the sites not remember his name, I download and install it got.

0

Share this post


Link to post
Share on other sites

Unfortunately this link also does not help me.

0

Share this post


Link to post
Share on other sites

You can add inside your Autounattend.xml file:


<settings pass="oobeSystem">
<component name="Microsoft-Windows-International-Core" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<UILanguage>en-US</UILanguage>
<UserLocale>fa-IR</UserLocale>
<InputLocale>0429:00000429</InputLocale>
<SystemLocale>fa-IR</SystemLocale>

And check the file with WSIM.

Edited by myselfidem
0

Share this post


Link to post
Share on other sites

Thanks. I cheked this file with WSIM , but Autounattend.xml Not acceptable.

0

Share this post


Link to post
Share on other sites

Your original Windows 7 is English?

*Edit: When I use your Autounattend.xml with WSIM with the new values, all is OK!


<?xml version="1.0" encoding="utf-8"?>
<unattend xmlns="urn:schemas-microsoft-com:unattend">
<settings pass="windowsPE">
<component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="NonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<SetupUILanguage>
<UILanguage>en-US</UILanguage>
</SetupUILanguage>
<InputLocale>0429:00000429</InputLocale>
<UserLocale>fa-IR</UserLocale>
<UILanguage>en-US</UILanguage>
<SystemLocale>fa-IR</SystemLocale>
</component>
<component name="Microsoft-Windows-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="NonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<ImageInstall>
<OSImage>
<InstallFrom>
<MetaData wcm:action="add">
<Key>/IMAGE/NAME</Key>
<value>Windows 7 ULTIMATE</value>
</MetaData>
</InstallFrom>
<InstallToAvailablePartition>false</InstallToAvailablePartition>
<WillShowUI>OnError</WillShowUI>
</OSImage>
</ImageInstall>
<UserData>
<ProductKey>
<Key>xxxxx-xxxxx-xxxxx-xxxxx-xxxxx</Key>
<WillShowUI>OnError</WillShowUI>
</ProductKey>
<Organization>Behdadsoft</Organization>
<FullName>Behdadsoft</FullName>
<AcceptEula>true</AcceptEula>
</UserData>
</component>
</settings>
<settings pass="oobeSystem">
<component name="Microsoft-Windows-International-Core" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<InputLocale>0429:00000429</InputLocale>
<SystemLocale>fa-IR</SystemLocale>
<UserLocale>fa-IR</UserLocale>
<UILanguage>en-US</UILanguage>
</component>
<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="NonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<UserAccounts>
<LocalAccounts>
<LocalAccount wcm:action="add">
<Name>Behdadsoft</Name>
<Group>Administrators</Group>
<Password>
<PlainText>true</PlainText>
<Value></Value>
</Password>
</LocalAccount>
</LocalAccounts>
</UserAccounts>
<OOBE>
<NetworkLocation>Home</NetworkLocation>
<HideEULAPage>true</HideEULAPage>
<ProtectYourPC>1</ProtectYourPC>
<HideWirelessSetupInOOBE>true</HideWirelessSetupInOOBE>
</OOBE>
<DisableAutoDaylightTimeSet>true</DisableAutoDaylightTimeSet>
<TimeZone>Iran Standard Time</TimeZone>
<Display>
<ColorDepth>32</ColorDepth>
<HorizontalResolution>1024</HorizontalResolution>
<VerticalResolution>768</VerticalResolution>
<RefreshRate>60</RefreshRate>
</Display>
</component>
</settings>
<settings pass="specialize">
<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="NonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<ComputerName>Novin_Pendar</ComputerName>
</component>
<component name="Microsoft-Windows-Security-SPP-UX" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="NonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<SkipAutoActivation>true</SkipAutoActivation>
</component>
</settings>
</unattend>

Edited by myselfidem
0

Share this post


Link to post
Share on other sites

I solved the problem. I'll test it and give you poor thing.

0

Share this post


Link to post
Share on other sites

By adding this code will not cause any changes and still my default input language is Persian .

0

Share this post


Link to post
Share on other sites

When Windows is installed in Persian and English languages ​​exist in taskbar , and my default input language is English.

0

Share this post


Link to post
Share on other sites

You can find help here: my post #57

http://www.msfn.org/...se/page__st__40

Unattended Windows Setup Refernce for Windows 7

Values

Input_Locale

Specifies the input language and keyboard layout for a Windows installation.

Input_locale can be one of two values:

  • To use the default input locale for a language, you can specify the language identifier. For example, to use the default keyboard for English (United States) that corresponds with the QWERTY keyboard, you can specify the value en-US.
  • Specify the locale ID and keyboard layout hexadecimal values. For example,
    for en-US, use 0409:00000409. The first value (0409) is the locale ID that represents the input language and the second value (00000409) is the keyboard layout value.

If you want to specify more than one input locale to add support for more than one keyboard type, you can specify multiple values separated by semicolons.

For example, you can specify:

<InputLocale>en-US; fr-FR; es-ES</InputLocale>

to add support for English (US), French (France), and Spanish (Spain) keyboards. The first value listed is used as the default keyboard.

The valid keyboard layouts that can be configured on your system are listed in the following registry key. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Keyboard Layouts

For a list of the default input locale values, see Supported Language Packs and Default Settings.

Example (choose the one you needs!):

<InputLocale>0429:00000429;040c:0000040c;0409:00000409</InputLocale>

Edited by myselfidem
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.