Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 

Recommended Posts

condor    4

Hy again,

It is an option in WPI to wait 10-20 sec after X program was installed then to start command from the next program? I try in the last 4 days to make my own XP kit with post-installed applications. The switch command are OK because I have tested in CMD and work. For example you can`t install adobe reader if it is open another installation from another software. I search on net, here, wpi manual but nothing found. What I want to do in WPI is:

Example

1. program A

2. program B

3. program C

I want something this in WPI.

program A

command1----succes

wait 10-20 sec

program B

command1----succes

wait 10-20 sec

program C

command1 ---succes

Every time when I test my XP kit I get one or two application failed because WPI who don`t know to wait after program is installed. I reordered application but nothing good. Any help?

Tks

Edited by condor

Share this post


Link to post
Share on other sites
condor    4

Isn`t only adobe, sometime fail skype. Last time ai tested with ccleaner and one xp language pack and she wast last from list. Ccleaner was installed successuful but language pack not and give me this error:

Friday, April 15, 2011 1:40:32 PM - cmd1 Success (returned code 0): "D:\wpi\Install\Software\ccsetup305.exe" /S

Friday, April 15, 2011 1:40:32 PM - Finished installation.

Friday, April 15, 2011 1:40:38 PM - cmd1 *** Fail *** (returned code 1618): "D:\wpi\Install\LanguagePack\LIPSETUP.MSI" /quiet /norestart

Friday, April 15, 2011 1:40:38 PM - Finished installation.

Searching by error code I found this:

http://support.microsoft.com/kb/229683

Another installation is already in progress. Complete that installation before proceeding with this install.

Edited by condor

Share this post


Link to post
Share on other sites
myselfidem    5

With some msi files I use successfully with WPI (example):

['msiexec.exe /i "%wpipath%\\Install\\Shrink\\dvdshrink2007.msi" /qn']

Edited by myselfidem

Share this post


Link to post
Share on other sites
myselfidem    5

About LIPSetup.msi:

Write maually inside: Configuration | Add:

msiexec.exe /i "%wpipath%\Install\LIP\LIPSetup.msi" /qn

The command will be writed by WPI (inside config.js):

['msiexec.exe /i "%wpipath%\\Install\\LIP\\LIPSetup.msi" /qn'] 

Edited by myselfidem

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×