herbalist

Tor-Vidalia with KeX on Win 9x/ME

36 posts in this topic

Nice selection of tools. Thanks.

Mijzelf

According to that article, I'm set much higher than I should be at 512 but have not seen any instability. Lowering "TcpTimedWaitDelay" to 30 might be one reason. The errors have never returned. I have to believe the unofficial upgrades, primarily Revolutions Pack made that possible. I'm also wondering how much effect selecting "network server" in file system properties has here. Never took the time to check what it changes. This instance of Tor has run for 17 days now, still seems fine. Total uptime has reached 3 weeks. Both the available RAM and GDI resources have gone back up some.

I still wonder why the error messages both ended with "Not enough ram?" when MemLoad showed that I had RAM available. It also has me asking if stronger hardware would help here?

Looking at the other Dell with 2GB RAM and a 2.6GHZ P4 sitting next to this unit, wondering if the other half would notice if I swapped hardware with her.

Edited by herbalist
0

Share this post


Link to post
Share on other sites

I haven't had the chance to verify it, but I think I've found one of the items draining the RAM and/or resources. I'd forgotten that I had Kerio firewall set to log outbound Tor traffic. Needless to say, the log had become quite large. Deleting the log gave me back 25MB of RAM and available GDI resources went up 8%. The odd part here is that the decrease in RAM usage didn't show up in any of the processes listed in MemLoad but does show in in the free physical memory.

0

Share this post


Link to post
Share on other sites

After finding the issue with Kerio logs and RAM usage, I started looking for other processes that were consuming resources and RAM, shutting them down and restarting them. When I shut down SSM, available GDI resources went up to 80%. They remained there after I restarted SSM, but the system had become unstable and eventually crashed. The majority of the errors pointed to user32.dll and were general protection faults.

0

Share this post


Link to post
Share on other sites

As far as I can determine, the last crash was due to a conflict between System Safety Monitor and the latest version of Kernel Ex. Keeping these 2 compatible with each other has been problematic with Kernel Ex adding and modifying APIs and SSM hooking the same APIs. The Kernel Ex settings for the 2 primary SSM components, SysSafe.exe and mchook9x.dll, greatly affect how they interact and SSM's ability to function. This conflict appeared to be resolved with Kex 4.0 but looks to have reappeared with 4.5.2. For the moment I've left the Kex settings for mchook9x.dll on default and disabled Kex for SysSafe.exe with the "Don't use these settings in child processes" option checked.

For the most part, the gradual depletion of resources does not appear to be related to Tor, but the steady increase in RAM usage does. Before I do any more with Tor, I need to sort through the SSM-Kex interactions and determine why it resulted in so much resource depletion. While not directly related to running Tor on 98, I also need to determine how the different Kex settings for the 2 SSM components affect its ability to defend a Kex modified system. With more governments and entertainment industry watchdogs regarding Tor as a threat to their authority and/or profits, the possibility of Tor exit nodes being targeted for attack is increasing. While Kernel Ex is doing wonders for making 98 a viable system that can run todays software, its effects on 98 in regards to its vulnerability to exploits in user applications and the ability to defend against them is unexplored territory.

0

Share this post


Link to post
Share on other sites

I was very unsatisfied with webproxy sites (accessed pages either don't work or links escape from the webproxy's sandbox and switch back to unprotected URLs), so I just downloaded the Tor-Vidalia bundle and tried to install it on Win98SE with KernelEx 4.5.101.

I only want to use it as a client but Vidalia 0.2.17 refuses to work and shows wrong paths (from generic English Windows, mine is German and on E: ), and worse, once I correct these by hand, it won't save them but shows the same wrong paths after every restart. When Vidalia attempts to start tor, the screen always switches into DOS text mode and exits with errors. I tried to start tor manually from a DOS box (which works only when online and loaded 10 minutes to build the "circuit" on my analogue modem), but the Tor-Button on Firefox 3.6.22 only shows a proxy error even when tor.exe in a DOS box is running. When I tried to manually start Vidalia, it requests a password to connect to the running tor process, despite I had set none. What is wrong here?

I then found out that Vidalia can only be started with an argument pointing to its data directory, which (strange enough) works only with DOS file names due to quotation mark problems. So my link has this form:

"E:\Programme\Vidalia Bundle\Vidalia\vidalia.exe" -datadir "E:\PROGRA~1\VIDALI~1\Vidalia"

So Vidalia now can save entered data, but it still refuses to keep tor running. In its debug.log I found the following error message:

Apr 14 02:25:15.630 [debug] connection_handle_write_impl(): After TLS write of 512: 0 read, 586 written
Apr 14 02:25:16.070 [warn] Error "Die Zugriffsnummer ist nicht definiert.

" occurred while polling handle for monitored process 2147483647; assuming it's dead.
Apr 14 02:25:16.070 [notice] Monitored process 2147483647 is dead.
Apr 14 02:25:16.070 [notice] Owning controller process has vanished -- exiting now.

Apparently a connection handle(?) is undefined, causing tor.exe to exit after some seconds when started by Vidalia.

- Is it possible at all to properly use Vidalia/Tor on Win98SE with analogue modem?

Edited by CyberyogiCoWindler
0

Share this post


Link to post
Share on other sites

Starting in version 0.2.16, Vidalia uses a different location for its data directory.

From the changelog:

Make the default data directory in windows be located in the Local

AppData instead of the Roaming one. Fixes bug 2319.

On my system, when Vidalia .2.17 starts, it creates C:\application data\vidalia and no longer uses /windows/application data/vidalia. It appears other data and config file locations have also changed. Some of the paths are not found on 98 units. So far, I haven't managed to get Vidalia .2.17 to work properly. Vidalia has been something of a problem on 98, even when it did work. Version 0.2.15 works fairly well. If you really want Vidalia, try that version. I stopped using Vidalia. IMO, it's more trouble than it's worth. For all purposes, Vidalia is nothing more than a GUI, log reader, and configuration file editor for Tor. On 98, the Vidalia network map is unreliable, works part time. For the message log data, Tor can just as easily send that data to file.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.