• Announcements

    • xper

      MSFN Sponsorship and AdBlockers!   07/10/2016

      Dear members, MSFN is made available via subscriptions, donations and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, become a site sponsor and ads will be disabled automatically and by subscribing you get other sponsor benefits.
Sign in to follow this  
Followers 0
engjcowi

My first website design

3 posts in this topic

Hey guys just thought id show you my first website design. Its not an IT related website but i was very happy at the setup. Please comment if you like :)

www.lifesupportmedics.com

thanks

jamie

p.s im setting up a tech blog shortly too :)

0

Share this post


Link to post
Share on other sites

Oh boy are you in for it now!

:w00t:

Website, just looking at it

- it seems your entire top div is a link back to the home page, but it is designed to look like it is in different pieces. You may not necessarily need to have the "home page" part of the picture up top.

- you should put a text based shortcut menu in the footer that has Home | the other top level menu choices.

- the contact us/courses/links boxes bottom borders align differently in relation to the line in the background image differently on each page.

- the picture on the About Us page should have a background that matches the page content color. Same with the gear in the Courses box. In fact a lot of images are like this.

- the social networking icons are larger than your top level menu options, meaning the viewers focus will gravitate towards them.

- the three contact images on the Contact Us form do not match the overall color/design scheme of the site.

- the hover color of the "head office" link on the bottom is too similar to the background color on the gradient.

- Your copyright says 2010...

- on some pages, the Links box at the bottom has a picture in it.

Website, behind the scenes

- Google Analytics code should be at the bottom of the document and not the top. You can find best use instructions on your GA account.

- Tables are for tables not for layout! :no:

- you have mixed case in some attributes, and use full URI for some and not others. Example:

<p><a href="www.hse.gov.uk" title="HSE">www.hse.gov.uk</a></p>
<p><A href="http://www.ilcor.org/" target="_blank">www.ilcor.org/</A>

- your CSS validates, which is great, but your HTML has no Doctype.

- you are specifying attribute tags for objects that do not support them, such as Marginwidth, MarginHeight, etc.

- Your code is closest to HTML 4.01 Transitional. Add this as your Doctype, and adjust your code appropriately if you want that part to be good. It is fine to make coding sacrifices of course, for example on my own site, I'm not overly concerned about having ALT tags for every image or specifying an encoding type.

forum

- the logo on your forum does not match your website.

- the design and colorscheme of the forum does not match the website

- the forum #1 user is Admin. This is bad. Always set to hide the Admin account. Then your second user is a Global Mod and is your everyday use account.

- not sure why all the forum hovers say Merry Christmas on them... :blink:

summary

It looks fine and is likely to be functional for what it is designed for. Nothing really glaring except for the GA placement. I also didn't bother testing your contact form. You want to make sure that is sanitized and secure since it is a direct source into your webserver. In the end, this looks like a run of the mill business website, which isn't a knock against you since it is your first website. Heck my first website looked like everyone else's too. That's just how you start.

0

Share this post


Link to post
Share on other sites

Hi Guys

I want to thank you so much for your feedback. There are awesome point for improvement!! Im still learning but the stated points are allowing me to go away and learn each respectively and gain a greater understanding as my knowledge is basic at the moment.

Again thank you for taking the time and effort to look and point me in the right direction.

Jamie :)

p.s the forum i just happended to google free forum and it came up. The graphic was the only 1 i had available at the time but i can sort and update now and i have no idea why it says happy christmas. that was already there when the forum was set up lol. Ill have a look and try to remove

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.