Kelsenellenelvian

WPI Bug Report Thread

210 posts in this topic

Thank you for the new release 8.2.0.

I have updated WPI 8.1.0 to 8.2.0.

When I add some new programs from CONFIG, and then I try to find a silent switch using the magnifier icon at the right side of the window, I got different errors.

The errors are depending on the kind of setup packages which I mentioned on attached images.

I tested four different packages which I added in previous versions of WPI without any error messages.

USS-Error-01 is for RAR SIlent packages which I made for installing firefox.

USS-Error-02 is for MSI setup package which I used before for installing ESET Smart Security.

USS-Error-03 is for Inno setup packages.

USS-Error-04 error occurs when I have added two commands instead of one command at a time. I hope to see an error which tells me my mistake but it says:

Could not open TEMP directory.

I use Windows XP SP3 X86 and IE 7.0.5730.11

Anyone else has these errors when adding new programs?

post-154125-0-02007700-1306971945_thumb.

post-154125-0-44048900-1306971999_thumb.

post-154125-0-40308400-1306972038_thumb.

post-154125-0-00578600-1306972070_thumb.

Edited by ghaffar
0

Share this post


Link to post
Share on other sites

Hello,

I updated WPI 8.1 to 8.2 it looks more accurate. (I copy from 8.1 to 8.2 config.js; useroptions.js and windowoptions.js).

The only problem I've with WPI 8.2 is 2 screens overlaped.

In fact my WPI consist of 4 screens of prog to install. When WPI start, everything goes fine. Few minutes later screen 3 and 4 become overlaped and can't check or uncheck any prog to install (see image bellow).

I'll appreciate any help

post-11791-0-89884200-1307047082_thumb.jpg

0

Share this post


Link to post
Share on other sites

Finally I got success fixing the overlap screens, by modifying the SortOrder at the top of config.sys file :thumbup

SortOrder=[1111,'222,'333,'...];

Still I can't explain why v8.1 I haven't overlap screens :whistle:

Regards

0

Share this post


Link to post
Share on other sites

@coucou

Happy to see you have found a solution!

You can also use with WPI inside Options\Tools: Script or program to execute after the installation is complete: cleanup.exe (select the path where is located your exe file).

Edited by myselfidem
0

Share this post


Link to post
Share on other sites

@coucou

Happy to see you have found a solution!

You can also use with WPI inside Options\Tools: Script or program to execute after the installation is complete: cleanup.exe (select the path where is located your exe file).

Yes I know ;)

My cleanup.exe (config.js ordr 999) have to do with the Start/Al Programs/Shortcuts... (settle, sort, copy, delete... à mon goût) . As some peopple don't like that settle, sort... i gave the opportunity to install it or not.

Still I can't explain why v8.1 I haven't overlap screens :whistle:

Regards

Edited by coucou
0

Share this post


Link to post
Share on other sites

Finally I got success fixing the overlap screens, by modifying the SortOrder at the top of config.sys file

SortOrder=[1111,'222,'333,'...];

OK. Nice!

I think you mean config.js and not config.sys!!

0

Share this post


Link to post
Share on other sites

With WPI 8.2.0, I have the same error than ghaffar about script error inside:

configwizard_ussf.js:

line 69 character 3 => The property value for "sprintf" is null or undefined

And the silent switch isn't writed inside the command line.

But works perfectly with WPI 8.1.0

Thanks

Edited by myselfidem
0

Share this post


Link to post
Share on other sites

Arg. That was my bad. I sent Kel a new archive to replace on the site. Download a new copy when he posts about it here.

0

Share this post


Link to post
Share on other sites

Many thanks mritter ;)

*Edit:

It's not a bug...But I see inside the file lang_en.js the same line (twice):

line 622 => lblPointingDevice[lang] = ['Pointing Device'];

line 623 => lblPointingDevice[lang] = ['Pointing Device'];

Is that correct?

Thanks

Edited by myselfidem
0

Share this post


Link to post
Share on other sites

It also happends an error inside aboutupdate.js

line 267 character 2: "split" null object or undefined

Can't know if an update is available.

Thanks

Edited by myselfidem
0

Share this post


Link to post
Share on other sites

Thank you very much Kels for the new WPI version 8.2.1 :thumbup

And for the nice options added!

Exellent program!

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.