Kelsenellenelvian

WPI Bug Report Thread

210 posts in this topic

Sorry, but why I found on the parent directory WPI_v8.5.7.rar ?

http://www.wpiw.net/downloads/

The archive have been removed now...But I can send you this archive if you want!

Very Strange.

Regards

Edited by myselfidem
0

Share this post


Link to post
Share on other sites

(Canceled the archive during upload)

I am used to making rar ones and autopilot made one. I forgot to delete the canceled one after uploading the zip.

0

Share this post


Link to post
Share on other sites

I have always a black screen after the installation is done and I must restart the computer to have Windows working!

Could you add more space for the text inside the tooltips box please? There is not enough space for french text like there is inside the right pane!

Thanks

Edited by myselfidem
0

Share this post


Link to post
Share on other sites

To solve the problem with the reboot with WPI 8.5.7

I do like this. I set inside core.js


function DeleteAllRegKeys()
{
position="core.js";
whatfunc="DeleteAllRegKeys()";

// Just in case. Don't want to have a restart of WPI for no reason
DeleteRegKey("HKEY_LOCAL_MACHINE\\Software\\Microsoft\\Windows\\CurrentVersion\\RunOnce\\WPIresume");
DeleteRegKey("HKEY_LOCAL_MACHINE\\Software\\Microsoft\\Windows\\CurrentVersion\\RunOnceEx\\001\\1");
DeleteRegKey("HKEY_LOCAL_MACHINE\\Software\\Microsoft\\Windows\\CurrentVersion\\RunOnceEx\\001\\");

I set inside installer.js (line 198) (this reg file is writed also at line 456)

WriteRegKey("HKEY_LOCAL_MACHINE\\Software\\Microsoft\\Windows\\CurrentVersion\\RunOnce\\WPIresume",sysdir+'\\mshta.exe "'+wpipath+'\\Common\\Installer.hta"',"REG_SZ");

Using the fix given here:

http://www.msfn.org/...ost__p__1006639

Removing also inside global_lang.js

var optFloat=[], 

However after the installation is done, when Windows restarts there is a very long time a black screen (almost 4 minutes) before Windows starts!

Regards

*Edit: When I select inside Options | Features: MaintainAutoLogonCount=true;

This isn't applied and I don't see this option inside WPI_Log.txt. And I don't see this value inside installer_log.js (I added and works, now).

Edited by myselfidem
0

Share this post


Link to post
Share on other sites

Got the reg entries fixed again.

Also about your txt request. (The theme wizard) the area is already coded to resize according to the amount of txt the lang file has in that entry.

Looking for the logon count thing now. Added to the log file now.

Edited by Kelsenellenelvian
0

Share this post


Link to post
Share on other sites

Hi..

WPI_v8.5.7..

Sorry to tell Kelsenellenelvian,but still no music.

If you will save time.and noboby have this problem.but only me.

I think it's not needed to search for the problem,It work great if i use C:\Audio.

The Audio map is easy to remove with little script.

I'am happy with it..so many thx for try to fix this problem.maby you find it latere days^^.

Grt Whatsup

0

Share this post


Link to post
Share on other sites

When I apply all changes given above - with WPI 8.5.6 or WPI 8.5.7 - all is fine if I don't select Audio Player! (20 seconds to restart Windows 7).

The problem seems to be using Audio Player during installation programs (almost 4 minutes to restart and shutdown the first time the OS).

And stop the sound doesn't work!

Regards

Edited by myselfidem
0

Share this post


Link to post
Share on other sites

HI..

[myselfidem].

(almost 4 minutes to restart and shutdown the first time the OS).

Did you made this settings manual or in WPI option menu??

If you do it manual,the settings [music] will not been placed in Install.m3u file in Audio folder.

So you most work in the WPI option menu!!!

Sorry if i'am wrong with your steps..

Thank you for the small test,..But I do not have the same problem that you describe.

============================================================================================================

I have no trouble with restart or shutdown the Pc..all is fine here.

You select music player start from CD/DVD/USB .that work fine by me!!.

Can you test this one time for me??!!..

If you let the Audio first copy to your Hard Drive!!!!...

will your music now start???

here only if i make it C:\Audio.in WPI option menu.

The settings [music] in Install.m3u file,

Are the same when you do %systemdrive%\Audio or C:\Audio

In both case is it C:\Audio\01.mp3 but the music wil only start by C:\Audio.

useroptions.js does like this.

CopyAudioPath=['%systemdrive%\\Audio']; didn't work for me.

CopyAudioPath=['C:\\Audio']; Work fine here..

Thx and Greatings^^

0

Share this post


Link to post
Share on other sites

In fact to be more clear, I selected Audio Player with only the installer ( selecting: Shuffle) choosing 3 or 4 music inside: .\WPI\Audio\

All selction made with WPI and not manual!

All works fine and Audio Player works inside the installer exept to stop the sound!

But like I said, when Windows restarts there is a black screen during 4 minutes and there is an error: Connection service failure, Event system...

And to restart the OS I must wait 4 minutes... After all is OK.

But all is fine without using Audio Player inside the installer and applying the changes given above! (20 secondes to restart the OS).

I tried to copy a folder but I made something wrong, no success at this time...Maybe it's needed to create a folder inside WPI and this one will be copied !

HTH

*Edit: But if remeber and if I understand you have a warning pop-up using the path: C:\Audio ?

Edited by myselfidem
0

Share this post


Link to post
Share on other sites

*Edit: But if remeber and if I understand you have a warning pop-up using the path: C:\Audio ?

Yep... If WPI is ready/finis with installing his software,then the Audio folder most been removed.then i have a Waring.

But WPi close just normal his installer window.and restart fine in about 30sec ,thats the time i put in for restart.

0

Share this post


Link to post
Share on other sites

I will try tomorrow to copy the music file on the HDD and I give you the result.

0

Share this post


Link to post
Share on other sites

I will try tomorrow to copy the music file on the HDD and I give you the result.

Oke Thank you^^....i most work tomorrow,so read it late time 17:00 i'am back i hope^^..

Thx alot myselfidem.till then..sleep well.bye

0

Share this post


Link to post
Share on other sites

Tried to copy Audio using : %systemdrive%\Audio

And all the WPI\Audio folder is copied on the HDD successfully.

But the file install.m3u seems not working with Media Player...I will try another music! This music file need to be converted to use with Media Player!

About m3u files and Media Player:

http://en.wikipedia.org/wiki/M3U

*Edit:

You are right, after a new test using %systemdrive%\Audio

the folder Audio is copied and also removed - but doesn't work. No music are displayed.

rb_config.js


// WPI Reboot Configuration File
// Install process started at: lundi 20 août 2012 09:31:37

prb=0;

programs[prb]=new program(prb);
programs[prb].prog=['Copie du dossier audio sur le disque dur'];
programs[prb].uid=['COPY_AUDIO_TO_HD'];
programs[prb].ordr=[0];
programs[prb].bit64=['no'];
programs[prb].cat=['WPI Built In'];
programs[prb].cmds=['{DIRCOPY} D:\\wpi\\Audio %systemdrive%\\Audio'];
prb++

programs[prb]=new program(prb);
programs[prb].prog=['Execute After'];
programs[prb].uid=['EXECUTE_AFTER'];
programs[prb].ordr=[0];
programs[prb].bit64=['no'];
programs[prb].cat=['WPI Built In'];
programs[prb].cmds=['"%systemdrive%\\Windows\\SETUP\\SCRIPTS\\clean.vbs"'];
prb++;

programs[prb]=new program(prb);
programs[prb].prog=['Suppression du dossier audio sur le disque dur'];
programs[prb].uid=['DELETE_AUDIO_FROM_HD'];
programs[prb].ordr=[0];
programs[prb].bit64=['no'];
programs[prb].cat=['WPI Built In'];
programs[prb].cmds=['{DELDIR} %systemdrive%\\Audio'];
prb++;

Using: C:\Audio to copy on the HDD works and no warning pop-up without using install.m3u

But Windows needs time to restart when I install only some programs with the music inside the installer!

*Edit 2: After a new test. All works fine using the path C:\Audio. Shuffle works and the folder is removed at the end of the installation. But do not select Install.m3u music.

WPI_Log.txt


Fichier journal de l'installation WPI

Début de l'installation: lundi 20 août 2012 08:22:48

Information WPI:
Version=8.5.7
Exécutable utilisé=true
Version d'Internet Explorer=9.0

Connexion Internet=false

Système d'exploitation
Système d'exploitation=Not found
ID Edition=Not found
Service Pack=1

Architecture
Nom de l'Architecture=GenuineIntel
Chaîne du Nom de l'Architecture=Intel(R) Core(TM) i5 CPU 650 @ 3.20GHz
ID Architecture=x86 Family 6 Model 37 Stepping 2
Nombre de Processeurs=1
MHz=3066
Type d'Architecture=x86
Bits Architecture=32

Fichier Options=D:\wpi\UserFiles\useroptions.js
Fichier Configuration=D:\wpi\UserFiles\config.js
Fichier Réseau=D:\wpi\UserFiles\networkoptions.js

// Window tab
Resolution=0
MainWindowWidth=800
MainWindowHeight=600
MainWindowX=-1
MainWindowY=-1
InstallerWindowX=25
InstallerWindowY=25

// General tab
NumCols=2
// ---
Timer=true
Seconds=4
StartBeepAtSecs=10
// ---
Language='fr'
// ---
DefaultInstallPath='%wpipath%'
CustomInstallPath=['']
// ---
AbortInstallIfFailure=true
ExecuteCommandIfFailure=['']
ContinueWhereFailed=false

// Features tab
ShowExtraButtons=true
DoNotShowIfCD=true
USSFSilentMode=false
VerifyInstallHDD=false
AllowCheckForInternet=false
LoadDesktopBeforeInstall=true
ReOpenAfterInstall=false
DisableCatCheckBoxes=false
SortWithinCats=false
DisableOnDepsNotMet=true
AlwaysUseScrollBar=true
DontSplitCats=false
InstallByCategory=false
ReallyForce=false
DisableIfDoGray=false
InstallFonts=true
ShowCommandInInstaller=false
ShowInstallerImages=true
AlwaysShowOutputWindow=false
EjectCDWhenDone=false
DoNotShowIfUSB=true
DisableHotKeys=false
MaintainAutoLogonCount=true

// Tools tab
MonitorResolution=0
MonitorDepth=0
MonitorRefresh=0
// ---
ExecuteBeforeEnabled=false
ExecuteBeforebit64=false
ExecuteBefore=['']
ExecuteAfterEnabled=true
ExecuteAfterbit64=false
ExecuteAfter=['"%systemdrive%\Windows\SETUP\SCRIPTS\clean.vbs"']
// ---
RestartComputer=false
RestartType=0
RestartSeconds=0
DoNotLoadDesktop=false
// ---
LogInstallation=true
LogPath=['%temp%\WPI_Log.txt'];
TimeStampLogFile=true

// Audio tab
PlayAudioInInstaller=true
InstallAudio=['Galaga.mid,Jingle.mid,Space.mid']
Volume=75
Shuffle=true
CopyAudioFolder=true
CopyAudioPath=['C:\Audio']
DeleteAudioFolder=true

// Sounds tab
SndWPIStartCB=true
SndWPIStart=['"%wpipath%\Audio\SoundsScheme\Alert.wav"'];
SndInstallStartCB=false
SndInstallStart=['"%wpipath%\Audio\SoundsScheme\AtBeginning.wav"'];
SndInstallSuccessCB=false
SndInstallSuccess=['"%wpipath%\Audio\SoundsScheme\Yes.wav"'];
SndInstallFailCB=false
SndInstallFail=['"%wpipath%\Audio\SoundsScheme\No.wav"'];
SndInstallFinishCB=false
SndInstallFinish=['"%wpipath%\Audio\SoundsScheme\AtEnd.wav"'];

// Style tab
Theme='Win7'
Skin='SkyBlue'
BgPicture='Wallpaper.png'
// ---
LayoutStyle=2
// ---
ShowToolTips=false

Variables Globales:
%OSLANG%=
%WPIPATH%=D:\wpi
%ROOT%=D:
%CDROM%=D:
USB=
%DOSPATH%=
%SYSTEMDRIVE%=C:
%WINDIR%=C:\Windows
%PROGRAMFILES%=C:\Program Files
%TEMP%=C:\Users\Antoine\AppData\Local\Temp
%SYSDIR%=C:\Windows\System32
%ALLUSERSPROFILE%=C:\ProgramData
%USERPROFILE%=C:\Users\Antoine
%APPDATA%=C:\Users\Antoine\AppData\Roaming
%COMMONPROGRAMFILES%=C:\Program Files\Common Files

Liste des programmes à installer:
Copie du dossier audio sur le disque dur
Adobe Reader 10.1.3
Firefox 14.0.1
Java 7u4
Flash Player 11 ActiveX
Flash Player 11 Plugin
Execute After
Suppression du dossier audio sur le disque dur

8 Eléments, 9 Commandes

-----

lundi 20 août 2012 08:22:55
Programme: Copie du dossier audio sur le disque dur
ID unique: COPY_AUDIO_TO_HD
Ordre: 0
Catégorie: WPI Built In
lundi 20 août 2012 08:22:56 - cmd1 Succès (Code de retour 0): CMD /C XCOPY D:\wpi\Audio C:\Audio /C /I /E /Y /H /R
lundi 20 août 2012 08:22:56 - Installation terminée.

-----

lundi 20 août 2012 08:22:56
Programme: Adobe Reader 10.1.3
ID unique: ADOBEREADER1013
Ordre: 000006
Catégorie: Applications
lundi 20 août 2012 08:24:25 - cmd1 Succès (Code de retour 0): "D:\wpi\Install\Adobe\AdbeRdr1013_fr_FR.exe" /sAll /rs
lundi 20 août 2012 08:24:26 - cmd2 Succès (Code de retour 0): "RegEdit" /S "D:\wpi\Install\Adobe\Adobe.reg"
lundi 20 août 2012 08:24:27 - Installation terminée.

-----

lundi 20 août 2012 08:24:27
Programme: Firefox 14.0.1
ID unique: FIREFOX1401
Ordre: 000007
Catégorie: Applications
lundi 20 août 2012 08:24:37 - cmd1 Succès (Code de retour 0): "D:\wpi\Install\Firefox\Firefox14.0.1.exe" -ms
lundi 20 août 2012 08:24:39 - Installation terminée.

-----

lundi 20 août 2012 08:24:39
Programme: Java 7u4
ID unique: JAVA7U4
Ordre: 000008
Catégorie: Applications
lundi 20 août 2012 08:25:33 - cmd1 Succès (Code de retour 0): "D:\wpi\Install\Java\Java7u4.exe"
lundi 20 août 2012 08:25:35 - Installation terminée.

-----

lundi 20 août 2012 08:25:35
Programme: Flash Player 11 ActiveX
ID unique: FLASHPLAYER11ACTIVEX
Ordre: 000009
Catégorie: Applications
lundi 20 août 2012 08:25:54 - cmd1 Succès (Code de retour 0): "D:\wpi\Install\FlashPlayer\install_flash_player_11_active_x.exe" -install
lundi 20 août 2012 08:25:55 - Installation terminée.

-----

lundi 20 août 2012 08:25:55
Programme: Flash Player 11 Plugin
ID unique: FLASHPLAYER11PLUGIN
Ordre: 000010
Catégorie: Applications
lundi 20 août 2012 08:26:15 - cmd1 Succès (Code de retour 0): "D:\wpi\Install\FlashPlayer\install_flash_player_11_plugin.exe" -install
lundi 20 août 2012 08:26:16 - Installation terminée.

-----

lundi 20 août 2012 08:26:16
Programme: Execute After
ID unique: EXECUTE_AFTER
Ordre: 0
Catégorie: WPI Built In
lundi 20 août 2012 08:26:27 - cmd1 Succès (Code de retour 0): "C:\Windows\SETUP\SCRIPTS\clean.vbs"
lundi 20 août 2012 08:26:29 - Installation terminée.

-----

lundi 20 août 2012 08:26:31
Programme: Suppression du dossier audio sur le disque dur
ID unique: DELETE_AUDIO_FROM_HD
Ordre: 0
Catégorie: WPI Built In
lundi 20 août 2012 08:26:33 - cmd1 Succès (Code de retour 0): CMD /C RD /S /Q C:\Audio
lundi 20 août 2012 08:26:35 - Installation terminée.

-----

Nombre d'installations échouées: 0

Installation terminée: lundi 20 août 2012 08:26:36

Edited by myselfidem
0

Share this post


Link to post
Share on other sites

Adding inside informations.js

ConditionsGrid.addRow(gId++,'getOSvernum()=="'+getOSvernum()+'"');

works fine!

And this can be also added to My Computer! (inside lang_en.js; global_lang.js; information.js). Example.

MyComputerGrid.addRow(gId++,getText(lblOSvernumber)+','+getOSvernum()+'');

And inside installer_log.js

WriteLogLinePlain("   "+getText(lblOSvernumber)+"="+getOSvernum());

Regards

*Edit: missing inside installer_log.js


// Features tab

WriteLogLinePlain(" ShowDownloadOutput=" + ShowDownloadOutput);
WriteLogLinePlain(" DisableInstallCombobox=" + DisableInstallCombobox);

Edited by myselfidem
0

Share this post


Link to post
Share on other sites

HI..

Thanks a lot myselfidem for your test time!!!..

CopyAudioPath=['C:\\Audio'];

Only in my case,If i set DeleteAudioFolder=true; [Warning popup] see below.

The Audio folder is empty,all files are removed.

but the Audio folder himself is not removed.

If i set DeleteAudioFolder=false; ofcourse then there is no Warning.

But i most remove Audio folder and files with little script.

warninghs.png

I hoop the image is visible...

Again myselfidem thx alot ^^

Grt Whatsup

Edited by Whatsup
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.