Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 



Recommended Posts

Some informations aren't displayed inside information Computer boxe.

It seems it's not possible with java script?

It is possible to add a .vbs script like this one inside WPI to give these informations!

Information.vbs


' get OSVersion and OSLanguage

strComputer = "."
Dim Act, ComputerReport, Fso, Dtop, Ts
Set Act = CreateObject("Wscript.Shell")
Set Fso = CreateObject("Scripting.FileSystemObject")
Dtop = Act.SpecialFolders("Desktop")
Set Ts = Fso.CreateTextFile(Dtop & "\ComputerReport.txt")
Set objWMIService = GetObject("winmgmts:" _
& "{impersonationLevel=impersonate}!\\" & strComputer & "\root\cimv2")

Set colOperatingSystems = objWMIService.ExecQuery _
("Select * from Win32_OperatingSystem")

For Each objOperatingSystem in colOperatingSystems
MfgHex=""
For i=1 To Len(objOperatingSystem.Caption)
MfgHex=MfgHex & Hex(Asc(Mid(objOperatingSystem.Caption,i,1)))
If i Mod 4 = 0 then MfgHex=MfgHex & " "
Next
ComputerReport = (space(2) & "Caption: " & objOperatingSystem.Caption & vbCrLf &_
space(2) & "Version: " & objOperatingSystem.Version & vbCrLf &_
space(2) & "OSLanguage: " & objOperatingSystem.OSLanguage & vbCrLf)
Next
Ts.WriteLine ComputerReport : Ts.Close
Act.Run(Chr(34)& Dtop & "\ComputerReport.txt" & Chr(34)),1,True

Here is the result on my Desktop:

Caption: Microsoft Windows 7 Édition Intégrale

Version: 6.1.7601

OSLanguage: 1036

Image Information

Btw, I made a new lang_fr.js, because two tabs needed shorter words.

Thank you very much!

Edited by myselfidem

Share this post


Link to post
Share on other sites

hello, my problem is that the AtEnd.wav not being played

i have correct the line 886 of installer.js from SndInstallFinshCB to SndInstallFinishCB (notice the missing "i") but no luck...

Share this post


Link to post
Share on other sites

OK! found a workaround...

cut the IF block at line 886 (i used notepad++) into file installer.js


if (RegKeyValue("HKEY_CURRENT_USER\\Software\\WPI\\SndInstallFinishCB"))
{
document.getElementById("MediaPlayer").controls.stop();
document.getElementById("MediaPlayer").url="";
PlaySound(RegKeyValue("HKEY_CURRENT_USER\\Software\\WPI\\SndInstallFinish"));
}
Pause(3,0);

and paste it at line 856 and now WORKS!

the problem is generated by this: DeleteAllRegKeys();

	if (!UserAborted && !ReturnCodeReboot)
{
DeleteRebootFile();
DeleteHistoryFile();

RestartComputer=RegKeyValue("HKEY_CURRENT_USER\\Software\\WPI\\RestartComputer");
RestartType=RegKeyValue("HKEY_CURRENT_USER\\Software\\WPI\\RestartType");

WriteRegKey("HKEY_CURRENT_USER\\Software\\WPI\\ResumeInstall",0,"REG_DWORD");
>>>>>>>DeleteAllRegKeys();<<<<<<<<<<
}
else
{
RestartComputer=false; // Yes?
}

Edited by RealFasix

Share this post


Link to post
Share on other sites

Thanks RealFasix ! :)

Works now with your "workaround"!

I need also to make changes for sounds to fonction inside = Options | Sounds:

Warning.wav to Warning.WAV

Exit.wav to Exit.WAV

Cheers

*Edit: After some tests I see it's just needed to change inside the file global.js two lines (129 and 133):


// Sounds tab
var SndInstallWarning=['"%wpipath%\\Audio\\SoundsScheme\\Warning.WAV"'];

var SndWPIExit=['"%wpipath%\\Audio\\SoundsScheme\\Exit.WAV"'];

Edited by myselfidem

Share this post


Link to post
Share on other sites

Hi, i could use some help.

I've been using WPI v5.4 for years but only upgraded recently so i could use the menu on Win7 systems as well. I've only just discovered my build (8.2.1) now doesn't work on WinXP systems. 8.1 also appears to not work. The problem is weird: i have quite a large menu but half of the titles are unselectable ... when i go to try to select titles in the bottom half of the menu, before i can click on the check box, i am taken back to the middle of the menu (back a few pages) ... nothing i can do will allow me to select individual check boxes for about half the titles. Every time i try to put my mouse pointer anywhere near these titles i am taken back up to the middle of the menu again.

I have tried trouble-shooting, it works perfectly on a Win7 system, the problem is definitely due to WinXP ... i have tried both VMs and real world tests.

I am lest interested right now in understanding why this is happening, more interested in getting a dual system working. Am i the only one with this issue? If there is anyone with a working WPI that works on Win7 and XP, can you tell me which version it is and what you did to make it work?

Many thanks.

Share this post


Link to post
Share on other sites

Hi,

I think WPI 8.2.2 has a bug. There is no problem with 8.2.1 but 8.2.2. hangs on this screen:(Run from RunOnceEx.cmd)

jCcqO.png

it said also an error like this(I don't remember the whole); One script may cause not to respense or stop internet explorer, you want to stop this script etc.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×