• Announcements

    • xper

      MSFN Sponsorship and AdBlockers!   07/10/2016

      Dear members, MSFN is made available via subscriptions, donations and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, become a site sponsor and ads will be disabled automatically and by subscribing you get other sponsor benefits.
Kelsenellenelvian

WPI Bug Report Thread

210 posts in this topic

Aha...so that was the reason that it stops working for me in the past^^...well found myselfidem.

Yes. Thanks ;)

And we can see also that the volume slider works fine!

0

Share this post


Link to post
Share on other sites

Thanks for the new release WPI_v8.6.0 :thumbup

However could you apply the changes needed inside core.js:

line 135:

Enum=winMgts.OSLanguage;

with


// %OSLANG%
var Enum, DtoH;

CreateLocalArray();
try
{
objWMIService=GetObject("winmgmts:\\\\" + "." + "[url="file://\\root\\CIMV2"]\\root\\CIMV2[/url]");
colItems=objWMIService.ExecQuery("SELECT * FROM Win32_OperatingSystem", "WQL", wbemFlagReturnImmediately | wbemFlagForwardOnly);

enumItems=new Enumerator(colItems);
for (; !enumItems.atEnd(); enumItems.moveNext())

objItem=enumItems.item();
OSLanguage=objItem.OSLanguage;

// OSLanguage=1033, 1036, ....

try
{
var Enum=objItem.OSLanguage;

}
catch(ex2)
{
Enum=1033;
}

line 331

var hD="0123456789ABCDEF";

with

var hD="0123456789abcdef";

Regards

*Edit: post updated !

Edited by myselfidem
0

Share this post


Link to post
Share on other sites

Thanks for the new release WPI_v8.6.0 :thumbup

However could you apply the changes needed inside core.js:

line 135:

Enum=winMgts.OSLanguage;

with


CreateLocalArray();
try
{
objWMIService=GetObject("winmgmts:\\\\" + "." + "\\root\\CIMV2");
colItems=objWMIService.ExecQuery("SELECT * FROM Win32_OperatingSystem", "WQL", wbemFlagReturnImmediately | wbemFlagForwardOnly);
enumItems=new Enumerator(colItems);
objItem=enumItems.item();


// OSLanguage=1033, 1036, ....

try
{
var Enum=objItem.OSLanguage;

}
catch(ex2)
{
}

Are you sure about bottom ---> }

I'm just adding.just to be sure.Thx^^

0

Share this post


Link to post
Share on other sites

Thanks Whatsup! :) Iupdated my last post !

Missing some values:


catch(ex2)
{
Enum=1033;
}

core.js for %OSLANG%


// %OSLANG%
var Enum, DtoH;

CreateLocalArray();
try
{
objWMIService=GetObject("winmgmts:\\\\" + "." + "[url="file://\\root\\CIMV2"]\\root\\CIMV2[/url]");
colItems=objWMIService.ExecQuery("SELECT * FROM Win32_OperatingSystem", "WQL", wbemFlagReturnImmediately | wbemFlagForwardOnly);

enumItems=new Enumerator(colItems);
for (; !enumItems.atEnd(); enumItems.moveNext())

objItem=enumItems.item();
OSLanguage=objItem.OSLanguage;


// OSLanguage=1033, 1036, ....

try
{
var Enum=objItem.OSLanguage;

}
catch(ex2)
{
Enum=1033;
}

DtoH=DecToHex(Enum);
while (DtoH.length<4)
DtoH="0" + DtoH+"";

for (var x=0; x<arrOSLang.length; x++)
{
if (arrOSLang[x].LCID==DtoH)
{
oslang=arrOSLang[x].TLA;
oslocale=arrOSLang[x].Locale;
break;
}
}

}
catch(ex)
{
oslang="ENU";
oslocale="English - United States";
}


// Environment variable for batch file
setEnvVar("HDD",hdd,false);
setEnvVar("CDDRV",cddrv,false);
setEnvVar("WPIPATH",wpipath,false);
setEnvVar("ROOT",root,false);
setEnvVar("OSLANG",oslang,false);
setEnvVar("OSLOCALE",oslocale,false);
}

*Edit: I'm testing with these values now! I don't know if it's a good idea...But works! I'm testing on VM to see the result and see if there is always WMI errors!

Regards

Edited by myselfidem
0

Share this post


Link to post
Share on other sites

Inside information.js

It seems it's an error:

ArchitectureGrid.addRow(gId++,getText(lblArchType)+','+sysArch+'');

Changed with:

ArchitectureGrid.addRow(gId++,getText(lblArchType)+','+getArch()+'');

Regards

0

Share this post


Link to post
Share on other sites

Hi.

The body.clientWidth and body.clientHeight are changed in installer.js.

So the installer window is a bit out of context.

installer.js

old

line 177 : window.resizeTo(iWidth+(460-document.body.clientWidth),iHeight+(560-document.body.clientHeight));

new

Line 177 : window.resizeTo(iWidth+(430-document.body.clientWidth),iHeight+(570-document.body.clientHeight));

so i think it's better to stay by 460 and 560.

Thx for the new update Kel^^

PS:I upload soon dutch lang_nl.js it's almost ready.

0

Share this post


Link to post
Share on other sites

I see inside wmi.js that is missing for getOSvernum (line 22, ect.)


function getOSvernum()
{
position="wmi.js";
whatfunc="getOSvernum()";

Regards

*Edit. I see there is a new download link for WPI:

http://www.wpiw.net/help.html

Edited by myselfidem
0

Share this post


Link to post
Share on other sites

When I select some applications there is an error on Windows 7 with System event and the system needs time: 4 minutes to start and 4 minutes to restart the first time.

If I install all programs, all is fine: 20 seconds to start and 20 seconds to restart.

Can you clarify???

Not totaly solved!

The trouble was a warning message on a popup window at start and restart Windows on VM Oracle VirtualBox, only installing some applications with WPI, but not when installing all.

WMI error message insde the Event System log:

Event filter with query "SELECT * FROM __InstanceModificationEvent WITHIN 60 WHERE TargetInstance ISA "Win32_Processor" AND TargetInstance.LoadPercentage > 99"

could not be reactivated in namespace "//./root/CIMV2" because of error 0x80041003.

Events cannot be delivered through this filter until the problem is corrected.

And Windows needed 4 minutes to start and 4 minutes to restart only the first time.

Windows Management Instrumentation

This happens only using VM VirtualBox - not on my Computer - and I made some adjustments inside VM:

Configuration | System | Acceleration

uncheck the boxes:

- Hardware Virtualization:

Activate VT-x/AMD-V

Enable Paging nested

WPI is more faster than never!

Using WMI

Maintaining WMI Security

Regards

Solved using this workaround:

Event ID 10 is logged in the Application log after you install Service Pack 1 for Windows 7 or Windows Server 2008 R2

This originated in the Windows 7 SP1 DVD/ISO creation process. There was an issue in the creation process that caused a WMI registration to remain in the DVD/ISO. Since the registration is designed to work only during the DVD/ISO creation process, it fails to run on a live system and causes these events. These events are not indicative of any issue in the system and can be safely ignored. If however you want to prevent these events from getting generated and want to remove this specific WMI registration manually, please follow the steps mentioned in this article for running the workaround script.

Using with WPI and not have window boxes I use like this:

Workaround.vbs


' Event ID 10 is logged in the Application log after you install
' Service Pack 1 for Windows 7 or Windows Server 2008 R2
' For more details read instructions on the link below
' http://support.microsoft.com/kb/2545227

strComputer = "."

Set objWMIService = GetObject("winmgmts:" _
& "{impersonationLevel=impersonate}!\\" _
& strComputer & "\root\subscription")

set obj1 = objWMIService.ExecQuery("select * from __eventfilter where name='BVTFilter' and query='SELECT * FROM __InstanceModificationEvent WITHIN 60 WHERE TargetInstance ISA ""Win32_Processor"" AND TargetInstance.LoadPercentage > 99'")

For Each obj1elem in obj1

set obj2set = obj1elem.Associators_("__FilterToConsumerBinding")

set obj3set = obj1elem.References_("__FilterToConsumerBinding")

For each obj2 in obj2set

obj2.Delete_

next

For each obj3 in obj3set

obj3.Delete_

next

obj1elem.Delete_

Next

Or we can download and use Microsoft FixIt installing with WPI, at last:

MicrosoftFixit50688.msi (using /qn switches).

Regards

Edited by myselfidem
0

Share this post


Link to post
Share on other sites

Many thanks Kels for the new awesome release WPI_v8.6.1 :thumbup

To display the Archtype correctly could you change like this inside information.js:

Replace:

ArchitectureGrid.addRow(gId++,getText(lblArchType)+','+getArch+'');

with:

ArchitectureGrid.addRow(gId++,getText(lblArchType)+','+getArch()+'');

Thanks to update the wpi.xml file with: <version>8.6.1</version>

Regards

Edited by myselfidem
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.