Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account



Photo

How to replace the inactive [Open in IE] button in Opera

- - - - -

  • Please log in to reply
3 replies to this topic

#1
egrabrych

egrabrych

    Junior

  • Member
  • Pip
  • 97 posts
  • Joined 27-May 10
  • OS:98SE
  • Country: Country Flag

Donator

Greetings!

I'm a user of the Opera web browser, working in Windows 98 SE + KernelEx 4.51. My Opera has the additional button [Open in Internet Explorer] placed on the toolbar, that allows to open the currently visible site in the Internet Explorer (mine is in 6.0 SP1 version). This button is implemented by a notation in the Opera standard_toolbar[...].ini file: "Open in Internet Explorer"="Execute program, "iexplore", "%u", "Open in Internet Explorer"".

Up until the version 11.01 of the Opera, the button functioned properly. Unfortunately, after actualizing the Opera to 11.10 version, the button ceased to function completely - even though in the same version of the Opera, but installed in the Windows XP Professional SP3 executive system, it does still work (however, the button applies to the Internet Explorer 8 there).

I don't have the knowledge vast enough to fix the problem by myself. I noticed, however, that clicking the right mouse button on a website window displayed by the Opera opens a context menu, in which one of the entries is command "Open with - Firefox" (I also have the Firefox 3.6). I was thinking, that perhaps I could try to place the entry "Open with - Internet Explorer" in there too. In order to do that, I used the notation placed in Windows XP Registry in the key [HKEY_LOCAL_MACHINE\SOFTWARE\Clients\StartMenuInternet] through the Internet Explorer 8 installer. This notation, after importing it to the Windows 98 SE Registry, I abridged of the sub keys irrelevant to this matter, finally leaving it in this very shape:

[HKEY_LOCAL_MACHINE\SOFTWARE\Clients\StartMenuInternet\IEXPLORE.EXE]
@="Internet Explorer"

[HKEY_LOCAL_MACHINE\SOFTWARE\Clients\StartMenuInternet\IEXPLORE.EXE\DefaultIcon]
@="C:\\Program Files\\Internet Explorer\\iexplore.exe,0"

[HKEY_LOCAL_MACHINE\SOFTWARE\Clients\StartMenuInternet\IEXPLORE.EXE\shell]

[HKEY_LOCAL_MACHINE\SOFTWARE\Clients\StartMenuInternet\IEXPLORE.EXE\shell\open]

[HKEY_LOCAL_MACHINE\SOFTWARE\Clients\StartMenuInternet\IEXPLORE.EXE\shell\open\command]
@="C:\\Program Files\\Internet Explorer\\iexplore.exe"

The Attached File  import.reg   557bytes   6 downloads
file contains such an abridged notation.

After executing all this, in the context menu suddenly appeared the expected "Open with - Internet Explorer", that functions properly in the Opera 11.10 (11.11) operating in the Windows 98 SE + KernelEx 4.51.

I must add, that placing in the:
[HKEY_LOCAL_MACHINE\SOFTWARE\Clients\StartMenuInternet]
key the @="IEXPLORE.EXE" value causes the entry "Open with - Internet Explorer" to be placed the highest in the context menu (without this value, the alphabetical order (of browsers' names) is in effect).
The Attached File  import_plus.reg   634bytes   5 downloads
file contains such a notation, with that value as well.

Thanks to using the aforesaid solution, the lack of functioning [Open in Internet Explorer] button is no longer severe to me and I removed it from the toolbar.

Of course, if anybody knows how to fix the problem properly, let him give it away to the other Opera users, including me :) .

Edited by egrabrych, 20 May 2011 - 10:38 AM.



How to remove advertisement from MSFN

#2
loblo

loblo

    Oldbie

  • Member
  • PipPipPipPipPip
  • 801 posts
  • Joined 12-January 10
  • OS:ME
  • Country: Country Flag
That's the only known workaround I am afraid and I did mention it in another thread (without going in such great details though).

http://www.msfn.org/...post__p__964313

I think it's worth mentioning that, using the template you provided, one can easily create other entries for other suitable applications to appear in the Opera "Open With" menu.

:hello:

#3
rilef

rilef

    Junior

  • Member
  • Pip
  • 59 posts
  • Joined 08-April 10
  • OS:none specified
  • Country: Country Flag
There appears to be two compatibility issues at work here.

First, for Windows 98, "StartMenuInternet" is in the following Windows Registry key:

[HKEY_LOCAL_MACHINE\Software\Clients\StartMenuInternet\ ...

On the other hand, beginning with Windows XP, "StartMenuInternet" is in the following Windows Registry key:

[HKEY_LOCAL_MACHINE\SOFTWARE\Clients\StartMenuInternet\ ...

Apparently, Opera 11's "Open With" menu no longer looks in the "Software" registry key for "iexplore.exe", but only in the "SOFTWARE" Windows Registry key. Thus, manually entering new "SOFTWARE" registry keys, for IE and other browsers, fixes the problem.

Second, Windows 98 handles long file names somewhat differently than Windows XP and above. For example, a lookup of the application path for "iexplore.exe" shows this result in my Windows 98:

[HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\App Paths\IEXPLORE.EXE]
@="C:\\PROGRA~1\\INTERN~1\\iexplore.exe"
"Path"="C:\\PROGRA~1\\INTERN~1\\;"
"set"="8"

Again, Opera 11 may no longer lookup "IEXPLORE.EXE" in the "Software" Windows Registry key, only in the
"SOFTWARE" Windows Registry key. And, Opera 11 may no longer handle Windows 98 long filename notation. So try changing your custom IE button in the Opera standard_toolbar[...].ini file from:

"Open in Internet Explorer"="Execute program, "iexplore", "%u", "Open in Internet Explorer"".

to this:

"Open in Internet Explorer"="Execute program, "C:\\Program Files\\Internet Explorer\\iexplore.exe", "%u", "Open in Internet Explorer"".

#4
egrabrych

egrabrych

    Junior

  • Member
  • Pip
  • 97 posts
  • Joined 27-May 10
  • OS:98SE
  • Country: Country Flag

Donator

So try changing your custom IE button in the Opera standard_toolbar[...].ini file from:

"Open in Internet Explorer"="Execute program, "iexplore", "%u", "Open in Internet Explorer"".

to this:

"Open in Internet Explorer"="Execute program, "C:\\Program Files\\Internet Explorer\\iexplore.exe", "%u", "Open in Internet Explorer"".

I tried, does not work :(

That's the only known workaround I am afraid and I did mention it in another thread (without going in such great details though).

http://www.msfn.org/...post__p__964313

I think you're right.

Edited by egrabrych, 22 May 2011 - 05:12 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users