Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account


Photo

High CPU


  • Please log in to reply
17 replies to this topic

#1
universalbloggers

universalbloggers
  • Member
  • 7 posts
  • OS:none specified
  • Country: Country Flag
Hi,

i have windows 7 home premium 64 bit
4gb ram
1gb graphic card
core i3 processor

recently one problem is bugging me a lot. whenever i play any game, cpu goes high but even after i close the game cpu remains high only. i checked task manager but the cpu consumption don't add up to 90-100% . then i used process explorer, nothing found there also except too many svchost entries.
kindly suggest something.

UB


How to remove advertisement from MSFN

#2
-X-

-X-

    Member

  • Patrons
  • 2,392 posts
  • OS:XP Pro x86
  • Country: Country Flag

Donator

Under Task Manager, Processes what's using up the CPU?

Download all Windows XP Post SP3 High-Priority Updates with a simple double click @ xdot.tk post-12166-0-42859000-1399044129.png ]
               If someone helps you fix a problem, please report back so they and others can benefit from the solution. Thanks!


#3
MagicAndre1981

MagicAndre1981

    after Windows 7 GA still Vista lover :)

  • Patrons
  • 5,921 posts
  • OS:Vista Ultimate x86
  • Country: Country Flag

Donator

run a xperf trace:

http://www.msfn.org/...caused-by-apps/

and upload the ZIPPED etl to mediafire.com and post a link here.
Posted Image

#4
universalbloggers

universalbloggers
  • Member
  • 7 posts
  • OS:none specified
  • Country: Country Flag
here is latency.etl zip file.
plz check and help.
http://www.mediafire...9lu/latency.zip

#5
MagicAndre1981

MagicAndre1981

    after Windows 7 GA still Vista lover :)

  • Patrons
  • 5,921 posts
  • OS:Vista Ultimate x86
  • Country: Country Flag

Donator

Microsoft Security Essentials is permanently causing 40% CPU usage. Because MS doesn't offer debug files for MSE I can't see which function from MSE causes the high CPU usage.

So remove MSe and try other tools like Avira AntiVir or Avast.

1 other thing I can see is that the Interrupts cause some CPU usage. The Hal.dll is the cause. This is DLL for the hardware abstraction layer. Which power plan do you use? Also update the BIOS if possible.

Edited by MagicAndre1981, 17 June 2011 - 08:09 AM.

Posted Image

#6
pankaj

pankaj

    Junior

  • Member
  • Pip
  • 63 posts
  • OS:Windows 7 x64
  • Country: Country Flag
Hi universalbloggers..
Whenever you play games your game increaeses your cpu usage and as you said that it even after you close the game cpu remains high this may because of other Applications using your cpu...You can check them by Opening Task manager and then processes and check which application is using your Cpu more and you can close it by click on that process and click on End process button...

Hi..
This may also due to installation of unwanted Softwares in your PC...you can also reduce your CPU usage by uninstallling the unwanted Software from your PC....
Thanks and Regards,
Pankaj

#7
universalbloggers

universalbloggers
  • Member
  • 7 posts
  • OS:none specified
  • Country: Country Flag

Microsoft Security Essentials is permanently causing 40% CPU usage. Because MS doesn't offer debug files for MSE I can't see which function from MSE causes the high CPU usage.

So remove MSe and try other tools like Avira AntiVir or Avast.

1 other thing I can see is that the Interrupts cause some CPU usage. The Hal.dll is the cause. This is DLL for the hardware abstraction layer. Which power plan do you use? Also update the BIOS if possible.

hi, bios is updated recently so i don't think there will be any more updated version.
i use custom power plan with no sleep options.
one tmore thing my laptop battery needs to be replaced, don't know if that is cause of problem.

UB

#8
MagicAndre1981

MagicAndre1981

    after Windows 7 GA still Vista lover :)

  • Patrons
  • 5,921 posts
  • OS:Vista Ultimate x86
  • Country: Country Flag

Donator

ok, so try a different powerplan and if this doesn't solve it, uninstall MSE and try a different free AV software.
Posted Image

#9
pankaj

pankaj

    Junior

  • Member
  • Pip
  • 63 posts
  • OS:Windows 7 x64
  • Country: Country Flag


Microsoft Security Essentials is permanently causing 40% CPU usage. Because MS doesn't offer debug files for MSE I can't see which function from MSE causes the high CPU usage.

So remove MSe and try other tools like Avira AntiVir or Avast.

1 other thing I can see is that the Interrupts cause some CPU usage. The Hal.dll is the cause. This is DLL for the hardware abstraction layer. Which power plan do you use? Also update the BIOS if possible.

hi, bios is updated recently so i don't think there will be any more updated version.
i use custom power plan with no sleep options.
one tmore thing my laptop battery needs to be replaced, don't know if that is cause of problem.

UB

When you have purchase your laptop???????
Thanks and Regards,
Pankaj

#10
MagicAndre1981

MagicAndre1981

    after Windows 7 GA still Vista lover :)

  • Patrons
  • 5,921 posts
  • OS:Vista Ultimate x86
  • Country: Country Flag

Donator

do the same what I told the other user. Run a xperf trace and give me the files.

@universalbloggers

MS released a newer version of MSE. Try it again, maybe the new version is better.

Edited by MagicAndre1981, 29 June 2011 - 06:49 AM.

Posted Image

#11
universalbloggers

universalbloggers
  • Member
  • 7 posts
  • OS:none specified
  • Country: Country Flag
Hi,

I have purchased new battery, i am using balanced power plan right now, also disabled Microsoft security essentials service and defender service also.
still i am facing same issue.
check new latency file:

http://www.mediafire...0jy3j29qvoyxbzq

#12
MagicAndre1981

MagicAndre1981

    after Windows 7 GA still Vista lover :)

  • Patrons
  • 5,921 posts
  • OS:Vista Ultimate x86
  • Country: Country Flag

Donator

hi, the new trace shows me that the Windows Explorer causes a lot of CPU usage.

I can see that the Explorer extracts Icons to get the thumpnails. I looked and saw that the gameux.dll is involved. This is the game explorer of Windows. I think the game explorer tries to look for updates and displays the icons. This causes the CPU usage. You can try to use ShellExView to disable 3rd party Shell extensions. Look if this improves the performance.
Posted Image

#13
universalbloggers

universalbloggers
  • Member
  • 7 posts
  • OS:none specified
  • Country: Country Flag
Hi Andre,

Thanks for a quick response.

I have changed settings in games explorer to "never automatically find updates" and "never find art and information about games". I used shellexview; but 95% were microsoft only. remaining consist of winrar, amd, sun, broadcom. should i disable any of these?

Meanwhile i found out that presentationfontcache.exe is sometimes coming in process list and taking high CPU like 25, 50 and even 60%. What is this process? It is running as local service.

UB

#14
MagicAndre1981

MagicAndre1981

    after Windows 7 GA still Vista lover :)

  • Patrons
  • 5,921 posts
  • OS:Vista Ultimate x86
  • Country: Country Flag

Donator

Disable all other addons 1 followed by the other and check if the usage is gone.

the presentationfontcache.exe is used by WPF (Windows Presentation Foundation) apps. Stop the service and delete the file C:\Windows\ServiceProfiles\LocalService\AppData\Local\FontCache3.0.0.0.dat if you use .net 3.5 or C:\Windows\ServiceProfiles\LocalService\AppData\Local\FontCache4.0.0.0.dat if you use .net 4.0.
Posted Image

#15
universalbloggers

universalbloggers
  • Member
  • 7 posts
  • OS:none specified
  • Country: Country Flag
Hi Andre,

i have deleted the files and disabled the service, but somehow presentationfontcache.exe still runs.

also, check this latency file:
http://www.mediafire...sec9bfrbkza9vh5

#16
MagicAndre1981

MagicAndre1981

    after Windows 7 GA still Vista lover :)

  • Patrons
  • 5,921 posts
  • OS:Vista Ultimate x86
  • Country: Country Flag

Donator

Hi Andre,

i have deleted the files and disabled the service, but somehow presentationfontcache.exe still runs.


this is correct, but it only uses 0.39% of the cpu during the complete run. Now the IE9, Tata Photon+, and the Windows Explorer together use 20% of the CPU.

Can it be that you use(d) Daemon Tools because the sptd driver is running and causes some DPC/Interrupt usage.
Posted Image

#17
universalbloggers

universalbloggers
  • Member
  • 7 posts
  • OS:none specified
  • Country: Country Flag
Hi,

Finally found the actual cause- the system fan is getting stopped due to dust on it and thus CPU core temp. rises and gives high CPU. After cleaning, now the system is working absolutely fine.
Thanks Andre and others for support.

UB

#18
MagicAndre1981

MagicAndre1981

    after Windows 7 GA still Vista lover :)

  • Patrons
  • 5,921 posts
  • OS:Vista Ultimate x86
  • Country: Country Flag

Donator

ok, nice to hear that you found the cause.
Posted Image




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users



How to remove advertisement from MSFN