dencorso

SATA to IDE adapters: which/what/why?

81 posts in this topic

I finally managed to get everything work.

Jaclaz was right. The first adapter was too tall to fit in the notebook, even when the SSD was used without its case. I couldn't find any other, flatter one locally so I order this one from eBay. It was actually cheaper than the previous one ;) because the shipping cost was only 1$. It took around 1.5 weaks to get it.

First of all, I can say that everything works properly and there are no problems with stability. The SSD is detected properly in the BIOS and also when installing Windows. As it's a 64 GB capacity drive there are no issues with the BIOS too (its limit is 160 GB).

I took some pictures of the whole 'operation'.

E-IDE cable + previous (tall) adapter + SSD:

nCEgI.jpg

As you can see it's impossible to use the SSD 'as it is':

fc1Zq.jpg

Samsung 470 can be very easily opened:

RHX0j.jpg

hQtwU.jpg

The Samsung SSD itself is only 1.8' size so it should fit to any laptop designed to work with a 2.5 HDD. I guess it may be important information as the newer model (Samsung 830) is 2.5' so it'll probably not fit when used together with an adapter.

The new flat adapter:

FhbPz.jpg

lwtCa.jpg

fuhED.jpg

Tbxy0.jpg

Samsung 470 detected in BIOS:

AZoZX.jpg

t8jD5.jpg

I did some basic benchmarks. As you can see, performance is heavily affected by the old ATA66 interface and the adapter too:

old IDE drive (Samsung HM160HC):

BCq0B.jpg

SSD (Samsung 470 64GB)

rKbgG.jpg

The results don't look very promising at the first sight but:

1. Access time difference - 18,2 ms (IDE) vs 0,1 ms (SSD)

2. 4K - huge difference

In general, there's a huge different in speed. You can't even compare system responsiveness on the old IDE drive to the current one. I can say that it's like giving a second life to this old machine :)

I want to thank everyone for providing help and useful information, and inspiring me to get this idea materialised although it looked quite unreal in the beginning.

0

Share this post


Link to post
Share on other sites

Jaclaz was right.

Sure :), the "queer" thing is that you actually doubted it :w00t:;)

In general, there's a huge different in speed. You can't even compare system responsiveness on the old IDE drive to the current one. I can say that it's like giving a second life to this old machine :)

I want to thank everyone for providing help and useful information, and inspiring me to get this idea materialised although it looked quite unreal in the beginning.

Happy you made it! :thumbup

jaclaz

0

Share this post


Link to post
Share on other sites

+1

Glad you've had success! :thumbup

0

Share this post


Link to post
Share on other sites

This gives food for thought on SSDing my HP NX6125

I'd love to put an SSD into it, the HDD is dying in it and SSDs are more or less vibration proof so the laptop can be used more freely

Edited by TmEE
0

Share this post


Link to post
Share on other sites

I got a JM20330 based one from eBay for $5: http://www.ebay.com/itm/140619484951

Difficult getting the SATA and power connectors in, difficult getting them out, particularly when the PCB flexes since it isn't anchored, but it's workable. Even comes with extra bright red LEDs! :) I didn't get a good look at those LEDs, a difficult angle, but I assume they indicate connect drives or something.

A 750GB Samsung looked fine with it, though I only checked it briefly with HDTune. Other than that so far I used it to copy data from a 500GB WDC. No problems noted. (Well, there were 2 1-bit read errors, but that's something my IDE controller's been known to do when running DMA modes, so I guess that was the cause... :))

While it has a master/slave jumper, I couldn't get that part to work correctly.

I tried both the 750GB Samsung and 500GB WDC SATA drives, with an IDE WDC being the other drive. The BIOS doesn't detect either drive in that case. In some cases I did manage to get the drive ID strings to show in the BIOS setup screens, but not in actual boot, and always after a long delay.

I tried both as master/slave, two 80-wire cables, two positions on cable, WDC jumpered to force SATA 150, IDE drive jumpered in two master positions (single/master+slave), but no go. The IDE controller I tried it on is a SIS 5513 (part of the SIS630 chipset).

Any idea if it might be a compatibility issue, or how to solve it?

Edited by shae
0

Share this post


Link to post
Share on other sites

Oh, God, I wish I had seen this thread before I bought this piece of crap sata-ide adapter based on the horrible Sunplus SPIF223A chipset :(

I'm using it to plug an IDE Hitachi HDS722516VLAT80 hard disk into a sata controller. But I'm getting an absolutely pathetic read speed of 4 MB/s. Yes, you've read that right, FOUR miserable megabytes per second :(

I'm thinking of just throwing this piece of s*** into the trashcan and buying this one instead:

http://www.acard.com/english/fb01-product.jsp?idno_no=226&prod_no=AEC-7923&type1_idno=6&ino=43

Has anyone tried it? What is the best chipset to connect an IDE hard disk into a SerialATA controller?

Kind regards.

0

Share this post


Link to post
Share on other sites

I don't know of anybody using the ACARD AEC-7923 SATA II-to-IDE bridge yet, so I cannot tell you anything about it. But, in general, people here is interested in the reverse process, that is, connecting a SATA drive into a IDE-only motherboard. That said, bear in mind that most, if not all, we know about such converters is in this thread, and some more info is findable in the links therein. But that's about it, I'm sorry to say. Our experience with such converters is very limited, in fact.

0

Share this post


Link to post
Share on other sites

I've found a few alternatives to the one with the ACARD ARC772 chipset.

Here's one with an unknown Silicon Image chipset (cannot identify the exact model in the photo)

http://www.manhattan-products.com/en-US/products/3155-ide-to-sata-150-converter

Another one with JMicron JM20330 chipset:

http://www.siig.com/it-products/controllers-storage/hard-drive-storage/drive-converters/sata-to-ide-adapter-1044.html

And this one is using a Marvell 88SA8040 chipset:

http://www.ioi.com.tw/products/proddetail.aspx?CatID=101&HostID=2037&DeviceID=3000&ProdID=1010048

Argh, choices, choices, so many of them! And I really want to avoid buying another crappy controller like the dreaded Sunplus!

0

Share this post


Link to post
Share on other sites

Hey dencorso, I know this isn't your thread, but is there any chance that someone could add a summary section to either the first or second post (yours :) ), where there could be a list of which ones there has been good or bad experience with, for data transfer in whichever direction, and the rest listed as unknown? Just a thought.

Cheers and Regards

0

Share this post


Link to post
Share on other sites
Hey dencorso, I know this isn't your thread, but is there any chance that someone could add a summary section to either the first or second post (yours :) ), where there could be a list of which ones there has been good or bad experience with, for data transfer in whichever direction, and the rest listed as unknown?

Sure there is! You're more than welcome to create such content and PM it to me. When it reaches my hands, I shall gladly insert all of it, as a quotation, into the 1st post. :yes:

0

Share this post


Link to post
Share on other sites

Touche my friend! PM sent.

Cheers and Regards

0

Share this post


Link to post
Share on other sites

Done, thanks!

And, yes, I've become OP in the process, BTW... :angel

0

Share this post


Link to post
Share on other sites
But I'm getting an absolutely pathetic read speed of 4 MB/s.
Perhaps the problem is somewhere else? I don't think any modern controller chip would do that in normal conditions.
What is the best chipset to connect an IDE hard disk into a SerialATA controller?
The best way might be to get an IDE controller card.
0

Share this post


Link to post
Share on other sites
Perhaps the problem is somewhere else? I don't think any modern controller chip would do that in normal conditions.

I don't know where else the problem could be. I have Windows 8 x64 recently installed. I'm using a Gigabyte GA-970A-DS3 motherboard with AMD SB950 south bridge. The SATA controller is configured in AHCI mode, and I'm using the stock AHCI drivers made by Microsoft and included in Windows 8.

The SATA cable is brand new and works perfectly well with my other disks (without CRC nor cabling errors)

My setup is pretty standard. Nothing out of the ordinary. What could be wrong on my part??!

The best way might be to get an IDE controller card.

Yes, I know, but I want something more portable, so I can carry it with me.

0

Share this post


Link to post
Share on other sites

I'd go with the Marvell 88SA8040 based board, but warn the seller that the Marvell 88SA8040 is mandatory.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.