• Announcements

    • xper

      MSFN Sponsorship and AdBlockers!   07/10/2016

      Dear members, MSFN is made available via subscriptions, donations and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, become a site sponsor and ads will be disabled automatically and by subscribing you get other sponsor benefits.
Sign in to follow this  
Followers 0
dencorso

IE8 crashes from just one site (but a big one at that).

14 posts in this topic

This link crashes my IE8 about 3 of every 5 times I attempt to view it. The crash either is a silent closing of IE8 or a message box, with the usual mention of a report. UOL is a big news portal in Portuguese, so avoiding it is not an option.

I'm having problems with UOL only, so my set-up apears not to be a problem. I didn't yet catch a report from that link in particular, but I'm attaching reports from previous ones that exhibited the same simptoms (and all 3 I've cached, from different links, are binarily identical). And yes, navigating In-private with no add-ons lowers the probability of crashing IE8, but by no means avoids it entirely. Please advise.

post-134642-0-45584900-1314388186_thumb.

8150_appcompat.7z

0

Share this post


Link to post
Share on other sites

Works for me in XP x64 SP2 in both 32 and 64-bit IE8 browsers. Opened six times in 32-bit, five in 64-bit.

Your appcompat file suggests you're using XP x86 SP3, but also shows files from Win2003 and Vista. Which OS are you using, which updates have you installed for IE8, and which version of Adobe Flash are you running?

The problem may simply be a bad Flash advertisement. You may want to consider installing the latest Flash version which was released within the past day or so. It is supposed to be a compatibility update.

http://fpdownload.macromedia.com/get/flashplayer/current/install_flash_player_ax.exe

0

Share this post


Link to post
Share on other sites

No problem for me either but as i am using a hosts file to block many unwanted things (ads mostly) perhaps that's the reason why.

0

Share this post


Link to post
Share on other sites

I'm using Win XP SP3. All Vista and Win 2003 files present stem from IE8 or its updates.

I've updated flash. Thanks, 5eraph, for the heads up! :thumbup

However, the crashes continue. IE8 crashed 7 times in 10 attempts, this time.

BTW, I'm using a custom hosts file, too. But perhaps it's less restrictive than the one you're using, allen2.

0

Share this post


Link to post
Share on other sites

Have you tried Compatibility View?

I don't use a customized HOSTS file. Still no issues testing here.

Perhaps resetting IE would solve the problem. Microsoft has a Fix It solution available at KB923737. Instructions for manually resetting IE are also provided.

0

Share this post


Link to post
Share on other sites

Could be related to this:

<meta http-equiv="X-UA-Compatible" content="IE=edge" />

I can find mixed results of using the Edge value. Some have problems, some say its made for HTML5.

From what I understand, using edge will force IE8 to use the IE8 renderer instead of the IE7 (Compatibility) renderer. Then again, I've also read that IE8 may totally ignore this value, so not sure if it is related.

0

Share this post


Link to post
Share on other sites

use procdump (procdump -e PID dumpname) to generate a crash dump. Zip and uplaod the dump.

0

Share this post


Link to post
Share on other sites

Thanks a lot to both of you, MagicAndre1981 and Tripredacus! You rock! :thumbup

I did some more tests and I'm convinced that the issue is in IE8 itself, since navigating In-private with no add-ons lowers the probability of crashing IE8, but by no means avoids it entirely. And I do think Tripredacus is right in that some HTML, perhaps Edge is trigering it, because, up to now I've had problems only with UOL. So, the easiest solution would be to upgrade to IE9, but MS decided users of XP SP3 like me are not worthy... :wacko:

But it's OK. I've just added Opera 11.5 to my system, and now I can again browse the news without any crashes.

Time permitting, I'll try to follow up and, with your help, debug it. But for the time being, the issue is duly worked around. :D

0

Share this post


Link to post
Share on other sites

you might like to use Proxomitron, with it you can easily create a web-filter to remove the offending html tag.

0

Share this post


Link to post
Share on other sites

I've sorted it out! And it's a catch-22 situation. :wacko:

Turns out that, in july, while trying to disable a nagging prompt IE8 presents on reopening, every time it's killed or when it crashes, I disabled "Enable automatic crash recovery" as recorded in the "Auto-"go to homepage" in IE8... Is there a way to do it?" thread, which last post I quote below, for easy reference:

But now I've found the answer: :yes:

Go to Tools --> Internet Options --> Advanced --> Browsing and untick "Enable automatic crash recovery"

That suppresses the dialogue box, after IE crashes. And then it goes to the default homepage, as required.

I'm posting it here just for the record, so that others may find it, on searching.

And it worked OK for a while, then UOL made some "HTML Updates" to its pages and the crashes described in this thread began.

However, when I re-enabled "automatic crash recovery", the crashes still happen, but IE8 recovers from them seamlessy, so they are imperceptible, unless one causes the machine to really slow down. Hence, there's more to the "Enable automatic crash recovery" setting than the nag prompt I was keen on disabling, and it's really not advisable to untick it. :(

I guess it's best to put up with the occasional nag screen, than to use two browsers on a regular basis.

@Joseph_sw: True enough. Proxomitron can solve it, but I'd have to identify all offending tags, by trial and error...

In any case I'll look into it further, since I've been considering adding it to my setup for a long time already, and this may be a good time for it. Thanks for the suggestion.

0

Share this post


Link to post
Share on other sites

and speaking about hosts file,

proxomitron is also good to help you build one,

as properly installed proxomitron has: local.ptron/.pinfo/urls/

it will list the histories of any sites that proxomitron trying to access.

whenever i saw something i don't like from that list, i'll add it immediately to hosts file.

if the list is not large enough (default was: 100 last accessed sites),

you can even make it larger my changing "MaxCapURL" value from proxomitron's default.cfg

0

Share this post


Link to post
Share on other sites

try to capture a crash dump and upload it.

0

Share this post


Link to post
Share on other sites

@MagicAndre1981: As soon as I manage to do it I'll post it.

Menwhile I've see the same crash happen in at least 7 different machines at work, all of them having plain vanilla XP SP3 installations with IE8.

The site for getting the crashes is the main page of the UOL news portal. It's content varies by the day, but clicking on news links and then in news links inside the newly arrived-at page, sooner or later causes a crash. And disabling the "automatic crash recovery" reults in either the messages in the 1st post or in IE8 closing suddenly.

This also seems to be a bug known to MS, but fixed only for latter versions of windows (see: KB979665).

0

Share this post


Link to post
Share on other sites

That fix is from 2010 (included in MS10-002), and the error is very generic. There's no way to tell if the fix from 979665 is actually for the issue you are seeing without you getting a crash dump and comparing that versus the fix.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.