Asp

"open" for HTML files keeps changing

12 posts in this topic

For years I had used either Opera or Firefox as my default browser.

So if I clicked on an HTML file (e.g., a program help file) that browser would open.

Recently though the browser window opens, but no file. If I use "file/open" in the browser and navigate to the folder and select the file, it opens. Which is an enormous pain.

If in Explorer I click on a HTML file, same thing, browser opens, but not the file.

If I look at the file associations, I see the default action is:

"open" with "P:\Opera\Opera.exe" "%1"

which is correct.

but I also see for "edit" :

"P:\MSOffice\Office\msohtmed.exe" %1

and "print": ""P:\MSOffice\Office\msohtmed.exe" /p %1"

And I have no idea how those got there.

If I change or just delete the "edit" and "print" association, Opera will open the file normally.

But a short time later, it reverts.

I assume that if I open MS Word or Excel that somehow it thinks it has a licence to screw up my file associations.

recently I updated MS Office, though I certainly DID NOT agree to it doing anything about HTML files.

How can I fix this permanently?

Edited by Asp
0

Share this post


Link to post
Share on other sites

You do realize that you did not mention the actual Office version you are running? :unsure:

It may depend on the version.

It used to be needed to force with a switch the re-registering of the application, like last paragraph here:

http://www.officearticles.com/misc/files_dont_open_when_double-clicked_in_microsoft_office.htm

but if everytime an Office app re-registers itself, it will be tough to fix the issue.

Here should be the solution you are looking for (NOT exactly the specific one, but it could give you a hint on where/what to look for):

http://social.msdn.microsoft.com/Forums/pl-PL/tfsadmin/thread/0b3bf5f2-1431-4848-b20d-83e01d663a74

http://answers.microsoft.com/en-us/office/forum/office_2010-customize/how-can-stop-outlook-2010-from-changing-file/f3b746a7-f9ef-4d34-b655-962456f36aaa

jaclaz

Edited by jaclaz
0

Share this post


Link to post
Share on other sites

You do realize that you did not mention the actual Office version you are running? :unsure:

It may depend on the version.

Office 2000, but my daughter installed a later version as a "trial" which I had to get rid of (no need for the **** thing) and it may have left remnants).

It used to be needed to force with a switch the re-registering of the application, like last paragraph here:

http://www.officearticles.com/misc/files_dont_open_when_double-clicked_in_microsoft_office.htm

That's the same file associations dialog you get via Explorer.

I already did that, as I said, it gets reverted after a short time.

but if everytime an Office app re-registers itself, it will be tough to fix the issue.

Here should be the solution you are looking for (NOT exactly the specific one, but it could give you a hint on where/what to look for):

http://social.msdn.microsoft.com/Forums/pl-PL/tfsadmin/thread/0b3bf5f2-1431-4848-b20d-83e01d663a74

I found that earlier, couldn't see anything there helpful.

The last post:

[HKEY_CURRENT_USER\Software\Microsoft\Office\11.0\Common\Internet]

"DoNotCheckIfOfficeIsHTMLEditor"=dword:00000001

I already have at "1" = do not check ( I presume that's what it should be).

That says to lock the Registry branch; I can't do that (in Win2k).

I expected that since it's MS Office that is stubbornly doing this there would be an option in MS Office to stop it.

But Microsoft being the control freak that it is, that was misguided I guess.

0

Share this post


Link to post
Share on other sites

WHY not? :unsure::w00t:

and WHY you posted in:

MSFN Forum > Microsoft Software Products > Windows XP >

if you are running 2K?

BTW, I assumed that you were running XP because you posted in XP ;) (AND you did not specify your running OS, AND you have no OS specified in your profile) but really cannot see what would be the difference in 2K (you will need to use regedit32 instead of regedit, obviously).

jaclaz

Edited by jaclaz
0

Share this post


Link to post
Share on other sites

I can't see the option anywhere.

and WHY you posted in:

MSFN Forum > Microsoft Software Products > Windows XP >

if you are running 2K?

BTW, I assumed that you were running XP because you posted in XP ;) (AND you did not specify your running OS, AND you have no OS specified in your profile) but really cannot see what would be the difference in 2K (you will need to use regedit32 instead of regedit, obviously).

I saw an "NT" forum and "XP", so chose the latter, of course now I see 2k is also in the NT group.

And as you know, XP and 2k are very similar in most respects, I run lots of "XP" software, I haven't needed to upgrade.

But really, I think this is not so OS specific.

Googling found various people complaining about this problem many versions, including Win7.

If nothing turns up here I'll repost in the MS Office forum, that being the guilty party.

0

Share this post


Link to post
Share on other sites

I can't see the option anywhere.

(you will need to use regedit32 instead of regedit, obviously).

jaclaz

0

Share this post


Link to post
Share on other sites

This is for Office 2003, but as far as I remember there is something similar, if not the same, in Office 2000.

KtukF.png

GL

0

Share this post


Link to post
Share on other sites

(you will need to use regedit32 instead of regedit, obviously).

There is no "regedit32" on my PC.

So I thought you were just confused with a later version.

But I looked again and found that there is "regedt32"

(So you were just confused by Microsoft's spelling.)

Looks interesting.

Had it on my PC almost 10 years without noticing.

But with GrofLuigi's hint seeming to work it may not be necessary for this issue.

This is for Office 2003, but as far as I remember there is something similar, if not the same, in Office 2000.

[img=http://i.imgur.com/KtukF.png]

Thanks!

That SEEMS to have worked. I remain cautious as it has reverted every other time I thought I'd fixed it, but after opening and closing Excel and Word a few times, it seems stable.

0

Share this post


Link to post
Share on other sites

Looks interesting.

Had it on my PC almost 10 years without noticing.

Yep, this is actually a good sign and a living demonstration of the stability of 2K, as it means you didn't have to mingle with the Registry permissions or ever needed to mount a hive and what not for 10 years. :thumbup

Sorry for the misunderstanding, I thought that a long time 2K user would have known this, NT 4.00 and 2K have two different programs to deal with Registry, a "simple" Regedit and a "more advanced" Regedt32 (yep, sorry for the spelling), starting with XP the two apps were "merged" in a "single" Regedit.

Personally I doubt that Office 2000 has the same settings Grofluigi detailed for Office 2003, as a the time the Office support for .htm was primitive and "secundary".

With the evolution of Office, the html feature remained absolutely primitive (IMHO) :w00t: BUT the policy "All your base are belong to us" ;) became more effective. :ph34r:

If I recall correctly there is only the first option" Check if Office ....." and NOT the "Check if Word" one. :unsure:

It could be that the msohtmed.exe (and related Registry settings) you have currently are somehow coming from the "trial install" of a later version.

Let us know what happens.

jaclaz

0

Share this post


Link to post
Share on other sites

and WHY you posted in:

MSFN Forum > Microsoft Software Products > Windows XP >

if you are running 2K?

Well I certainly can't leave this topic in the wrong place... but to Office or Win2k? :wacko:

:angel

0

Share this post


Link to post
Share on other sites

Well I certainly can't leave this topic in the wrong place... but to Office or Win2k? :wacko:

Decisions, decisions .... always decisions.... :ph34r:;)

jaclaz

0

Share this post


Link to post
Share on other sites

Well I certainly can't leave this topic in the wrong place... but to Office or Win2k? :wacko:

:angel

Office; that was the cause and where the solution was.

(That wasn't clear to me at the beginning, but it is now.)

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.