Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 



Sign in to follow this  
Tripredacus

IS One-Click-Installer (OCI) silent?

Recommended Posts

Tripredacus    286

I'm trying to figure out how to do a silent install of a program called LockIndicator.

Main DL page: http://www.msi.com/product/nb/GT780DX.html#/?div=Utility&os=All

Link to DL: http://www.msi.com/service/download/utility-17253.html

The installer is InstallShield12, but seems to be built inside of a web-installed called OCI or One-Click-Installer. It does not appear to accept any switches. Anytime a switch is used, Setup opens, extracts everything, and then exits. If you run the setup normally, the program installs and works. I've tried with both the main setup, and also the one that gets extracted into the Temp folder. Neither of these setups seem to accept switches.

Being connected to the internet doesn't seem to have anything to do with it. It won't install using a switch, but will if using the GUI.

Have you ever seen an installer like this?

Share this post


Link to post
Share on other sites

allen2    1

As far as i saw, it seems the dotnetinstaller.exe is embed in both installer and might be causing this behavior. I didn't found any way to disable it so perhaps repackaging entirely is the best option (with installrite perhaps).

Share this post


Link to post
Share on other sites
Geej    0

Since Lock Indicator is just a tool to indicate the status of Caps Lock/Num Lock/Scroll Lock status, perhaps you can look for alternative that does the same thing. Perhaps Keyboard Leds?

Regards

Share this post


Link to post
Share on other sites
Tripredacus    286

Since Lock Indicator is just a tool to indicate the status of Caps Lock/Num Lock/Scroll Lock status, perhaps you can look for alternative that does the same thing. Perhaps Keyboard Leds?

That looks like a good tool for alternate uses. Unfortunately, I can't use it in production since we need to use the official programs. Even MSI doesn't list LockIndicator as a required program, its an optional utility. However, after using this notebook for a couple days, not knowing the lock status is annoying. At the moment (if it can't be figured out) I've sent along instructions to manually install it during deployment.

I'll take a look into InstallRite and see if I am allowed to use it in this case, but I still haven't heard back from MSI yet.

Share this post


Link to post
Share on other sites
Tripredacus    286

I was able to build an exe with InstallRite 2.5, but it does not install (or do anything) on another system... I followed this general instructions, save the last part:

http://www.netopia.com/support/software/how2docs/netoctopus/installrite.html

I've tried both double-clicking and running from cmd. The test environment is Windows 7 Pro x86 in Audit Mode.

Share this post


Link to post
Share on other sites
CoffeeFiend    0

I'm not quite sure why it's not working for you. If I keep the extracted files (setup.exe and so on) from %temp%\{some GUID here}\Disk1 and run setup.exe -r on that, it does generate a valid setup.iss file, which does work with the -s switch as expected.

If that helps, here's the contents of the setup.iss file:


[InstallShield Silent]
Version=v7.00
File=Response File
[File Transfer]
OverwrittenReadOnly=NoToAll
[{CBDF64A5-44E0-4ECF-B5B3-FE8EF961CF13}-DlgOrder]
Dlg0={CBDF64A5-44E0-4ECF-B5B3-FE8EF961CF13}-SdWelcome-0
Count=3
Dlg1={CBDF64A5-44E0-4ECF-B5B3-FE8EF961CF13}-SdStartCopy2-0
Dlg2={CBDF64A5-44E0-4ECF-B5B3-FE8EF961CF13}-SdFinish-0
[{CBDF64A5-44E0-4ECF-B5B3-FE8EF961CF13}-SdWelcome-0]
Result=1
[{CBDF64A5-44E0-4ECF-B5B3-FE8EF961CF13}-SdStartCopy2-0]
Result=1
[Application]
Name=LockIndicator
Version=1.0.1106.2401
Company=Micro-Star International Co., Ltd.
Lang=0009
[{CBDF64A5-44E0-4ECF-B5B3-FE8EF961CF13}-SdFinish-0]
Result=1
bOpt1=0
bOpt2=0

Share this post


Link to post
Share on other sites
Tripredacus    286

I'm not quite sure why it's not working for you. If I keep the extracted files (setup.exe and so on) from %temp%\{some GUID here}\Disk1 and run setup.exe -r on that, it does

I didn't hink of running the record on that setup... Anyways, it seems the InstallRite does work after all. Maybe I just needed that weekend thing. :rolleyes:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×