Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 



Sign in to follow this  
lamaii

Configuring Raid controllers in boot.wim

Recommended Posts

lamaii    0

Hi all new to the forum and was hoping to get some assistance on a problem I’m having.

I’m trying to get the boot.wim file to configure an Adaptec raid controller before the windows 7 installation starts. I can inject the drivers & command line interface files and the script I need to create the raid container, but for the life of me I cannot figure out how to get the boot.wim file to run any commands before the win7 installation.

Share this post


Link to post
Share on other sites

arwidmark    0

The best way (IMHO) is to use the Microsoft Deployment Toolkit (MDT) to deploy your images. It has ready made functions (sequences) to allow you to do your commands before, and after deployment. In addition it also provides driver injections, admin UI, application installs and update... It's totally free, just download from www.microsoft.com/deployment.

Then you can download (or view online) the following free video tutorials on how to set it up.

Videos from the MDT 2010 Lite Touch - Unleashed series

/ Johan

Share this post


Link to post
Share on other sites
lamaii    0

Had a play with MDT and I cannot get it to do what I need. I've got a fully Automated Win7 installation and that is all working fine. Currently all deployments are done off DVD's, I do have plans to move to WDS but the company I work for is FDA audited and making changes to how we build systems takes time due to the testing and documentation required.

I've got a boot.wim file which I have injected all the required drivers & applications. The boot.wim file is a standard MS Windows 7 boot.wim from an install disk.

All I need it to do is run a .cmd file before setup starts, but for the life of me I just cannot figure it out.

Share this post


Link to post
Share on other sites
lamaii    0

Yer, I've got an old PE disk that uses startnet.cmd then runs an XP OS setup.

On a standard boot.wim you have the 2 images PE & Windows setup, I take it that if I make changes to the startnet.cmd on the "Windows setup" wim then that will be processed prior to windows setup starting?

Share this post


Link to post
Share on other sites
iamtheky    0

i would assume so, though none of my boot.wim(s) are exactly standard but we use startnet to verify the system and initiate our custom deployments since its the first thing to fire.

Edited by iamtheky

Share this post


Link to post
Share on other sites
lamaii    0

So after a week of head scratching I finaly looked into the registry and found the Winpeshl.exe, so changed that to startnet.cmd. Now able to dump all pre-installing commands I need then re-run the Winpeshl.exe at the end of the file.

Thanks for your help.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×