Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account



Photo

There is a problem with this Windows Installer Package during Unattend

- - - - -

  • Please log in to reply
1 reply to this topic

#1
My2GirlsDad

My2GirlsDad

    Junior

  • Member
  • Pip
  • 98 posts
  • Joined 28-December 08
  • OS:Vista Home Premium x86
  • Country: Country Flag
I am attempting an unattended XP install using Yumeyao's latest DotNetFXAIO_40F_20111019_Addon_ENU.cab using HFSLIP putting the extracted dotnetfx.exe in the HFSVCPACK folder.

When running XP SP3 setup I receive the following error when processing .Net 2.0SP2 portion:

"There is a problem with this Windows Installer Package. Please refer to the setup log for more information."

From then on all subsquent "installs" are broken, including Net 4.

After running a few tests I've found the problem. When I include the line "FileSystem=convertNTFS" in the [unattended] section then the error occurs but if I remove that line then no error.

I have no idea why this happens and if someone could enlighten me it would be much appreciated.

My2GirlsDad


How to remove advertisement from MSFN

#2
cyberyeye

cyberyeye

    Member

  • Member
  • PipPip
  • 145 posts
  • Joined 19-March 05
  • OS:XP Pro x86
  • Country: Country Flag
I have nearly the same problem in my latest una xp installation.
I dont know what hotfix using hfslip has broken msiserver (windows installer) but after 1st logon i've fix it using this:

1. Reinstalling Windows installer 4.5 from here (in XP normal boot mode without using F8): http://www.microsoft...ls.aspx?id=8483
switch used: WindowsXP-KB942288-v3-x86.exe /overwriteoem

2. Restarting XP in Safe Mode

3. In Safe mode, Start menu > Run > this command: msiexec /regserver
then reboot in normal mode (without using F8)

then Windows installer was working fine as usual ;)

Another bug i had, "my documents" was popping up each time after user logon, i've fix this with modifying a reg key:

IN: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon>
Userinit
Replace your actual value with this: C:/windows/system32/userinit.exe
(note: without comma at the end! And dont forget to change drive letter if using other than C drive...)

Rebooted & My doc didnt poppedt again.

Hope this help !

PS: for the 1st time i've used HfSlip from W7-86 >> maybe there's a problem using hfslip under W7 ?

Attached Files






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users