• Announcements

    • xper

      MSFN Sponsorship and AdBlockers!   07/10/2016

      Dear members, MSFN is made available via subscriptions, donations and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, become a site sponsor and ads will be disabled automatically and by subscribing you get other sponsor benefits.
marxo

Opera, KernelEx and related matters

222 posts in this topic

I was using Opera ftp built-in client. It allowed me to connect to the server but I was not able to change files and folders.

Yes I have permissions to make changes. Anybody know how to fix this?

I don't think there is anything to fix, Opera does lots of things but, as far as I know, it isn't an FTP application, aside from browsing/downloading files from FTP sites like most other web browsers do of course.

0

Share this post


Link to post
Share on other sites

I don't think there is anything to fix, Opera does lots of things but, as far as I know, it isn't an FTP application, aside from browsing/downloading files from FTP sites like most other web browsers do of course.

Thank loblo

0

Share this post


Link to post
Share on other sites

Thanks again dencorso! I see that Opera 11.60 was recently released. Anyone try it yet?

I have come across one particularly annoying bug in Opera 11.52. For some reason, the PgDn key doesn't properly page down one page at a time. Opera 11.52 tends to skip down much more than a page. I think the PgUp key tends to work better overall but it still may have similar quirky behavior. I don't recall this occurring at all with Opera 10.63.

Edited by Prozactive
0

Share this post


Link to post
Share on other sites

Yes, I have upgraded to Opera 11.60 installing it and running it with Win 2000 compatibility under Kernelex - it works fine.

0

Share this post


Link to post
Share on other sites
Opera 11.60 was recently released. Anyone try it yet?

Opera 11.60 is fine. :yes:

The most annoying bug with those last versions for me, is the loss of the drag&drop to desktop to create an Internet Shortcut.

I didn't found any way except manually to create one now :realmad: .

0

Share this post


Link to post
Share on other sites
Opera 11.60 was recently released. Anyone try it yet?

Opera 11.60 is fine. :yes:

The most annoying bug with those last versions for me, is the loss of the drag&drop to desktop to create an Internet Shortcut.

I didn't found any way except manually to create one now :realmad: .

I was able to fix most of these problems by going to opera:config and placing the name of my problem into the quick find field. Hope this works for you too. Worked well on the latest Opera 12 and 11.60.

Dave

0

Share this post


Link to post
Share on other sites

- is it possible to change the "Search With Google" menu to "Search With Dogpile" instead?

Oh crap I accidentally deleted it, and now I can't figure out how to get it back. :unsure:

0

Share this post


Link to post
Share on other sites

- is it possible to change the "Search With Google" menu to "Search With Dogpile" instead?

What are you talking about?

For the search bar: Ctrl + F12 -> tab 'Search' -> Add... Dogpile (If it is already here, highlight it and click: Edit...)

-> Details -> check the box: 'Use as default Search engine'.

For the right-click menu, you have to restore the 'standard_menu.ini' file.

HTH

Charles.

0

Share this post


Link to post
Share on other sites
I was able to fix most of these problems by going to opera:config

Sorry, but nothing about 'Internet Shortcut' in Opera 11.60's Preferences :} .

0

Share this post


Link to post
Share on other sites

What are you talking about?

For the search bar: Ctrl + F12 -> tab 'Search' -> Add... Dogpile (If it is already here, highlight it and click: Edit...)

-> Details -> check the box: 'Use as default Search engine'.

For the right-click menu, you have to restore the 'standard_menu.ini' file.

HTH

Charles.

That's exactly what I was looking for. Thanks.

I use Dogpile now instead of Google, I just didn't know out how to change the "Search With Google" thing, even though my homepage was set to Dogpile. But now it works. :)

0

Share this post


Link to post
Share on other sites

Thanks for the info. I updated to Opera 11.60 and so far everything seems to work well, except I have the bug again where my past "Find in Page" searches no longer show up in the address field (in the format "f xxxxxx" where xxxxxx is the search term). This also occurred after I updated from Opera 10.63 to 11.51. After a lot of effort, I finally was able to restore the "Find in Page" searches by fiddling around with search.ini. It had somehow gotten extensively modified and I replaced it with the former full version which somehow fixed the problem. Unfortunately, that no longer works for 11.60 and I'm not sure why or what to do now.

Also, the PgDn/PgUp scroll bug I previously mentioned is still there. I thought at first it was fixed but alas, that's not the case. They did finally fix the Wand password missing cursor bug though.

Edited by Prozactive
0

Share this post


Link to post
Share on other sites
I have the bug again where my past "Find in Page" searches no longer show up in the address field

Ctrl + F12 -> tab 'Search' -> in the Search engine list, you must see a line " Find (or Search) in Page ... f ".

But there is many ways to "Find in Page" :

CTRL+F (and then F3 to go to the next instance, Shift+F3 for the previous)

. (dot) or , (coma) or / (slash) on keyboard will open the search bar

There is also several buttons to call a search in Page

HTH

Charles :) .

Edited by CharlesF
0

Share this post


Link to post
Share on other sites

Thanks CharlesF. Yes I'm familiar with the many alternative ways of searching in Opera. It's somewhat difficult to explain this bug but Opera 11.60 no longer shows my previous (saved) Find in Page searches in the address field as I type the string 'f <space>'. Opera 10.63 would automatically display a list of previous (saved) Find in Page searches (in the format "f xxxxxx" where xxxxxx is the search term) in the pulldown list whereupon I could select the one I wanted. I finally was able to restore this functionality to Opera 11.5x by fiddling around with the search.ini file but I am unable to do so with Opera 11.60. I'm starting to suspect it's a deliberate redesign feature of their new address field. I've searched the Opera forums without much luck although there are tons of complaints about similar search issues.

Edited by Prozactive
0

Share this post


Link to post
Share on other sites
I was able to fix most of these problems by going to opera:config

Sorry, but nothing about 'Internet Shortcut' in Opera 11.60's Preferences :} .

Yeah, address field, search field, saved search data etc., also pose other probs to be addressed -- more than likely the final will work better. I'm waiting for that. Many ini's shall need to be rewritten completely (again) for the 98 recognized formats, otherwise the menus shall remain real messes and saved data won't show.

Dave

Edited by dw2108
0

Share this post


Link to post
Share on other sites

@dw2108: I'm using Opera 11.60 FINAL. I presume CharlesF is also. I still have not resolved this Find in Page search issue after more troubleshooting.

0

Share this post


Link to post
Share on other sites

@dw2108: I'm using Opera 11.60 FINAL. I presume CharlesF is also. I still have not resolved this Find in Page search issue after more troubleshooting.

Sorry I forgot to tell you, I'm messing with Opera 12 Alpha & now there's another 12 Beta & I've rewritten so many css, ini and dat files which will be overwritten by the devs at Opera because they noticed a problem & I should have waited for the 12 final.

Dave

0

Share this post


Link to post
Share on other sites

There's still a problem with tabs on bottom, where you just cannot make out which tab is open, tab does not connect with view. It is one of the reasons I did not upgrade to 11.60. I filed in a bug report last time about it, but seems it did not get fixed.

I sent in another bug report.

Edited by TmEE
0

Share this post


Link to post
Share on other sites

Yeah Opera still has a fair number of annoying bugs. I never did figure out a solution to the missing "Find in Page" bug I reported earlier and finally submitted a bug report. Unfortunately it's still not fixed in 11.61.

I just installed 11.61 and so far it seems to be working well. I tried running the setup .exe for the first time and that was a disaster. I finally went back to my tried and true method of manually extracting and replacing all files with 7-Zip.

Edited by Prozactive
0

Share this post


Link to post
Share on other sites

What had happened during running the setup.exe (disaster)? You only can run the setup with comp. mode Win2000SP4. I don't have any kind of problem with the setup if KernelEX 4.5.1 or 4.5.2 is installed.

0

Share this post


Link to post
Share on other sites

Well, the setup installer overwrote and replaced several files I didn't want to be overwritten, eliminated my Windows Native skin preference, and also somehow changed my default system font. After a lot of work, I subsequently figured out how to restore the Windows Native skin but it was extremely aggravating and frustrating. I will always use the manual extract and replace method of upgrading Opera in the future as it gives me full control over which files I want updated. And yes I did select Win2000 SP4 compatibility mode in KernelEx.

0

Share this post


Link to post
Share on other sites

I did not have a problem to install opera 11.61 as an upgrade over 11.60 with windows 2000 compatibility of kernelex 4.5.2.

on windows 98SE. Opera 11.61 operates faster for me then 11.60. It really works much better the Firefox 3.6.26. I have not tried

to print to a pdf though. I will try later.

0

Share this post


Link to post
Share on other sites

Installers beware of Opera 12.00 Alpha version 1289. This baby hooks Intel graphics card drivers and will hastily crash a PC. Best to unpack it and run it until the bugs are worked out.

Dave

EDIT: Workaround

Install in 2000 sp4 mode & configure this version: mail, bookmarks, etc. Then close. Now EXTRACT a new copy and run the EXTRACTED copy. Enough hooks have been set by the install that the extracted version's opera.exe (set to 2000 sp4 mode) will work well.

QUESTION: Are alphas and betas worth discussing? They are called such because they often DO have MAJOR problems.

EDIT #2 Try setting the opera.dll to KernelEX mode 2000 SP4 if you are still having Opera menu GUI problems.

EDIT #3 11.61 FINAL -- Setting this dll to the 2000 SP4 mode cures also the crash problem when Opera tries to open itself, when opening external links, etc.

MAJOR ISSUE: Just found out from an Opera dev that Flash 9 CAN cause the GUI problems with Opera 11.X and 12.X . Opera needs Flash version 10.x or higher. OPERA NOW USES THIS FLASH 10+ DLL FOR ITS GUI! SECURITY RISK?

Edited by dw2108
0

Share this post


Link to post
Share on other sites

I don't know if this will help anyone now that xeno86 has ceased development of KernelEx, but I have figured out the problems with opening Internet shortcuts, .html files, etc. when Opera is running are related to DDE.

If you have DDE enabled in your Windows shell and you launch a shortcut, Opera opens a new window, but it ends up just trying to Google a long string of garbage. (This problem has also been reported in another thread. At least I'm not the only one!)

So just disable DDE in the Windows shell, right? Apparently not. This will force the shell to start another copy of Opera, but apparently, if Opera is already running the new copy just sends the requested URL to the old copy via DDE, then crashes. Dismissing the crash dialog gives the same result as before: a Google search of a string of garbage. (DW2108's suggestion to set opera.dll to Win2KSP4 mode didn't work for me. I'm using Opera 11.61 build 1250.)

I also tried disabling DDE via opera:config. That didn't work either. The second copy just complains that "another user is already running a copy of Opera" and refuses to start.

This bug is particularly annoying when clicking links in emails. Drag-and-drop isn't an available option in that case. I have to end Opera, then click the link and wait for it to reload.

0

Share this post


Link to post
Share on other sites
This bug is particularly annoying when clicking links in emails. Drag-and-drop isn't an available option in that case. I have to end Opera, then click the link and wait for it to reload.

Can't you copy the link and then paste it in Opera's address bar? That's what I am doing.

I sure would love if there was a fix for that bug though.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.