Sign in to follow this  
Followers 0
harufy

Can't install programs and updates

2 posts in this topic

Windows Installer in Vista keeps failing to install updates. Fails for a variety of reasons:

- Auto updates - it goes through the process of installing them but after reboot most have failed and it wants to reinstall them

- Fails to install items like MSE or C++ runtime

- It does try to install items such as Vista Security updates eg KB263371. Security says it updated but then it reappears again as not updated

- at times fail codes (eg 641, 80070645, 2, 490), at other times nothing

Machine is an AcerAspire SA90 with Vista Home Basic SP2, Windows Firewall and Avast A/V

Things I've tried:

1. ran the MS Installation fixit program microsoftfixit.wu.run.exe as administrator. Each time it says it found the problem and fixed it. But running again gives the same result - ie it is not permanently fixing the problem

2. several full virus scans using Avira and Kaspersky boot CD's and again with Avast loaded into Windows. Also checked for root kit virus using Kaspesky online tool. Nothing found

3. run malwarebytes and ccleaner. Nothing found

4. installed fresh copies of msiexec.exe, msihnd.dll and msi.dll from a known good vista machine (file sizes were identical)

5. carried out the three steps listed at http://support.microsoft.com/kb/2642495

6. Observed during installs that the installer service gets started OK. Started the installer service manually.

7. Tried installing updates singly. Some seem to update OK but then reappear as not installed

8. Created a new account with admin permission and tried again using that - no change

9. Uninstalled C++ run time thinking it was the problem (Had to use Revo). Now can't reinstall. This seems to be impacting on Avast.

10. Tried all again with Antivirus and Firewall disabled

11. Uninstalled Avast and tried to firstly MSE and then AVG - both failed to install. Reinstalled Avast but still can't bring up its interface (suspect due to C++ runtime)

12. Ran sfc /scannow and no violations found.

13. Ran MS installer cleanup troubleshooter from http://support.microsoft.com/mats/Program_Install_and_Uninstall. It claimed to have found and fixed corrupt registry keys and uninstall issues

14. Many updates related to .Net framework so uninstalled that. Again no improvement.

Can anyone please offer any more suggestions. I'm running out of hair.

Regards and Happy NY

Keith

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.