Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account



Photo

Can't install programs and updates

- - - - -

  • Please log in to reply
1 reply to this topic

#1
harufy

harufy
  • Member
  • 1 posts
  • Joined 01-January 12
  • OS:Vista Home x86
  • Country: Country Flag
Windows Installer in Vista keeps failing to install updates. Fails for a variety of reasons:
- Auto updates - it goes through the process of installing them but after reboot most have failed and it wants to reinstall them
- Fails to install items like MSE or C++ runtime
- It does try to install items such as Vista Security updates eg KB263371. Security says it updated but then it reappears again as not updated
- at times fail codes (eg 641, 80070645, 2, 490), at other times nothing

Machine is an AcerAspire SA90 with Vista Home Basic SP2, Windows Firewall and Avast A/V

Things I've tried:
1. ran the MS Installation fixit program microsoftfixit.wu.run.exe as administrator. Each time it says it found the problem and fixed it. But running again gives the same result - ie it is not permanently fixing the problem
2. several full virus scans using Avira and Kaspersky boot CD's and again with Avast loaded into Windows. Also checked for root kit virus using Kaspesky online tool. Nothing found
3. run malwarebytes and ccleaner. Nothing found
4. installed fresh copies of msiexec.exe, msihnd.dll and msi.dll from a known good vista machine (file sizes were identical)
5. carried out the three steps listed at http://support.micro....com/kb/2642495
6. Observed during installs that the installer service gets started OK. Started the installer service manually.
7. Tried installing updates singly. Some seem to update OK but then reappear as not installed
8. Created a new account with admin permission and tried again using that - no change
9. Uninstalled C++ run time thinking it was the problem (Had to use Revo). Now can't reinstall. This seems to be impacting on Avast.
10. Tried all again with Antivirus and Firewall disabled
11. Uninstalled Avast and tried to firstly MSE and then AVG - both failed to install. Reinstalled Avast but still can't bring up its interface (suspect due to C++ runtime)
12. Ran sfc /scannow and no violations found.
13. Ran MS installer cleanup troubleshooter from http://support.micro..._and_Uninstall. It claimed to have found and fixed corrupt registry keys and uninstall issues
14. Many updates related to .Net framework so uninstalled that. Again no improvement.

Can anyone please offer any more suggestions. I'm running out of hair.

Regards and Happy NY
Keith


How to remove advertisement from MSFN

#2
Tripredacus

Tripredacus

    K-Mart-ian Legend

  • Super Moderator
  • 10,006 posts
  • Joined 28-April 06
  • OS:Server 2012
  • Country: Country Flag

Donator

Try installing this?
http://www.microsoft...ls.aspx?id=8483
MSFN RULES | GimageX HTA for PE 3-5 | lol probloms
tpxmsfn1_zps393339c1.jpg




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users