Welcome to MSFN

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


Sign in to follow this  
Followers 0
xjairusx

Integrating Windows Vista into 7 for grub4dos usb key

4 posts in this topic

Hi all,

I have managed to use imagex to import my vista x64 and x86 isos into the install.wim files, and have then imported licence files under sources in boot.wim on the w7 iso it is currently using to boot.

Windows 7 appears to work fine and the installer displays all vista images within the .wim....

It manages to copy files and expand them, but upon restarting the system and being presented with the: "please wait while windows sets up your computer..." the vista installer loads and i'm presented with the message: error Windows could not start the installation process.

Upon reboot I am then presented with this: "The computer restarted unexpectedly or encountered an unexpected error. Windows installation cannot proceed. To install Windows, click "OK" to restart the computer, and then restart the installation. When clicking "Ok" the computer than enters a continues loop of death producing the latter error.

post-343059-0-56759000-1326146345_thumb.

post-343059-0-25745400-1326146368_thumb.

0

Share this post


Link to post
Share on other sites

Attempting to load the vista iso loads the vista bootloader however I am presented with the error of: A required CD/DVD drive device driver is missing. If you have a driver floppy disk, cd, dvd, or usb flash drive, please insert it now.

Here are the .lst entries...

find --set-root /ISO/vistasp2x86.iso

map (hd0) (hd1)

map (hd1) (hd0)

map /ISO/vistasp2x86.iso (0xff)

map --hook

chainloader (0xff)

find --set-root /ISO/W7S08SP1.iso

map (hd0) (hd1)

map (hd1) (hd0)

map /ISO/W7S08SP1.iso (0xff)

map --hook

chainloader (0xff)

the root of the usb drive has a \sources\ directoy which contains the install.swms and setup.exe (windows 7).

Any help would be appreciated!

post-343059-0-41107200-1326150601_thumb.

Edited by xjairusx
0

Share this post


Link to post
Share on other sites

You do understand that you are asking about Installing Windows from USB in the Multi-Boot CD/DVDs forum?

Your question should possibly go here:

http://www.msfn.org/board/forum/157-install-windows-from-usb/

:unsure:

However, your report is "strange".

Windows 7 install from USB cannot normally work like that (from .iso) and you will have the same missing CD/DVD error, most probably the fact that you have (why?) duplicated sources like the "install.swms" may be, creates a sort of hybrid install. :ph34r:

You should read this one:

http://reboot.pro/9076/

and check among the proposed solutions:

http://www.rmprepusb.com/tutorials/how-to-create-a-usb-drive-that-will-install-vista-win7-and-server-2008

http://www.rmprepusb.com/tutorials/winiso

http://www.rmprepusb.com/tutorials/firawiniso

jaclaz

0

Share this post


Link to post
Share on other sites

I copied more than the entire sources folder off of the vista dvd into my sources directory on the root of my USB stick. All works now, however copying the entire wim takes a long time in comparison with just a single OS image!

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.