• Announcements

    • xper

      MSFN Sponsorship and AdBlockers!   07/10/2016

      Dear members, MSFN is made available via subscriptions, donations and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, become a site sponsor and ads will be disabled automatically and by subscribing you get other sponsor benefits.
drscouse

RT 7 Lite ignores regional information

14 posts in this topic

Went through the setup, and configured the following (taken from exported settings file)

Accept EULA=True

Select this version on install=True

Setup Language=en-US

Logon count=1

Network location=Home

Protect your computer=Recommended Settings

Specify=True

Keyboard=United Kingdom

Currency and date format=English (United Kingdom)

UI Language=en-US

Timezone=(UTC) Dublin, Edinburgh, Lisbon, London

Yet, when desktop loaded, and I checked in control panel, region and languarge, they were all US, keyboard, currency, time etc.. so basically ignored my choices...

Any ideas?

0

Share this post


Link to post
Share on other sites

Could you attach your Autounattend.xml file ?

0

Share this post


Link to post
Share on other sites

Ive extracted the relevant info... The only option I couldnt change during RT stup was the UI languarge, which only offered en-US

<?xml version="1.0" encoding="utf-8"?>
<!--This answer file generated by RT Seven Lite-->
<unattend xmlns="urn:schemas-microsoft-com:unattend">
<settings pass="windowsPE">
<component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="NonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<SetupUILanguage>
<UILanguage>en-US</UILanguage>
</SetupUILanguage>
<InputLocale>0809:00000809</InputLocale>
<UserLocale>en-GB</UserLocale>
<UILanguage>en-US</UILanguage>
<SystemLocale>en-US</SystemLocale>

I would also like to be prompted to enter computer name and other personal info unique to a pc, as I will be using this image on several home computers and want to be able to given them unique info during setup. Also seems that I cant define workgroup settings as suggested druing RT confign "Compute rname, domain and workgroup settings"...

post-11890-0-95341200-1326893906_thumb.j

Edited by drscouse
0

Share this post


Link to post
Share on other sites

Havent actually removed anything.. simply did unattended bits, and added 2 tweaks!

<?xml version="1.0" encoding="utf-8"?>
<!--This answer file generated by RT Seven Lite-->
<unattend xmlns="urn:schemas-microsoft-com:unattend">
<settings pass="windowsPE">
<component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="NonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<SetupUILanguage>
<UILanguage>en-US</UILanguage>
</SetupUILanguage>
<InputLocale>0809:00000809</InputLocale>
<UserLocale>en-GB</UserLocale>
<UILanguage>en-US</UILanguage>
<SystemLocale>en-US</SystemLocale>
</component>
<component name="Microsoft-Windows-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="NonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<ImageInstall>
<OSImage>
<InstallFrom>
<MetaData wcm:action="add">
<Key>/IMAGE/NAME</Key>
<value>Windows 7 ULTIMATE</value>
</MetaData>
</InstallFrom>
<InstallToAvailablePartition>false</InstallToAvailablePartition>
<WillShowUI>OnError</WillShowUI>
</OSImage>
</ImageInstall>
<UserData>
<ProductKey>
<Key>REMOVED</Key>
<WillShowUI>OnError</WillShowUI>
</ProductKey>
<AcceptEula>true</AcceptEula>
</UserData>
</component>
</settings>
<settings pass="oobeSystem">
<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="NonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<UserAccounts>
<LocalAccounts />
</UserAccounts>
<OOBE>
<NetworkLocation>Home</NetworkLocation>
<ProtectYourPC>1</ProtectYourPC>
<HideWirelessSetupInOOBE>false</HideWirelessSetupInOOBE>
<SkipMachineOOBE>false</SkipMachineOOBE>
<SkipUserOOBE>false</SkipUserOOBE>
</OOBE>
<DisableAutoDaylightTimeSet>false</DisableAutoDaylightTimeSet>
<TimeZone>GMT Standard Time</TimeZone>
</component>
</settings>
<settings pass="specialize">
<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="NonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" />
</settings>
</unattend>

0

Share this post


Link to post
Share on other sites

I think this can be done like this:


<?xml version="1.0" encoding="utf-8"?>
<unattend xmlns="urn:schemas-microsoft-com:unattend">
<settings pass="windowsPE">
<component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<SetupUILanguage>
<UILanguage>en-US</UILanguage>
</SetupUILanguage>
<InputLocale>0809:00000809</InputLocale>
<SystemLocale>en-GB</SystemLocale>
<UILanguage>en-US</UILanguage>
<UserLocale>en-GB</UserLocale>
</component>
<component name="Microsoft-Windows-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<DiskConfiguration>
<WillShowUI>Always</WillShowUI>
</DiskConfiguration>
<ImageInstall>
<OSImage>
<InstallFrom>
<MetaData wcm:action="add">
<Key>/IMAGE/NAME</Key>
<value>Windows 7 ULTIMATE</value>
</MetaData>
</InstallFrom>
<InstallToAvailablePartition>true</InstallToAvailablePartition>
<WillShowUI>OnError</WillShowUI>
</OSImage>
</ImageInstall>
<UserData>
<AcceptEula>true</AcceptEula>
<ProductKey>
<Key>XXXXX-XXXXX-XXXXX-XXXXX-XXXXX</Key>
<WillShowUI>OnError</WillShowUI>
</ProductKey>
</UserData>
</component>
</settings>
<settings pass="specialize">
<component name="Microsoft-Windows-Security-SPP-UX" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<SkipAutoActivation>true</SkipAutoActivation>
</component>
</settings>
<settings pass="oobeSystem">
<component name="Microsoft-Windows-International-Core" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<InputLocale>0809:00000809</InputLocale>
<SystemLocale>en-GB</SystemLocale>
<UILanguage>en-US</UILanguage>
<UserLocale>en-GB</UserLocale>
</component>
<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<TimeZone>GMT Standard Time</TimeZone>
<OOBE>
<HideEULAPage>true</HideEULAPage>
</OOBE>
</component>
</settings>
</unattend>

Let me know if it works for you!

*Edit: You can also add more keyboard layouts:


<settings pass="oobeSystem">
<component name="Microsoft-Windows-International-Core" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<!-- You can add keyboards here: examples: en-GB, en-US, en-CA, fr-CA -->
<InputLocale>0809:00000809;0409:00000409;1009:00001009;0c0c:00000c0c</InputLocale>
<SystemLocale>en-GB</SystemLocale>
<UILanguage>en-US</UILanguage>
<UserLocale>en-GB</UserLocale>
</component>

Edited by myselfidem
0

Share this post


Link to post
Share on other sites

I tried your config but for some reason I am now prompted to select the language at the beginning of the setup....

Which I supposes gives me the chance to select the correct one, but not very unattended!

Thanks for your help

EDIT: Ttrying again as I spotted an error when I copied it!... my fault!

Nope.. doesnt seem to work.. I simply copied all your code and entered in into a clean file and entered my key in.. It stops and asks me to chose language options and begining of install...

Edited by drscouse
0

Share this post


Link to post
Share on other sites

Nope.. doesnt seem to work.. I simply copied all your code and entered in into a clean file and entered my key in.. It stops and asks me to chose language options and begining of install...

Which language option do you have to choose?

Could you past your new Autounattend.xml file, please?

At last do you have the keyboard layout for en-GB?

0

Share this post


Link to post
Share on other sites

Nope.. doesnt seem to work.. I simply copied all your code and entered in into a clean file and entered my key in.. It stops and asks me to chose language options and begining of install...

Which language option do you have to choose?

Could you past your new Autounattend.xml file, please?

At last do you have the keyboard layout for en-GB?

My new file is the one you posted above, I assumed this had been modified/corrected and I could simply copy and paste that int a blank Autounattend.xml file and add my product key in... I also get this error after continuing the install, see attached...

post-11890-0-06159400-1327001731_thumb.j

0

Share this post


Link to post
Share on other sites

You've made an error when you have copied the file...Check it with WSIM or attach your Autounattend.xml file, please and remove your product key inside!

Here is my file: try it and let me know the result, thanks! Add your product key inside!

Edited by myselfidem
0

Share this post


Link to post
Share on other sites

Now I changed 2 things this time..

First I used your .xml file...

Second, I noticed the VMWare was using an Easy Install wizard which was asking for the key and my username etc.. so I am wondering if this was causing an issue.. I chose not to use this option to install this time, and it seemed to work...

So dont know if it was the xml file you provided, or disabling the Easy Install thing in vmware!!

But seems to be working...

Thanks!!!

0

Share this post


Link to post
Share on other sites

Now I changed 2 things this time..

First I used your .xml file...

Second, I noticed the VMWare was using an Easy Install wizard which was asking for the key and my username etc.. so I am wondering if this was causing an issue.. I chose not to use this option to install this time, and it seemed to work...

So dont know if it was the xml file you provided, or disabling the Easy Install thing in vmware!!

But seems to be working...

Thanks!!!

Nice ! :)

The problem when we copy/paste some Autounattend.xml file inside the editor inside a post, you can see that the URL are writed TWICE and an error occurs during the installation...I always check the files with WSIM:

http://www.msfn.org/...post__p__970087

I will try to avoid this issue next time! The Autounattend.xml file attached is the same as the one posted above.

Edited by myselfidem
0

Share this post


Link to post
Share on other sites

Decided to start from scratch and used RT again to build new image, and skipped the Easy Install part of VMWare and it was all ok.. seems the VMWare bit was perhaps overwriting part of the unattended info created by RT...

Thanks for you help

0

Share this post


Link to post
Share on other sites

I found the workaround about URL's writed TWICE inside the posts with the editor for Autounattend.xml or xml files inside the forum. :rolleyes:

If I copy/paste the code we can see this error: http:// writed twice:

Example with error:


<component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="[url="http://schemas.microsoft.com/WMIConfig/2002/State"]http://schemas.microsoft.com/WMIConfig/2002/State[/url]" xmlns:xsi="[url="http://www.w3.org/2001/XMLSchema-instance"]http://www.w3.org/2001/XMLSchema-instance[/url]">

And if we use this workaround:

Simply click the line with http:// and click on the icon on the top left: Remove formatting. And now all is fine!

Correct example:


<component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

Errors occurs when we copy/paste some examples on the forum with this coding error!! I will update all my posts! Posts updated inside this thread !

Edited by myselfidem
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.