Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account


Photo

"device not ready" [SOLVED]

- - - - -

  • Please log in to reply
5 replies to this topic

#1
ExpertNoob

ExpertNoob
  • Member
  • 4 posts
  • OS:2003 x86
  • Country: Country Flag
Hi,
Just installed Windows Server 2003 (R2) on a PC that runs XP just fine.
All partitions without a drive letter are "device not ready" !! Can't format a partition (ext4) that's not christened :} Can't mount TrueCrypt volumes..
Add a drive letter, and everything's back to normal. Remove it : "device not ready"

Installing chipset driver and other drivers (for all devices) changes nothing..

ANY ideas ? I got nothing.

Thx

Edited by ExpertNoob, 17 October 2012 - 07:12 AM.



How to remove advertisement from MSFN

#2
blackwingcat

blackwingcat

    Friend of MSFN

  • Member
  • PipPipPipPipPip
  • 764 posts
  • OS:Windows 2000 Professional
  • Country: Country Flag

Hi,
Just installed Windows Server 2003 (R2) on a PC that runs XP just fine.
All partitions without a drive letter are "device not ready" !! Can't format a partition (ext4) that's not christened :} Can't mount TrueCrypt volumes..
Add a drive letter, and everything's back to normal. Remove it : "device not ready"

Installing chipset driver and other drivers (for all devices) changes nothing..

ANY ideas ? I got nothing.

Thx


1. Ext2Fsd: It can read ext4 format.
2. Partition type changer: It is a utility which change s partition type. Try to change drive type to NTFS or FAT. you can access driver and format after reboot.
3. If you have windows 2000. I think you can format the drive after install it :)
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
BlackWingCat =^^=
http://blog.livedoor.jp/blackwingcat/
+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

#3
ExpertNoob

ExpertNoob
  • Member
  • 4 posts
  • OS:2003 x86
  • Country: Country Flag
blackwingcat: I can do what I want after assigning a drive letter, no special tools needed.
The question is: why ?! Under XP (on the same machine), I don't have to !

I have this problem with Windows Server 2003.

#4
bphlpt

bphlpt

    MSFN Addict

  • Member
  • PipPipPipPipPipPipPip
  • 1,797 posts
  • OS:none specified
  • Country: Country Flag
Dumb question - if you don't have a drive letter assigned to the drive, how do you address it? And why would you NOT want the drive to have a drive letter? I'm confused.

Cheers and Regards

Posted Image


#5
ExpertNoob

ExpertNoob
  • Member
  • 4 posts
  • OS:2003 x86
  • Country: Country Flag

if you don't have a drive letter assigned to the drive, how do you address it? And why would you NOT want the drive to have a drive letter?


Almost all my drives are encrypted, I have like 5 encrypted partitions (I'm using TrueCrypt). I don't want those to have assigned drive letters: it's useless (they are encrypted !) and dangerous (some soft could try to access them and ruin them - only TrueCrypt should access them when mounting them). Besides, it messes "My Computer"..

When I boot on a disk having Windows XP, I can mount them (even though they don't have assigned drive letters).
When I boot on the W2k3 disk, I can't ("The device is not ready"). Unless I assign them drive letters (so, they ARE ready, after all !!).

Regardless, what I'm seeing under W2k3 is that a volume without an assigned drive letter somehow becomes "not ready". I can't reformat the second partition of the system disk (hosting the system on it's first partition) if I remove it's drive letter ! That doesn't happen under XP ! And it doesn't make sense (how can the disk the system is booting from not be "ready" ?!). :wacko:

I hope that's clear enough.

Edited by ExpertNoob, 12 April 2012 - 04:22 AM.


#6
ExpertNoob

ExpertNoob
  • Member
  • 4 posts
  • OS:2003 x86
  • Country: Country Flag
Ok, found a solution: just used a partitionning software (DiskDirector) to change the type of those pesky partitions to Unknown (0Dh) :wacko:
I have no idea why this is necessary, it just works ! (W2k3 didn't like partition IDs or something ?!)
Hope this will be useful to somebody out there.

Cheers.

Edited by ExpertNoob, 18 October 2012 - 05:25 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users



How to remove advertisement from MSFN