tomasz86

Unofficial SP 5.2 for Microsoft Windows 2000 (WIP)

994 posts in this topic

tomasz86, I am not clear on the error you get with wintrust.dll, I did not see a specific description or screenshot of it.

This dll is involved with digital certificates on a running OS, it is not involved with setup.

To expand more on what acus said, do a global replace in both TXTSETUP and LAYOUT of ,_x, to ,, (comma underscore x comma ---> comma comma)

Hacking SFC is handy but doesn't relate to wintrust. This may be handy for you, it is buried in my site

edit: by "This dll is involved with digital certificates on a running OS, it is not involved with setup" I mean there is nothing you can do during setup to suppress errors from this dll later. An error thrown because of this means another dll that windows is attempting to verify is failing verification. So strictly speaking, another dll might be the actual problem.

Edited by fdv
0

Share this post


Link to post
Share on other sites

@desertofunknown

Hmm, what do you mean exactly by using SVN?

@fdv

This is the exact error:

g2oCM.jpg

xYfJO.jpg

and I think that these are the catalogs which cannot be installed:

iD8dV.jpg

There are probably two easy ways to overcome it:

  1. Remove the catalogs from syssetup.inf so that setup will be able to continue with the current wintrust.dll. SFC must be disabled too.
  2. Use an official version of wintrust.dll in the first part of the setup and then replace it with the current one during T-13. This method can be implemented in a service pack but cannot in case of a rollup slipstreamed with HFSLIP.

To expand more on what acus said, do a global replace in both TXTSETUP and LAYOUT of ,_x, to ,, (comma underscore x comma ---> comma comma)

Don't you have to disable SFC when doing this too?

Edited by tomasz86
0

Share this post


Link to post
Share on other sites

Ahhh! Okay, now I get you... catalogs.

Since you are replacing a lot of binaries in a SP (of your own making) and not installing the CAT files that come with each hotfix, you might as well delete all of the listed CATs except the first two, NT5INF and NT5. That's how I did what I did and it worked. IIRC SP4.CAT can go too. FYI, I know you know this but for other people reading, if you wanted to make an unofficial SP where each file actually passed a signature verification, you would need to copy all of the CAT files in each hotfix and list them ALL under [ProductCatalogsToInstall].

I honestly forget what happens when you install no CATs at all.

My hacked SETUPAPI.DLL turns off all signature checking and I use that in conjunction with the SFC.DLL hack. You can get both in my fileset. Since they are MSFT binaries permission is not mine to give, but if you wanted to use the ones from my fileset, I personally have no problem with that.

Some part of me thinks that even with all of this you might still get a problem with a different WINTRUST. Worth checking into if it eliminates your error.

0

Share this post


Link to post
Share on other sites

@desertofunknown

Hmm, what do you mean exactly by using SVN?

I mean using SVN via a place like Sourceforge would allow you to make revisions and undo them easily and also allow you to have other developers easily commit to your project SVN is more a newer tool for open source development and every time you commit to your project a version is made and all data is stored on the website database allowing you to reverse changes check threw all your progress ect in one easy to use area

0

Share this post


Link to post
Share on other sites

That sounds like a good idea, but since, as fdv said, the binaries of many of the pieces of tomasz86's work come from MS, (even though they are no longer supported in any way by MS, just like a lot of the Win98 pieces that are discussed on this forum), MS might have a problem with them being posted on Sourceforge and then being worked on by multiple people. There might not be any issue, but...

Cheers and Regards

0

Share this post


Link to post
Share on other sites

That sounds like a good idea, but since, as fdv said, the binaries of many of the pieces of tomasz86's work come from MS, (even though they are no longer supported in any way by MS, just like a lot of the Win98 pieces that are discussed on this forum), MS might have a problem with them being posted on Sourceforge and then being worked on by multiple people. There might not be any issue, but...

Cheers and Regards

Perhaps then we should as Microsoft for permission to work on them.... I think if we explain the situation and we tell them our goals and describe to them and insure them that we will not edit the files in anway that would cause a problem with Microsoft as well make sure that Microsoft does not take blame for any security flaws that might happen because of our work on it and agree not to distribute any of the files to anyone that does not already own the system then im sure they would be willing to allow us to improve on there operating systems foundation

0

Share this post


Link to post
Share on other sites

Your idealism and optimism knows no bounds! I totally agree that is the way it should be in a perfect world, but unfortunately their behavior and decisions around the world in their entire history say that will not happen. Some of the MS support team are members and contributors on this board and, to my knowledge, they have never made a single post in any of the threads having to do with extending or modifying any of the Win98 or Win2K files discussed in any of the threads here even though they would be aware of the work being done just by looking at the forum index. Some might argue that their silence implies consent, but somehow I doubt that. Again, I could be wrong, but...

Cheers and Regards

Edited by bphlpt
0

Share this post


Link to post
Share on other sites

Your idealism and optimism knows no bounds! I totally agree that is the way it should be in a perfect world, but unfortunately their behavior and decisions around the world in their entire history say that will not happen. Some of the MS support team are members and contributors on this board and, to my knowledge, they have never made a single post in any of the threads having to do with extending or modifying any of the Win98 or Win2K files discussed in any of the threads here even though they would be aware of the work being done just by looking at the forum index. Some might argue that their silence implies consent, but somehow I doubt that. Again, I could be wrong, but...

Cheers and Regards

Hmm well I think if we give them a chance they will come around

0

Share this post


Link to post
Share on other sites

@desertofunknown

Like bphlpt has already written, I don't think that this project belongs to SourceForge simple because almost all files included in it come from M$ being either the original ones or modified versions. Therefore it's not open source.

I have just uploaded a new daily version of UURollup-v11 (if it's not there yet then check again one hour later). All files have been updated to the newest available versions and I've also added several files from IE6 SP3 (they're installed only if IE6 is present in the system). The wintrust.dll problem still persists and there's also another issue with slipstreaming so at the moment this version can be only installed manually. Also starting from this version UURollup now officially requires Update Rollup 2 to be present in the system before installation.

Edited by tomasz86
0

Share this post


Link to post
Share on other sites

http://www.windows2000.tk/ has referenced this topic for discussion about UURolup.

I reinstalled my computer with

Windows 2000 SP3

installed SP4

installed Update Rollup 1

installed Update Rollup 2

then i installed UURollup and after the reboot, the computer reboots after the pause at startup that some installations have, you shouldnt say its 'complimentary' on the windows2000.tk site , but 'avoidable'....

also you need to remove the statements that update rollup 1 is in update rollup 2 in this topic: (because that is false, causes BSOD on boot up, when done without UR1)

BTW, how do you install the latest java? i can only get success with 6u29, and no further than 6u33 (original file needs downloading, Sun has updated all their old versions to use a new win2000-unfriendly installer). i ask because i get the occaisional web advertiser trying to put trojans on the computer. i use comodo and host files to defend against that but the latest java is best.

Charlie.

Edited by charlieb001
0

Share this post


Link to post
Share on other sites

I'm not sure if I understand the comment about UURollup, Update Rollup 1 and Update Rollup 2 correctly. Which version of UURollup did you install? The last stable version of UURollup requires only SP4+UR1 (or USP5.1) to be present but the new daily versions require SP4+UR1+UR2 (or USP5.1+UR2) to work. Update Rollup 2 itself requires SP4+UR1 (or USP5.1).

The other topic about UR2 is about the old package which was completely different than the current one. That's why it says "suspended / discontinued" in the title so you should just ignore it.

The offline installer of the latest Java 6 just works on my system (with UURollup-v10c installed).

Edited by tomasz86
0

Share this post


Link to post
Share on other sites

I've uploaded a new weekly version of UURollup-v11. It's very similar to the last daily. I just added some cosmetic fixes and tested it more thoroughly.

Important! It's impossible to slipstream it directly but you can put it in HFSVCPACK_SW1 while UURollup-v10c must be placed in HF at the same time.

0

Share this post


Link to post
Share on other sites

I've uploaded a new daily version of UURollup. No big changes this time. I've just updated and added files from the newest version of the BWC kernel.

At the moment I'm working on the .NET Framework merged installer again. This time I want to have it done 100% automatically so I've been working on a script which would repack and merge the OnePiece's .NET Framework addons (and make changes / fix problems if necessary). It should be ready shortly because I want to reinstall Win2k on my computer as soon as possible (my current system has become very messy) and I actually need this .NET Framework merged installer for myself too :P

Edited by tomasz86
0

Share this post


Link to post
Share on other sites

@Hackeronte

Hello again :) I was actually waiting for you :w00t:

OnePiece's packages are indeed fantastic and very useful if you want to just integrate one big update pack and have your system updated. The problem is that at the moment that Update Pack hasn't been updated for a long timeand that it only covers official updates. The hundreds of HBRs included in UR2 and the unofficial updates from UURollup are not included there. Some of the other official updates released after EOL are also not included. Of course you can just use that pack and install the missing updates manually later.

As for the ITA version, I'd recommend that you download the latest weekly version of UURollup-v11 and check its structure. It's pretty stable and the basic structure shouldn't change a lot in the future too so you can just accustom yourself with it now.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.