tomasz86

Unofficial SP 5.2 for Microsoft Windows 2000 (WIP)

994 posts in this topic

Now I’m confused. Tomasz86, in post #428 you used the term “Unofficial Update Rollup 2.” I didn’t think there was any such thing. Is this the same as “Update Rollup 2?” I thought “Update Rollup 2” was comprised of only official updates. Are you referring to it as “unofficial” in the sense that those official updates (between Update Rollup 1 v.2 and EOL) were never officially packaged together?

0

Share this post


Link to post
Share on other sites

https://www.dropbox.com/sh/ch0oa53ew4i4fxq/dlBhq8Tk0f/Public/Windows2000/UpdateRollup2/Stable

This is the Unofficial Update Rollup 2, it contains MS only Windows Update files. Sometimes it is referred to as Unofficial Update Rollup 2 or just plain old Update Rollup 2. Either way, they're both the work of Tomasz and they do NOT provide any type of kernel extensions that Microsoft did not intend for Windows 2000. This is just the last of the Windows Update files that Microsoft didn't bring out as a rollup pack I believe. I think installing it will make it a completely patched Windows 2000 machine when it comes to hotfixes and security updates.

Edited by Tommy
0

Share this post


Link to post
Share on other sites

I released Japanese version Windows 2000 Extended Kernel Hfslip package.

It includes following functions.

- Extended Core and Extended kernel(NT6.0 version) applied

- High speed Network Setting.

- Recentest Java 6u43 / Flash 11.6 / ShockWave 12 / Adobe Air 3.6 / Firefox 17.0.4 /Google Earth / Picasa installed

- Windows Defender / Movie Maker 2.6 / MSN Game Zone / Remote Desktop Client 7.0 / Skype 6.0 / Microsoft Virtual CD Application / OutLook Express 6 SP2 / IME 2010 SP1 / Journal Viewer 1.5 / Windows Scrip-t Host 5.8 / User Profile Hive Cleanup Service / PowerToy Calc / Media Player 10 / Media Encoder / Network Monitor 3.4 / MDAC 2.8SP2 are available.

- It supports SATA / USB 2.0 / 3.0 Keyboards.

- IE6 SP1 + MS13-021 + Windows LiveToolbar applied.

- Direct X 9.0 + XAudio extension are installed.

- .Net 1.0SP3/1.1SP1/2.0SP2/3.0SP2/3.5SP1 + Security update applied.

- It contains XNA and SlimDX and Power Shell v1.0.

- Vista screen savers .

- PhysX and Demos

- Free fonts

- VB6 / VC++ 2002/2003/2005 SP1/2008 SP1/2010 SP1/2012 Runtimes

- RSA / AES / SHA-2 are supported.

http://blog.livedoor.jp/blackwingcat/archives/1761775.html

Edited by blackwingcat
0

Share this post


Link to post
Share on other sites

但愿会有一个英文版本;)

0

Share this post


Link to post
Share on other sites

Okay since yesterday I ran into a number of issues-I installed in the order I mentioned before, only to run into a problem when I restarted the computer, it would go to the Win2000 loading screen then the computer would restart as though I hit the restart button! This happened with UUrollupv10e and the current stable version of 10. I thought I was going to have to settle for WinXp again, but I downloaded the current version of UUrollup11 and gave it one last try-for some reason version 11 works! I have a windows 2000 setup with the current version of Firefox and Semonkey on it-YAY! :thumbup

0

Share this post


Link to post
Share on other sites

I've just uploaded two new daily versions - one of UURollup-v11 and one of UURollup-v10e. I removed a file called "normaliz.dll" from both of them. It was the culprit which prevented new versions of Skype (>5.9) from sending text messages.

tomasaz,

I been trying to test your new versions of UURollups. I continue to have an issue with v10 when slipstreaming with HFSLIP. The issue is with WMP9 and the error below.

I only have the following in HF nothing in the other folders (HFCABS, HFSVCPACK, HFSVCPACK_SW1, and HFSVCPACK_SW2):

MPSetup.exe

w2ksp51.exe

Windows2000-UpdateRollup2-x86-ENU.exe

Windows2000-UURollup-v10e-d20130312-x86-ENU.exe

I can hit ok and setup finishes and WMP9 is installed. I run unattended installs so would like it error free.

I have no issues with v11 as that installs fine. It only happens with v10.

Any thoughts? Appreciate your help.

M2GD

post-224904-0-21616100-1363576467_thumb.

0

Share this post


Link to post
Share on other sites

I've had this too, I know whatever version is slipstreamed into his November 2012 package, it has this issue.

0

Share this post


Link to post
Share on other sites

@bluebolt As Tommy has already said, I added "unofficial" to distinguish between official M$ releases and others. It doesn't really matter whether there are new modified files or whether it's just a compilation of official M$ files - it's still an unofficial package after all. In one word - Update Rollup 2 = Unofficial Update Rollup 2.

@blackwingcat I've already seen it on your blog before... and I'm actually very happy that you started to play around with HFSLIP as it's now possible to integrate your kernel32.dll directly into Windows source (and you've also fixed videoprt.sys, haven't you?) :thumbup

@OldSchool38 I'm glad that you've finally managed to get your system work. I wouldn't be surprised if the current builds of UURollup-v11 were actually more stable than UURollup-v10x. The reason is that UURollup-v11 is constantly updated and fixed while UURollup-v10x still uses the same old version of WildBill's kernel.

@My2GirlsDad,Tommy This particular issue is a strange one. I remember that you had already told me about it before, right? The problem is that I can't reproduce it in my environment :blink:

Edited by tomasz86
0

Share this post


Link to post
Share on other sites

I've just uploaded two new daily versions - one of UURollup-v11 and one of UURollup-v10e. I removed a file called "normaliz.dll" from both of them. It was the culprit which prevented new versions of Skype (>5.9) from sending text messages.

tomasaz,

I been trying to test your new versions of UURollups. I continue to have an issue with v10 when slipstreaming with HFSLIP. The issue is with WMP9 and the error below.

I only have the following in HF nothing in the other folders (HFCABS, HFSVCPACK, HFSVCPACK_SW1, and HFSVCPACK_SW2):

MPSetup.exe

w2ksp51.exe

Windows2000-UpdateRollup2-x86-ENU.exe

Windows2000-UURollup-v10e-d20130312-x86-ENU.exe

I can hit ok and setup finishes and WMP9 is installed. I run unattended installs so would like it error free.

I have no issues with v11 as that installs fine. It only happens with v10.

Any thoughts? Appreciate your help.

M2GD

It is Shell Space Function Problem on Windows 2000.

We must indicate resource name directly.

Ex)

@foobar.dll,-123341 -> "this is test"

@blackwingcat I've already seen it on your blog before... and I'm actually very happy that you started to play around with HFSLIP as it's now possible to integrate your kernel32.dll directly into Windows source (and you've also fixed videoprt.sys, haven't you?) :thumbup

videoprt.sys was fixed since Kernel Core v13 :)

Edited by blackwingcat
0

Share this post


Link to post
Share on other sites

Something related to Internet Explorer is in Japanese, specifically when it asks you about others being able to see what you're searching for.

0

Share this post


Link to post
Share on other sites

Something related to Internet Explorer is in Japanese, specifically when it asks you about others being able to see what you're searching for.

It's because of JPN urlmon.dll.

0

Share this post


Link to post
Share on other sites

I get that unreadable IE screen, too, from UUR Mar12. Also, Windows Update says I need Update Rollup 1. I notice there’s a new Daily up now. I will try it.

Regarding the .net frameworks, 1-4 install fine, but then Windows Update says I need 2.0 Service Pack 1. This has been the case in every version after 1210260023.

I don’t let Windows Update run any of these updates. Is that right?

0

Share this post


Link to post
Share on other sites

You must not use Windows Update when using any unofficial updates.

That's why UURollup completely disables Automatic Updates. Windows Update should be used only in systems with no unofficial updates installed.

0

Share this post


Link to post
Share on other sites
That's why UURollup completely disables Automatic Updates. Windows Update should be used only in systems with no unofficial updates installed.

The only sole exception to this is if you use Windows Defender. Automatic updates on Windows Defender require the latest version of Windows Update to be installed but then you can go through the program, and not the Windows Update site.

0

Share this post


Link to post
Share on other sites

First, tomasz86, thank you for your work on the Windows 2000 archive, and for this thread. I also want to express my appreciation for the contributions of others here, all of which has improved my knowledge of the W2K operating system and given me a better sense of its workings. You have helped make my Windows 2000 project seem, well, slightly less impossible. Thank you again.

My goal was to set up Windows 2000 Professional on modern hardware, specifically an Intel Sandy Bridge processor and a Z-77 motherboard, and I am now running such an installation. There are no unknown devices in Device Manager (with the caveat that I am using an X600 video card rather than the integrated graphics).

The problem I’m having concerns the lack of USB function during the installation process. Because of this, I have to use a PS/2 keyboard or mouse (and I do mean keyboard or mouse, because my motherboard has only one PS/2 connector). This means I plug in the keyboard during the text part of the install, then shut down the system via the keyboard, then change the keyboard out for the PS/2 mouse, then start it back up. From there, I am able to get into Device Manager to let Windows install the USB drivers (which are apparently there on the computer the whole time in c:\winnt\inf\oem10.inf) so that I can use a USB keyboard and mouse. Then everything’s fine.

Is there a way I can have USB function from the get-go? Because sometimes the system won’t recognize the PS/2 mouse during installation, and when that happens, I’m stuck. This has limited my ability to conduct experiments with others’ W2K installation files, for example the populated HFSLIP folders you make available through Dropbox.

Today I tested a new renesas USB PCI card, with an eye toward integrating its drivers into my W2K installation disc with nLite. But first I’m trying to simply install the card in the existing Windows enviroment, to see if it even works with W2K. So far, I have not been able to make the card work.

If someone has any ideas how to at least make the generic built-in USB drivers work automatically during the initial installation, I would really appreciate your sharing those ideas with me.

I have a very similar system (Ivy Bridge) which when Win2k installs, it does not detect the USB 2 Ports! So, If I use the oem10.inf, will the USB work?

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.