Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account


Photo

Unofficial SP 5.2 for Microsoft Windows 2000


  • Please log in to reply
719 replies to this topic

#701
tomasz86

tomasz86

    www.windows2000.tk

  • Members
  • PipPipPipPipPipPipPipPip
  • 2,497 posts
  • OS:XP Pro x86
  • Country: Country Flag
Unfortunately blackwingcat hasn't been able to fix the Javascript problem :( It's a known bug and has been present since the very beginning. You can check this post and the further ones:

http://www.msfn.org/board/topic/159004-uxthemedll/?p=1018200

where this particular issue was discussed.
 

The reason is unknown yet, so it is difficult.
 

The problem occurs since version 0.4, when it shows Javascript dialog. wacko.gif

I see. I suppose that there's no easy fix for this, right? :}




How to remove advertisement from MSFN

#702
Zettoz

Zettoz
  • Members
  • 1 posts
  • OS:Windows 2000 Professional
  • Country: Country Flag

Not sure if I am reading incorrectly or doing it completely wrong. But these patches are supposed to get .net framework 4.0 to work on windows 2000 profession correct? I cannot seem to get it to work whatsoever.



#703
Tommy

Tommy

    Brooke's Tommy honey <3

  • Members
  • PipPipPip
  • 442 posts
  • OS:98SE
  • Country: Country Flag

Not sure if I am reading incorrectly or doing it completely wrong. But these patches are supposed to get .net framework 4.0 to work on windows 2000 profession correct? I cannot seem to get it to work whatsoever.

Hi Zettoz, have you tried using these packages for .NET Framework installation: https://drive.google...y13dTlXOWs#list

You cannot use the Microsoft distributed ones that I know of on Windows 2000, tomasz86 has these specially crafted to install and run on Windows 2000, and they do work, I've used .NET 4 applications on Windows 2000 using these updates and they run flawlessly. Good luck! Oh, and you'll need 7Zip or WinRAR to open these packs. The plus part is it installs every single .NET Framework package all in one, so no need to do them all separately!


Edited by Tommy, 19 February 2014 - 05:46 PM.


#704
aofarrell2

aofarrell2

    Newbie

  • Members
  • 17 posts
  • OS:Windows 2000 Professional
  • Country: Country Flag

Hey Guys,

 

Just a quick update of how my Windows 2000 is running, this time on my new laptop with 2GB RAM and a Intel Core 2 Duo 1.6Ghz.

 

Windows 2000 recognizes and uses BOTH cores!

 

Also, I have been having great success running the Windows XP drivers using UURollup V11 and UURollup 2 Stable and USP5.1. My laptop was designed for XP so I've been very happy to get the XP drivers working in Win2K!



#705
Tommy

Tommy

    Brooke's Tommy honey <3

  • Members
  • PipPipPip
  • 442 posts
  • OS:98SE
  • Country: Country Flag

Hey Guys,

 

Just a quick update of how my Windows 2000 is running, this time on my new laptop with 2GB RAM and a Intel Core 2 Duo 1.6Ghz.

 

Windows 2000 recognizes and uses BOTH cores!

 

Also, I have been having great success running the Windows XP drivers using UURollup V11 and UURollup 2 Stable and USP5.1. My laptop was designed for XP so I've been very happy to get the XP drivers working in Win2K!

Glad to hear it! Windows 2000 is great when it comes to using dual core processors. Blackwingcat runs even i5 processors I believe. Sometimes you can get lucky and run XP only drivers for Windows 2000. Usually anything Windows XP Service Pack 2 and below for drivers works on Win 2000. It seems like anything that requires XP SP3 has issues and I'm not sure what it is. Either way, I'm glad you're running great. I helped my girlfriend get Windows XP on her Dell Inspiron 660 machine which was designed for Windows 7 which was pretty iffy for the system build but I bet it could even run Windows 2000 without a hitch. I've been focusing a bit more on Windows 98 lately but my main machine still runs 2000. It's a great system!



#706
ironman14

ironman14

    Member

  • Members
  • PipPip
  • 135 posts
  • OS:Windows 2000 Professional
  • Country: Country Flag
@tomasz86. I still use chrome sometimes but my main browser is Firefox on 2k. It works good but YouTube videos seem to lag sometimes, which is a little strange considering I have FF 26(may need to upgrade to 27.0.1),Flash 12.0.70 and 1 GB RAM.

Also, have you ever considered adding in a tool like fcwin2k into UURollup? I have used it personally, and have been able to install certain programs such as QuickTime 7.7.x and iTunes 10.x on Windows 2000. Application Compatibility Launcher is good and useful, but it doesn't work with every single app, particularly apps that need you to rewrite the MSI.

Thanks for all your work on UURollup.

#707
tomasz86

tomasz86

    www.windows2000.tk

  • Members
  • PipPipPipPipPipPipPipPip
  • 2,497 posts
  • OS:XP Pro x86
  • Country: Country Flag
@ironman14

Firefox is less smooth than Chrome in general, but in case of YouTube it's the CPU / graphics power that's responsible for playing videos. Could you give more details about your hardware configuration?

The current version of Application Compatibility Launcher is very simple (primitive would be a better word to describe it  :o). What it does is to tell the program that the OS is Windows XP. It doesn't modify any files, etc. Everything is done in the system registry.

I do plan to improve the Launcher in the future but only after the other, more important things have been finished. As for MSI files, at the moment I don't know how to modify them from the command line so can't guarantee anything in this particular case :(

#708
Tommy

Tommy

    Brooke's Tommy honey <3

  • Members
  • PipPipPip
  • 442 posts
  • OS:98SE
  • Country: Country Flag

@tomasz86. I still use chrome sometimes but my main browser is Firefox on 2k. It works good but YouTube videos seem to lag sometimes, which is a little strange considering I have FF 26(may need to upgrade to 27.0.1),Flash 12.0.70 and 1 GB RAM.
 

Even on my Windows 98 machine that I upgraded from a Pentium 4 1.8GHz processor to a 2.6GHz P4 and having a GeForce 6200AGP with 256MBs of RAM, YouTube STILL lags for me. It can't be Windows 98 because Linux is also slow playing YouTube videos. I think if YouTube would've left their stuff alone instead of dinking around with it all the time, it would work on even some of the lowest end hardware from at least the early 2000s.



#709
aofarrell2

aofarrell2

    Newbie

  • Members
  • 17 posts
  • OS:Windows 2000 Professional
  • Country: Country Flag

So I was trying to use my application compatibility launcher tonight and it just isn't working right. Come to think of it, it dawns on me now that it just never has run right on this install.

 

Normally when I drag a EXE or MSI into it, it launches it automatically. It hasn't been doing that. I have to hit the return key. Tonight I noticed a error message: [some weird characters I can't type]ystem cannot find the file R=x

 

Any ideas?



#710
Tommy

Tommy

    Brooke's Tommy honey <3

  • Members
  • PipPipPip
  • 442 posts
  • OS:98SE
  • Country: Country Flag

Have you tried @blackwingcat's KDW wrapper tool? He's not updating it anymore and it is out of date for the most part, but it does include fcwin2k which is a very advanced application compatibility tool. It will allow you to modify both MSI files to work with Windows 2000 and also set proper compatibility permissions for exe files. You can find that here in case you want to give that a try, if you haven't already. Look for Ver 0.97a Download (2012/11/12) and download that.

 


 


Edited by Tommy, 02 March 2014 - 08:39 AM.


#711
aofarrell2

aofarrell2

    Newbie

  • Members
  • 17 posts
  • OS:Windows 2000 Professional
  • Country: Country Flag

I did some time ago.

 

The problem is, these programs I've tried installing worked just fine on a different Windows 2K installation with the same Application Compatibility Launcher.

 

Edit: Same problem today on another Win2K installation. All the same software versions, same UURollup, UURollup2 v11, USP5.1, etc... Only difference was that the error message was [some weird characters I can't type]ystem cannot find the file 6

 

Any ideas? I'm stumped.



#712
ironman14

ironman14

    Member

  • Members
  • PipPip
  • 135 posts
  • OS:Windows 2000 Professional
  • Country: Country Flag

@aofarell2

In the error in the application compatibility launcher,[characters] system can't find the file R-x, this is normal. The exe/MSI will launch normally after. I got the same thing.

The FCWIN tool (not KDW wrapper) is still updated, and works with UURollup. I have been able to install, and modify some XP+ programs with advanced protection to work on 2K, like iTunes, and Quicktime Player. Also, Adobe Reader, GIMP, the new Skype, AVG, McAfee Stinger, Winamp, and more should work. Those are some programs I would like to test.

 

@tomasz86

 

I was going to list my hardware, then I had the thought it was a Firefox addon I have, so I browsed through my addons and found "Google Update". I disabled it, restarted Firefox, and Youtube, while not being perfect since it i is W2k, plays MUCH better.


Edited by ironman14, 03 March 2014 - 07:43 PM.


#713
vanceayres

vanceayres
  • Members
  • 6 posts
  • OS:none specified
  • Country: Country Flag

Hello to all.  I need to ask a stupid question.  It SP4 needed if you install USP5?



#714
ironman14

ironman14

    Member

  • Members
  • PipPip
  • 135 posts
  • OS:Windows 2000 Professional
  • Country: Country Flag

Hello to all.  It SP4 needed if you install USP5?


Yes. SP4 is needed for USP5.

#715
aofarrell2

aofarrell2

    Newbie

  • Members
  • 17 posts
  • OS:Windows 2000 Professional
  • Country: Country Flag

Hmm service packs are supposed to cover all previous service packs. I.e. if you install SP2 you don't need to install SP1, or SP3 you don't need SP1 or SP2. I have successfully installed SP5 with only having SP3 installed and a few extra patches.



#716
vanceayres

vanceayres
  • Members
  • 6 posts
  • OS:none specified
  • Country: Country Flag

I've seen it both ways.  Sometimes SPs build on each other & sometimes they're standalone.  That's why I ask.  On another subject, I had setup a Windows 2000 Pro guest in a Windows 7 Pro VirtualBox 4.3.8 host & then with some difficulty got it to accept Windows updates from Microsoft using the article by ppgrainbow Guide to Installing and Updating Windows 2000 Professional.  I then noticed that I couldn't go into Seamless Mode.  Again with some difficulty I finally got this problem solved by installing w2ksp51.exe by tomasz86 & then installing Windows2000-UURollup-v10d-x86-ENU.exe.  Now all appears to be good!  Can anyone see anything wrong with what I've done?  It is interesting that all the Windows updates showed up in Add/Remove Programs until I installed USP5.1.  Can anyone think of reasons this might have occurred?  Thanks for the help I obtained from this forum!!



#717
Tommy

Tommy

    Brooke's Tommy honey <3

  • Members
  • PipPipPip
  • 442 posts
  • OS:98SE
  • Country: Country Flag

I have a question, I'm using the latest HF_SLIP compilation you have on your site (can't remember the date though) and for some reason, I'm always getting a 500 Internal Server error in Windows Media Player when I try to add album information from the web. I never had this issue using the November 2012 compilation. I'm thinking either something was removed to break this or something isn't going right but it's been well over a week and it's still not working. I'm using WMP11 which always worked in the past. Could it be because this didn't come with WMP9 first like November 2012 did and so I didn't bother with it and just installed WMP11. So it could be missing a few other components that WMP9 added?



#718
tomasz86

tomasz86

    www.windows2000.tk

  • Members
  • PipPipPipPipPipPipPipPip
  • 2,497 posts
  • OS:XP Pro x86
  • Country: Country Flag
I'm very sorry for being silent for quite a while. I got a new job and have to work till 2-3 AM. Because of that I've got almost no time for anything else :(

@vanceayres You don't need to install / slipstream any other Service Packs. USP5 is cumulative. As for Windows Update, at this moment UURollup isn't really compatible with it. Until any working solution is provided, I'd strongly advise against using Windows Update once you've installed any unofficial packages.

@Tommy I can't say anything about WMP11 as I don't use WMP at all but I'd say that your guess may be right. WMP11 is officially available only for Windows XP SP2 (and above) which already has newer versions of WMP integrated. On the other hand, Windows 2000 originally comes with WMP 6.4 only.

#719
bluebolt

bluebolt

  • Members
  • 42 posts
  • OS:Windows 2000 Professional
  • Country: Country Flag

I'm very sorry for being silent for quite a while. I got a new job and have to work till 2-3 AM. Because of that I've got almost no time for anything else :(

 

Congratulations on the new job, if that's appropriate, although I have to admit I hoped your recent silence was because you were working on USP5.2; I'm selfish like that :P

 

Seriously, though, best wishes with that new schedule (sounds like a prayer may be in order), and here's hoping we still get to hear from you...at least once in a while.



#720
Tommy

Tommy

    Brooke's Tommy honey <3

  • Members
  • PipPipPip
  • 442 posts
  • OS:98SE
  • Country: Country Flag

I'm very sorry for being silent for quite a while. I got a new job and have to work till 2-3 AM. Because of that I've got almost no time for anything else :(

@vanceayres You don't need to install / slipstream any other Service Packs. USP5 is cumulative. As for Windows Update, at this moment UURollup isn't really compatible with it. Until any working solution is provided, I'd strongly advise against using Windows Update once you've installed any unofficial packages.

@Tommy I can't say anything about WMP11 as I don't use WMP at all but I'd say that your guess may be right. WMP11 is officially available only for Windows XP SP2 (and above) which already has newer versions of WMP integrated. On the other hand, Windows 2000 originally comes with WMP 6.4 only.

Yes, congrats on the new job! That's truly awesome! I'm still job hunting and it's a bad job market here so I haven't been doing so well in it. But I'm not giving up! Well, now the only problem I'm having is I can't remove WMP11 to install WMP9 first and then WMP11 so I'm thinking maybe set the version numbers different so the installer will just overwrite anything that's already there. I know usually a 500 server error is on the other side but I don't think that's the case here, I think something is broken but I don't know what it is. The funny thing though is when I put a DVD in the drive, it'll automatically download information for it but I can't do it manually. Weird, huh?






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users



How to remove advertisement from MSFN