ppgrainbow

Java 6 Update 32 fails to install...

78 posts in this topic

@conductor71

There's no simple answer to your question :angel

Simply speaking, there exist several different ways how you can update your system. If you don't want to mess around too much then I'd recommend choosing one of the following two methods. I'm assuming that you've already installed everything available from M$ (WU):

1) Install Update Rollup 2 + UURollup (ENU). By doing this you will have almost all official updates & hotfixes and almost all unofficial updates installed. The current version of UURollup (ENU) utilises the extended kernel from WildBill although the next one is likely to use the BlackWingCat's version.

2) Install Update Rollup 2 + UURollup (Global) + BlackWingCat's kernel. By doing this you will have almost all official updates & hotfixes installed but you will miss most of the unofficial updates which aren't related to the kernel (you can still install them one by one manually). BlackWingCat's kernel is more advanced than the WildBill's one at the moment.

Please take into account the fact that this is a very simplified guideline which doesn't cover other packages like .NET Framework, etc. but it may be good for you to begin with.

0

Share this post


Link to post
Share on other sites

@tomasz86..

Will you will post here when the next version of UURollup (ENU) is released (that uses BlackWingCat's kernel)? I think that will be the breakpoint to take the plunge and install Update Rollup2 + UURollup (ENU). is there any issue in installing those two now and then wanting to use the next updated UURollup (ENU) when you release it? i.e. needing to or the ability to uninstall the current version of UURollup (ENU) in order to use a release with BlackWingCat's kernel (assuming it is in the next version as you suggest). or will the updated version conceivably replace the necessary files such that BWC's kernal is used? Does this make sense?

Thanks again for your work on the SP5.2

0

Share this post


Link to post
Share on other sites

@Yffffonz

1. If nothing unexpected happens then the next version of UURollup with BWC kernel will be probably released on 30th September 2012. A detailed release plan of UURollup is explained in the very beginning of the main USP5.2 topic. Of course, Daily & Weekly versions will be available much earlier.

2. At the moment UURollup (ENU) is incompatible with BWC kernel. If you install the two together then the system will likely not start (but safe mode should work). Only UURollup (Global) can be used with BWC kernel, and of course Update Rollup 2 is also compatible with BWC kernel.

3. I've always been testing installation over the previous version of UURollup so it shouldn't be a problem to just leave the old one and install the new one over it. Uninstallation is actually pretty risky, especially if you've installed other updates/programs in meantime. When the new version using BWC kernel is ready it should be also possible to install it over BWC kernel but I can't guarantee that yet.

Edited by tomasz86
0

Share this post


Link to post
Share on other sites

same issue with Java 6u33. It did not get fixed.

@BlackWingCat et al, is there a workaround for installing the Java 6 updates on Windows 2000?

The problem might be that this bug might not even get fixed as Java 6 will hit EOL sometime this November. So far, no one has even voted for that bug. :(

same problem when trying to install Java 6 Update 35, the newest release of Java 6, but I think this one is worse than previous releases.

0

Share this post


Link to post
Share on other sites
same problem when trying to install Java 6 Update 35, the newest release of Java 6, but I think this one is worse than previous releases.

Why do you think that Java 6 Update 35, the newest release of Java 6 is worse than the previous release?

Oracle has eventually extended the lifespan of Java 6 through sometime in February 2013.

0

Share this post


Link to post
Share on other sites

I migrate Java 6 update 35 Installere for WIndows 2000.

Java 6 Update 35 Installer for Windows 2000

The migration for Windows 2000 is too easy for me.

Sun microsystems is too lazyyyyyyyyy to understand that Sun can't do it. :realmad:

Thank you.

The last official version that works is jdk-6u31-windows-i586.exe, free download form Oracle.

0

Share this post


Link to post
Share on other sites

@ blackwingcat..

Thanks for this brother...

p.s. just a heads up. I had to run this twice on my machine to get it to work. might have been that I had ie and firefox windows open when i first ran it... Just a heads up for others that may try to run it.

Edited by Yffffonz
0

Share this post


Link to post
Share on other sites

Thx. I'll check it.

@ blackwingcat..

Thanks for this brother...

p.s. just a heads up. I had to run this twice on my machine to get it to work. might have been that I had ie and firefox windows open when i first ran it... Just a heads up for others that may try to run it.

0

Share this post


Link to post
Share on other sites

I migrate Java 6 update 35 Installere for WIndows 2000.

Java 6 Update 35 Installer for Windows 2000

The migration for Windows 2000 is too easy for me.

Sun microsystems is too lazyyyyyyyyy to understand that Sun can't do it. :realmad:

thanks for making the j6u35 package, BWC. although I got the original J6u35 package from Sun to install properly after I installed unofficial KB935839 v18b (kernelex) on Win2000.

0

Share this post


Link to post
Share on other sites

I released Java 6 update 37 for Windows 2000(you can also install it without extended kernel).

It is improved for Installation. :)

Edited by blackwingcat
0

Share this post


Link to post
Share on other sites

oh wow... thanks bwc.. i didn't even know u36 was out nevermind u37.. i will look on your site.

0

Share this post


Link to post
Share on other sites
This update is critical.

yes. thanks for the heads up and the explanation of the double number increment. got the new version installed with no problems. anyone else on win2k should go to your blog page and d/l the u37 update.

0

Share this post


Link to post
Share on other sites

Do you have the English language version of the Java 6 Update 37 package that can be installed without the extended kernel or the UURollup? If so, let me know.

I'm testing Java 6 Update 37 in a Win2K VMware VM and it still fails to install! :realmad:

Edited by ppgrainbow
0

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.