Jump to content
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble
Strawberry Orange Banana Lime Leaf Slate Sky Blueberry Grape Watermelon Chocolate Marble

MSFN is made available via donations, subscriptions and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, register and become a site sponsor/subscriber and ads will be disabled automatically. 

Sign in to follow this  
aurgathor

DDR is flaky and strange in K7VM2 mobo

Recommended Posts

aurgathor    0

I have a K7VM2 Athlon mobo that can take either SDRAM or DDR, 2 sticks each. Originally, I had 768 Meg of PC133 SDRAM with Win98, but since I successfully installed W2K, I decided to add some more memory by using DDR instead of SDRAM.

However, I ran into 2 serious issues:

1) with 1 or 2 gig DDR in there, system would only post about 10% - 15% of the time. :realmad: (vs. near 100% with SDRAM)

2) according to the bootup scren, the Athlon 2500+ was only 1900+ with DDR. :w00t: (I presume, running at 133 MHz instead of 166)

I have 266, 333, and 400 MHz DDRs (tried pretty much all) and speed ratings didn't seem to make much of a difference, but they were all recognized only as DDR266.

The mobo has a jumper to set FSB to either 100 or 133 (set to 133) and the CPU clock was set to 166 in the manual setup portion of the BIOS.

Anyone seen anything like this? What could be causing it? Is there a way to make DDR RAM work reliably without downclocking the CPU?

When I had an Athlon 750 (100 MHz) in there, both SDRAM and DDR worked equally reliably.

TIA

Share this post


Link to post
Share on other sites
dencorso    530

The manual says: "North Bridge: VIA KM266, FSB@200/266 MHz" if you set the bus speed to 166 MHz, the Northbridge won't be able to cope with it. Then again, it's highly doubtful whether the KM266 can really control 2 GiB at DDR 266 (= bus speed: 133 MHz). Try setting bus speed to 100 MHz (DDR 200) and it'll probably become stable. Moreover you don't need to run 1:1, so you still can set the CPU clock at 133 or maybe even 166 MHz, provided you run the RAM at DDR 200. Do give it a try.

I apologize for the wild goose chase, it turned out to be a case of 'bad' RAM. :blushing:

Separately, both sticks test fine -- together, they erred out on the modulo 20 test.... :angry:

That is a typical symptom of Northbridge choking... try setting them to DDR 200 and there's a good chance they'll run OK together.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×