Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account


Photo

Log Off - On problem.

- - - - -

  • Please log in to reply
11 replies to this topic

#1
NATO

NATO

    Junior

  • Member
  • Pip
  • 66 posts
  • OS:XP Pro x86
  • Country: Country Flag
Never having used the - Logoff - before I find that although I can access ALL accounts with no problem, when any account is running and I - Logoff - so that I can safely leave the comuter running, then I cannot simply - Logon - again and have to re-boot.

Fast user switching is off, is this a problem maybe?

Thanks for all previous advice.

PS

Tried out the 3D Pinball cheat codes last night. Amazing!

E.G.

When the game is running in Full Screen.

1. Type: hidden test
2. when the game is playing press R several times to gain promotion.

If you don't have 3D Pinball you can download it in the form of a .rar file.

The same site has all the cheats for the game.

Just Google. Have fun!

(Score without cheating to date: 5,125,450)


How to remove advertisement from MSFN

#2
Tripredacus

Tripredacus

    K-Mart-ian Legend

  • Super Moderator
  • 9,695 posts
  • OS:Server 2012
  • Country: Country Flag

Donator

I miss that game!

Anyways, unless you are on a domain, you can turn Fast User Switching on. At least to test it out to see if that solves your logon problem.
MSFN RULES | GimageX HTA for PE 3.x | lol probloms
msfn2_zpsc37c7153.jpg

#3
Ponch

Ponch

    MSFN Junkie

  • Patrons
  • 3,238 posts
  • OS:none specified
  • Country: Country Flag

I cannot simply - Logon - again and have to re-boot.

What's on your screen at the point you have to reboot ? Do you use Welcome Screen or CtrlAltDel ? XP Pro/Home ? Using built-in "Administrator" account ?

#4
NATO

NATO

    Junior

  • Member
  • Pip
  • 66 posts
  • OS:XP Pro x86
  • Country: Country Flag


I cannot simply - Logon - again and have to re-boot.

What's on your screen at the point you have to reboot ? Do you use Welcome Screen or CtrlAltDel ? XP Pro/Home ? Using built-in "Administrator" account ?


Hi Ponch,

When I logoff no problem. But when I try to logon again it says that my password is invalid so I have to re-boot.

Until I find the answer I have removed the logoff button for the time being.

This is XP Pro SP3 fully updated with the MUI rolled back and then removed by nLite.

I use the standard Welcome screen and have full Administrators account.

The built in administrators account does not appear on the Welcome screen, just my personal account.

To get to the Administrators account I have to go in via Safe Mode.

I know that you can modify the registry to get the Admin account to show as well, but I am told that this is not recommended.

Edited by NATO, 29 May 2012 - 01:57 AM.


#5
Tripredacus

Tripredacus

    K-Mart-ian Legend

  • Super Moderator
  • 9,695 posts
  • OS:Server 2012
  • Country: Country Flag

Donator

Do you not have a password on that account?
MSFN RULES | GimageX HTA for PE 3.x | lol probloms
msfn2_zpsc37c7153.jpg

#6
Ponch

Ponch

    MSFN Junkie

  • Patrons
  • 3,238 posts
  • OS:none specified
  • Country: Country Flag

when I try to logon again it says that my password is invalid

Can you try pressing CtrlAltDel twice at that point to enter your password and check keyboard is properly configured (typing in 1st box where you can see what you type)?
Note that if I remember correctly, from there you should be able to login as Administrator as well. Only in XP Home do you have to get in Safe Mode to log as Adminisrator.
Check the registry keys "Keyboard Layout/Preload/1" for both .Default user and your account. If not the same, that might be your problem.

Edited by Ponch, 30 May 2012 - 04:25 AM.


#7
NATO

NATO

    Junior

  • Member
  • Pip
  • 66 posts
  • OS:XP Pro x86
  • Country: Country Flag

Do you not have a password on that account?


Yes I do, but the Admin account only shows in Safe Mode.

#8
NATO

NATO

    Junior

  • Member
  • Pip
  • 66 posts
  • OS:XP Pro x86
  • Country: Country Flag


when I try to logon again it says that my password is invalid

Can you try pressing CtrlAltDel twice at that point to enter your password and check keyboard is properly configured (typing in 1st box where you can see what you type)?
Note that if I remember correctly, from there you should be able to login as Administrator as well. Only in XP Home do you have to get in Safe Mode to log as Administrator.
Check the registry keys "Keyboard Layout/Preload/1" for both .Default user and your account. If not the same, that might be your problem.


Thanks Ponch, I will check the registry keys out when I get home tonight.

Yesterday I tried out a new logon screen (Logon Studios). As soon as I clicked 'Apply' I got a notice to say that the computer was locked - enter your password.

Same thing "Password invalid."

Re-booted and all is fine.

I will let you know about the registry.

After what you said I am guessing that the preload is USKBD.DLL = 00000409

Problem being that this keyboard is a Belgian Point KBDBE.DLL = 00000813

As I have an 'm' in my password, it is in a different place on this AZERTY keyboard.

Makes it difficult to use in DOS.

So I am thinking that you are right.

Edited by NATO, 31 May 2012 - 06:27 AM.


#9
Ponch

Ponch

    MSFN Junkie

  • Patrons
  • 3,238 posts
  • OS:none specified
  • Country: Country Flag
CtrlAltDel does revert to default keyboard (from registry's .Default), while Welcome Screen does not (you stay with the previous user's config).
Belgian keyboard at the NATO,... makes sense. ;)

#10
NATO

NATO

    Junior

  • Member
  • Pip
  • 66 posts
  • OS:XP Pro x86
  • Country: Country Flag
Now I see that it probably depends on the original language setup as this machine was setup in UK English and the 1 keyboard is 00000809
I tried changing all the 1 keys (all six of them) to 00000813 which is the Belgian keyboard and the 2 keys to US English 00000409

Now I can't get in at all and will have to restore from the original drive image. \Ö/

So with an nLite .ISO of this US version of XP Pro I installed on the D: drive choosing US English as the input language and then adding the Belgian keyboard layout.

Works fine on the D: drive and has the benefit that the old legacy Teefer for NT PS/2 mouse and keyboard drivers were NOT installed as only USB hardware was connected, so now the errors no longer appear in the Event Log. (Teefer and wpsdrv failed to load.)

I think that the plan now is to work up the D: drive make an image and restore it to the C: drive with all the correct settings and none of the legacy drivers.

I know that the registry is set so that Ctrl/Alt/Del is not necessary.

Sincere thanks to all of you for all of your helpful suggestions.

Ian

#11
Ponch

Ponch

    MSFN Junkie

  • Patrons
  • 3,238 posts
  • OS:none specified
  • Country: Country Flag

I tried changing all the 1 keys (all six of them) to 00000813 which is the Belgian keyboard and the 2 keys to US English 00000409

Now I can't get in at all and will have to restore from the original drive image. \Ö/

I don't understand what you did. Why are you "correcting" to different values when your problem comes exactly from that ?
You install XP in English keyboard setting, you set your password for your "user" which contains a ";" as you pressed the "m" key on your physically belgian keyboard, then you log in and set Language/keyboard to Belgium (Nl); 813. When Going to Welcome screen, your password is typed correctly (well you think it's correct but in fact you do type an "m") on your belgian keyboard but is not the same as the one you entered before you log on (default is 409-US or 809-UK), each time you start the machine.
Pressing CtrlAltDel twice, you could have tried that, it was my first advice. Sorry if you reinstalled already.
2 easy solutions;
-offline registry editing from your other system
-log in as admin (safe mode if needed) and change your password to none or characters that do not depend on "azerty versus qwerty"; no "a", no z, q, w, m.

Edited by Ponch, 01 June 2012 - 02:31 PM.


#12
NATO

NATO

    Junior

  • Member
  • Pip
  • 66 posts
  • OS:XP Pro x86
  • Country: Country Flag
Solved. Finally!

As you know from the other posts I had to make an XP install CD from the installation on the C: drive. So I used the MS setup.exe on the C: drive to set up a copy on the indentical size D: partition (1st logical drive). I then booted to this partition and used the MS MUI rollback tool to remove the other languages.

I then made a drive image of the D: drive with Image for Windows 1.64 and extracted the files from the image to a folder on the F: partition using TBI View (Two really good software tools from TeraByte Unlimited in Las Vegas) so that I could use nLite to cut it down to size and make an ISO.

So I then formatted the D: partition (1st logical drive) and re-installed from the nLite ISO giving me XP Pro SP2 (OEM) without any unnecessary junk and practically no MUI. (Some keyboards did manage to get past this process but got picked out and deleted from the remaining MUI cache using Reg Organiser.)

As the SP3 downloaded file turned out to have corrupt .cab files, according to the Avast AV, (Previous post) I downloaded the US SP3 ISO and burned it to CDR.

I then re-installed and ran the subinactil.msi tool from MS and proceeded with the SP3 update which went in flawlessly.

(Contrary to those who claim that SP2 has to be - fully - updated - before - SP3 will install.)

I then added IE8 and all my other software archived on the F:partition, cleaned and optimised the registry, ran chkdsk, defragged the drive, and telephoned MS USA to validate the install.

1 - click later, back up and running. :-)

Just had to go online to update the AV, complete the validation, and add all the many security updates.

Made a new drive image of the, fully functional, D: drive to archive and then 'restored' it to the C: drive.

Re-booted to the C: drive edited the boot.ini file and formatted the ... 1st logical drive ... in the extended partition ... where the new install ... had been prepared.....

Login - Logoff works perfectly, as all settings are US English, even with the Belgian (Period) keyboard. (There is a Belgian (Comma) keyboard, but they are quite rare.)

I now have - NO - 'Teefer' (for NT) and 'wpsdrvnt' (Windows PS Driver NT) errors in the event viewer as there was no PS/2 keyboard and PS/2 mouse attatched when the initial installation was done and these legacy drivers no longer appear in the hardware device manager. Hooray!

So - VERY MANY THANKS - to all of you on the Forum for your help, which has proved to be invaluable.

Hope you - ALL - have a great day.

Ian.

PS

Just - two - little things... See above.

Now my primary partition shows as Local Drive D: (System with boot files) and the ... 1st logical drive ... shows as Documents C: ... \Ö/

Checking the Event viewer reveals that MS, in its infinite wisdom, chose to re-assign the drive letters so that the 'system' (Big Brother) could keep track of things.

Arrrggg !!! I feel like Winston Smith from 1984!

Anyway, that is three up, one down, which has to be good and the entire system is much more responsive.

'Apply' is very much quicker, for example.

Also the registry is as new and very much smaller.

Tonight I will see if it is possible to re-assign the drive letters using Boot-IT NG....

Edited by NATO, 04 June 2012 - 03:04 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users



How to remove advertisement from MSFN