Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account



Photo

Override ClearType fonts for certain websites?

- - - - -

  • Please log in to reply
10 replies to this topic

#1
tomasz86

tomasz86

    www.windows2000.tk

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,520 posts
  • Joined 27-November 10
  • OS:XP Pro x86
  • Country: Country Flag
I'm using a CRT monitor with default system "smooth edges of screen fonts" (no ClearType) turned on. I noticed that recently some (many?) sites have started to use ClearType fonts which look terrible on my screen. Sometimes they are actually almost unreadable.

Could anyone recommend any simple way to override them with "normal" ones, i.e. is it possible to make the browser replace those fonts with standard ones like Arial or Tahoma? The browsers I use are mostly Opera and/or Firefox.

I'm attaching a screen shot of http://www.neowin.net which uses such fonts. Right now I'm looking on it on a tablet (LCD) where it's displayed perfectly fine and on a CRT screen where they are blurred and very painful to read (see the screen shot below). Other sites using such fonts are for example Microsoft's or Apple's pages.

Has anyone else experienced a similar problem?

EDIT

I've just checked Neowin's CSS and this is probably the problem :/

html { font: 13px/24px 'Segoe UI', Segoe, 'Helvetica Neue', Helvetica, Roboto, Arial, FreeSans, sans-serif }

Attached Files


Edited by tomasz86, 01 June 2012 - 09:57 PM.

Posted Image
Unofficial Service Pack 5.2 for MS Windows 2000 <- use this topic if you need help with UURollup, Update Rollup 2 and other unofficial packages


How to remove advertisement from MSFN

#2
MagicAndre1981

MagicAndre1981

    after Windows 7 GA still Vista lover :)

  • Patrons
  • 6,091 posts
  • Joined 28-August 05
  • OS:Vista Ultimate x86
  • Country: Country Flag

Donator

For me this looks the same on Windows 8 with IE9 or in Metro. Looks horrible.

I'm using Firefox which allows me to use the old GDI metric or some fonts and I have a clear brilliant picture back not this horrible crap.
Posted Image

#3
tomasz86

tomasz86

    www.windows2000.tk

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,520 posts
  • Joined 27-November 10
  • OS:XP Pro x86
  • Country: Country Flag
First I managed to find some info on overriding fonts on all websites both in Opera and Firefox but it's not really a viable option as some sites look bad when their fonts are overridden.

Then I found this:

http://ask.metafilte...ecific-websites

It seems to be the best option to set fonts for specific sites in a custom CSS file. It'd be nice to have a more "dynamic" alternative, ex. to be able to change fonts on the fly.... but still better then nothing. And neowin.net looks much better after I've changed its font to Arial.

Edited by tomasz86, 02 June 2012 - 04:52 PM.

Posted Image
Unofficial Service Pack 5.2 for MS Windows 2000 <- use this topic if you need help with UURollup, Update Rollup 2 and other unofficial packages

#4
tomasz86

tomasz86

    www.windows2000.tk

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,520 posts
  • Joined 27-November 10
  • OS:XP Pro x86
  • Country: Country Flag
By the way, here you can see how different these fonts are rendered when ClearType is switched on and off. It's a part of the M$ site:


1. ClearType off:

Posted Image


2. ClearType on:

Posted Image


As you can see the fonts on the first screen shot are hardly readable :(

And lastly, the same thing but now the default font is overridden by Arial:


1. ClearType off:

Posted Image


2. ClearType on:

Posted Image


It may not look very good but at least in both cases they can be easily read.

Edited by tomasz86, 05 June 2012 - 11:26 PM.

Posted Image
Unofficial Service Pack 5.2 for MS Windows 2000 <- use this topic if you need help with UURollup, Update Rollup 2 and other unofficial packages

#5
tomasz86

tomasz86

    www.windows2000.tk

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,520 posts
  • Joined 27-November 10
  • OS:XP Pro x86
  • Country: Country Flag
It seems that SRWare Iron automatically enables ClearType for ClearType fonts even though ClearType itself is not turned on in the system. I'll probably just use it to view the problematic sites until a better solution is found.

Edited by tomasz86, 06 June 2012 - 07:45 AM.

Posted Image
Unofficial Service Pack 5.2 for MS Windows 2000 <- use this topic if you need help with UURollup, Update Rollup 2 and other unofficial packages

#6
tomasz86

tomasz86

    www.windows2000.tk

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,520 posts
  • Joined 27-November 10
  • OS:XP Pro x86
  • Country: Country Flag
I have found the real reason to cause the problem!

This is too strange to be funny. The broken fonts are caused by connecting a second monitor :ph34r:

1. When the second monitor is disabled in Display Properties:
Posted Image

2. As soon as I enable the second monitor:
Posted Image

I just want to ask: What the hell? :crazy:

I'm guessing that there might be something wrong in the graphic drivers. I'll try other ones and report the result... but the problem seems to be more complex though. Even when only one monitor is used the fonts are rendered like in 1) in Firefox & K-Meleon (Gecko based browsers) but in Opera and IE they are still broken, no matter whether the second monitor is enabled or not. They are broken in Maxthon (Webkit) too. They are displayed always correctly in Chromium & Qupzilla (both Webkit).
Posted Image
Unofficial Service Pack 5.2 for MS Windows 2000 <- use this topic if you need help with UURollup, Update Rollup 2 and other unofficial packages

#7
MagicAndre1981

MagicAndre1981

    after Windows 7 GA still Vista lover :)

  • Patrons
  • 6,091 posts
  • Joined 28-August 05
  • OS:Vista Ultimate x86
  • Country: Country Flag

Donator

which hardware do you use?
Posted Image

#8
tomasz86

tomasz86

    www.windows2000.tk

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,520 posts
  • Joined 27-November 10
  • OS:XP Pro x86
  • Country: Country Flag
My hardware is:

- monitors: main Compaq P1220 (CRT) + second Samsung SyncMaster 2043NW (LCD)
- graphic card: nVIDIA GeForce 6600
- motherboard: ASRock A55 Pro (FM1)
- CPU: Athlon II X4 631

Both monitors use only DSUB ports and are connected to the same graphic card (the LCD one through a DVI converter as the card has got only 1xDSUB + 1xDVI).
Posted Image
Unofficial Service Pack 5.2 for MS Windows 2000 <- use this topic if you need help with UURollup, Update Rollup 2 and other unofficial packages

#9
MagicAndre1981

MagicAndre1981

    after Windows 7 GA still Vista lover :)

  • Patrons
  • 6,091 posts
  • Joined 28-August 05
  • OS:Vista Ultimate x86
  • Country: Country Flag

Donator

maybe this happens because you mix a CRT with a LCD. Why don't you use the LCD as default?
Posted Image

#10
tomasz86

tomasz86

    www.windows2000.tk

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,520 posts
  • Joined 27-November 10
  • OS:XP Pro x86
  • Country: Country Flag
I use the CRT as default because it's a very good Diamondtron monitor while the LCD is... let's say "low quality" (=rubbish) :lol:

I've got an another old CRT somewhere so I'll try to connect it instead of the LCD and see if there's any difference. I don't think that Windows 2000 is able distinguish between CRT and LCD so I'm guessing the problem may be either:

1) a bug in Win2k related to multi-monitor setup
2) a bug in the graphic drivers
Posted Image
Unofficial Service Pack 5.2 for MS Windows 2000 <- use this topic if you need help with UURollup, Update Rollup 2 and other unofficial packages

#11
tomasz86

tomasz86

    www.windows2000.tk

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,520 posts
  • Joined 27-November 10
  • OS:XP Pro x86
  • Country: Country Flag
In the end I think that it is likely a bug in Windows 2000 and its font smoothing. I've done a test in XP and no such issues occured there. What I found interesting is that XP seems to render fonts differently from Win2k, even when ClearType is disabled and only the standard font smoothing is used.
Posted Image
Unofficial Service Pack 5.2 for MS Windows 2000 <- use this topic if you need help with UURollup, Update Rollup 2 and other unofficial packages




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users