• Announcements

    • xper

      MSFN Sponsorship and AdBlockers!   07/10/2016

      Dear members, MSFN is made available via subscriptions, donations and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, become a site sponsor and ads will be disabled automatically and by subscribing you get other sponsor benefits.
Sign in to follow this  
Followers 0
O0o0O0O0o

New to unattended windows creation

118 posts in this topic

To username X, on other thread you tell Alice to change 6 update cab with .exe ones when integrating WMP11,so I use boogy application and did as you say (uncheck box.delete Nlite file) But I do this before reading your last post and didn't add other 4 updates. I install and nothing but malicious tool show up on Microsoft Updates. So I do or don't need other 4 updates as you mentioned ? (last 4 in your list)

0

Share this post


Link to post
Share on other sites

That's very strange. You should need those updates. Don't know why they don't show up for you.

0

Share this post


Link to post
Share on other sites

Steps in order.

I use downloader,add IE8 addon to downloader folder,make adjustmentes in footnotes 4 5 6

Then add WMP11 to downloader folder and follow instruction to the letter

You should not use the WindowsXP-WindowsMedia-KBxxxxxx-x86-ENU.cab files but instead the original files. See footnote 1.

This is total 6 updates in .exe extension so I replace 6.

I do one of 6 update seperately,as you say unchecked/delete nlite file then procede to other updates as normal.

Already preinstalled boogy wmp11 slipslreamer and it pop up automatically during integration.

I add no additional updates and nothing pop up in windowsupdate but malicious tool remove.

I make no mistake,read whole thread with You,Alice,and submix8c.

Should I add additional updates or unessary ?

I use Microsoft Baseline Security Analyzer (MBSA) as well and No additional updates in your list above are mentioned.

0

Share this post


Link to post
Share on other sites

Sound like you did everything correctly. Can you attach your last session.ini? It's in the root of your CD or in the ISO/source folder if you are testing in a virtual machine.

I will investigate the file version numbers of those additional updates and have you check them.

0

Share this post


Link to post
Share on other sites

Can you check KB954154? MS08-054: Vulnerability in Windows Media Player could allow remote code execution

http://support.microsoft.com/kb/954154

WindowsMedia11-KB954154-x86-ENU.exe

Find Wmpeffects.dll. Perhaps in the system32 folder. It should have a version number of 11.0.5721.5252.

Well a thought occurred to me that they might have updated the installer without telling anyone. Sure enough, when I checked Wmpeffects.dll in the installer it was v11.0.5721.5262. Hence why it isnt showing on WU....it's already patched.

I'll check the rest when I have some time just to be sure.

OK, I had some time. :) I checked the 4 additional updates and they are not needed as the WMP installer has newer file versions.

So you're good to go and I learned something today.

Edited by -X-
0

Share this post


Link to post
Share on other sites

Sorry for delay.

Edit: Thank you for checking,very good . :)

(Just for some reason if you need last session ini)

.ini

Edited to clean up large 'cut/paste' .ini and replaced by attachment function.

Edited by O0o0O0O0o
0

Share this post


Link to post
Share on other sites

Looks good. :thumbup

I did a little further inspection of the updates and WindowsXP-WindowsMedia-KB952069-v2-x86-ENU.exe was published before the WMP11 installer and the installer has newer file versions. So you can remove that from your update list and confirm if you feel like it.

Note to self: KB952069 1/13/2009 - wmp11-windowsxp-x86-enu.exe signing time: Tuesday, February 03, 2009 12:36:26 AM

Edited by -X-
0

Share this post


Link to post
Share on other sites

Yes, I will confirm tonight one way or other.

Having problem downloading SP3 tonight,failed 3 times. I keep update folder so very easy to do. ( I Don't keep service pack)

0

Share this post


Link to post
Share on other sites

Looks good. :thumbup

I did a little further inspection of the updates and WindowsXP-WindowsMedia-KB952069-v2-x86-ENU.exe was published before the WMP11 installer and the installer has newer file versions. So you can remove that from your update list and confirm if you feel like it.

Note to self: KB952069 1/13/2009 - wmp11-windowsxp-x86-enu.exe signing time: Tuesday, February 03, 2009 12:36:26 AM

Yes, confirm.. No need for update KB952069 anymore... Kept out of integration this time and it didn't show up on MS Updates..

0

Share this post


Link to post
Share on other sites

New updates.

Windows XP Security Update for Windows XP (KB2685939) Tuesday, June 12, 2012 Windows Update

Windows XP Security Update for Windows XP (KB2709162) Tuesday, June 12, 2012 Windows Update

Windows XP Cumulative Security Update for Internet Explorer 8 for Windows XP (KB2699988) Tuesday, June 12, 2012 Windows Update

Windows XP Security Update for Windows XP (KB2707511) Tuesday, June 12, 2012 Windows Update

0

Share this post


Link to post
Share on other sites

Yeah, page and UDC already updated.

BTW, Java got security updates today so update if you have it on your system.

Edited by -X-
0

Share this post


Link to post
Share on other sites

Do you meant to have "entries_KB2676562.ini" in your updater ?

Edit: I guess footnote # 4 is no more. :)

Edited by O0o0O0O0o
0

Share this post


Link to post
Share on other sites

No, entries_KB2676562.ini is a mistake I made. You can delete it or re-download the UDC script, delete WindowsXP-KB2709162-x86-ENU-reg-entry.cab and have it recreated correctly (description missing) when you run the UDC.

What about footnote 4? It's still relevant.

If you're slipstreaming IE8, replace WindowsXP-KB2675157-x86-ENU.exe with IE8-WindowsXP-KB2699988-x86-ENU.exe.

0

Share this post


Link to post
Share on other sites

What about footnote 4? It's still relevant.

If you're slipstreaming IE8, replace WindowsXP-KB2675157-x86-ENU.exe with IE8-WindowsXP-KB2699988-x86-ENU.exe.

KB2675157 isn't in your updater anymore as it was replaced by KB2699988..

Edit: Should footnote 4 now read " replace KB2699988-x86-ENU.exe with IE8-WindowsXP-KB2699988-x86-ENU.exe ?

Edited by O0o0O0O0o
0

Share this post


Link to post
Share on other sites

Thank you to -X-, You have been most helpful and have the best thing for nLite. You investigate updates very greatly as reflected in your changelog and WU..

My installs are most perfect,couldn't have done it without you, thank you sir. :thumbup

I must donate now. Thank you much for your experience and creation !

Im done here,I donate tomorrow.

0

Share this post


Link to post
Share on other sites

I did new install without wmp11,don't need it.

I do the normal IE8,updater,footnote adjustment etc. on windows xp Home and KB978338 never able to integrate.. Any ideas Mr. -X- ?

Other CD perfect.

0

Share this post


Link to post
Share on other sites

Attach your "Last Session.ini" if using nLite.

It appears that MAYBE you are making the same mistake that many make when integrating HotFixes.... In the "Add Hotfixes" part, the List is presented when you add them. At the Top of the List, you need to Sort them by Date Ascending.

Also a VERY important question... Is this a Non-English XP Source? If so, you may need the Language Files for the language it's in... (don't remember if you said...)

0

Share this post


Link to post
Share on other sites

It probably integrated but it just used the wrong tcpip6.sys file.

tcpip6.sys.png

As you can see it's contained in both KB978338 and KB2509553. The newer version of tcpip6.sys is actually in KB978338. So it looks like it used the one in KB2509553.

Did you by chance turn on display reports in hotfix, advanced? If you did, you need to keep the highest version number.

0

Share this post


Link to post
Share on other sites

Attach your "Last Session.ini" if using nLite.

.ini

It appears that MAYBE you are making the same mistake that many make when integrating HotFixes.... In the "Add Hotfixes" part, the List is presented when you add them. At the Top of the List, you need to Sort them by Date Ascending.

Yes, I make same mistake, no sorting by date,just added them as they are. Didn't know it mattered with exception of -X- footnote # 9 - "Due to a bug in nLite, KB977816 must be processed before KB2115168. To do this, simply check the sort order of your Hotfix, Add-ons and Update Packs section of nLite. Sorting them by date, with the oldest first, is a good idea" -

So I make sure and was in order already.(oldest date closer to top) I read people arange and people don't but I do other CD w/ WMP11 same way,same order and it integrated perfect..

Question, What about Adobe and other few updates with no date(one piece IE8 etc.),do I add on top,bottom or just leave in place and move others with date in order ?

Also a VERY important question... Is this a Non-English XP Source? If so, you may need the Language Files for the language it's in... (don't remember if you said...)

I have English XP source from inside USA.

It probably integrated but it just used the wrong tcpip6.sys file.

tcpip6.sys.png

As you can see it's contained in both KB978338 and KB2509553. The newer version of tcpip6.sys is actually in KB978338. So it looks like it used the one in KB2509553.

Did you by chance turn on display reports in hotfix, advanced? If you did, you need to keep the highest version number.

No, I don't do this on last integration so you recommend ? Ok,will do so.

Edited to cleanup .ini 'cut/paste' and use attachment function instead.

Edited by O0o0O0O0o
0

Share this post


Link to post
Share on other sites

No, I don't recommend. Keep display reports off. nLite should use the higher version .sys files with it off.

0

Share this post


Link to post
Share on other sites

OK, will do without after I arrangement of update files by date...

Edited by O0o0O0O0o
0

Share this post


Link to post
Share on other sites

Ok, I do arangment of dates KB978338 still showing up on wu .. I do with wmp11 again,no matter this time.. Weird.

.ini

Edited to cleanup .ini 'cut/paste' and use attachment function instead.

Edited by O0o0O0O0o
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.