Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account



Photo

Windows7 vLite & DISM Recipe

- - - - -

  • Please log in to reply
No replies to this topic

#1
DreamworlD

DreamworlD

    Newbie

  • Member
  • 13 posts
  • Joined 29-March 12
  • OS:XP Pro x86
  • Country: Country Flag
Hello everyone,
I am trying to build Windows7 Lite Ultimate edition using DISM and vLite.
In the attachment is the recipies that I am using as follows:
L110612m.ini -> vLite Preset Settings
removal.bat ->  DISM Package removal script
cleanup.bat ->  Installation Cleanup script
-------------------------------------------
commit.bat ->   Commit changes script
discard.bat ->  Discard changes script
mount.bat ->    WIM mount script
setupcfg.txt -> Scripts Setup file
With DISM I am removing the following packages:
Microsoft-Hyper-V-Common-Drivers-Package
Microsoft-Hyper-V-Guest-Integration-Drivers-Package
Microsoft-Windows-Anytime-Upgrade-Results-Package
Microsoft-Windows-Backup-Package
Microsoft-Windows-BLB-Client-Package
Microsoft-Windows-Branding-Professional-Client-Package
Microsoft-Windows-BusinessScanning-Feature-Package
Microsoft-Windows-Client-Wired-Network-Drivers-Package
Microsoft-Windows-ClipsInTheLibrary-Package
Microsoft-Windows-Editions-Client-Package
Microsoft-Windows-Gadget-Platform-Package
Microsoft-Windows-GPUPipeline-Package
Microsoft-Windows-IE-Troubleshooters-Package
Microsoft-Windows-Links-Package
Microsoft-Windows-LocalPack-AU-Package
Microsoft-Windows-LocalPack-CA-Package
Microsoft-Windows-LocalPack-GB-Package
Microsoft-Windows-LocalPack-ZA-Package
Microsoft-Windows-LocalPack-US-Package
Microsoft-Windows-MobilePC-Client-Sensors-Package
Microsoft-Windows-NetworkDiagnostics-DirectAccessEntry-Package
Microsoft-Windows-OfflineFiles-Package
Microsoft-Windows-OpticalMediaDisc-Package
Microsoft-Windows-PeerDist-Client-Package
Microsoft-Windows-RecDisc-SDP-Package
Microsoft-Windows-Security-SPP-Component-SKU-Professional-Package
Microsoft-Windows-Shell-HomeGroup-Package
Microsoft-Windows-Shell-MultiplayerInboxGames-Package
Microsoft-Windows-SnippingTool-Package
Microsoft-Windows-StickyNotes-Package
Microsoft-Windows-TerminalServices-Publishing-WMIProvider-Package
Microsoft-Windows-TerminalServices-RemoteApplications-Client-Package
Microsoft-Windows-VirtualPC-Licensing-Package
Microsoft-Windows-VirtualPC-USB-RPM-Package
Microsoft-Windows-VirtualXP-Licensing-Package
Microsoft-Windows-WinOcr-Package
Microsoft-Windows-WindowsMediaPlayer-Troubleshooters-Package
Microsoft-Windows-Xps-Foundation-Client-Package
Networking-MPSSVC-Rules-UltimateEdition-Package
Microsoft-Windows-ShareMedia-ControlPanel-Package
Microsoft-Windows-CodecPack-Basic-Encoder-Package
Microsoft-Windows-PhotoPremiumPackage
After installing and configuring, I am having the following problem:
When I open Devices and Printers, nothing is showed in the window, and a indicator is showing constant loading.
When I stop it and try to add a device using "Add A Device" button. I am having error with the following code number:
"Windows cannot complete the current operation. The following error code occurred [80004002]".

This error code usually is for missing interface. In this case the interface is DDORes which is not registered properly as a COM object model, and I suppose that some of the packages that I've manipulated had unregistered this module.

Another problem is with the wireless wizard. Windows in unable to scan or connect to a WiFi network. It is not showing any information about the found networks, nor the "manual add network" function is wokring.

Also the try-bar notification icon for safety removal hardware is not working at all.

What I'm doing wrong here?

P.S.: in the vLite preset you'll se that I've checked the WinSxS cache for removal. It turns out that this is insignificant for the current task, because I compiled two versions, one with WinSxS checked, and without it. And it is still showing the same problems.

Attached Files




How to remove advertisement from MSFN



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users