GrofLuigi

Why can't I disable CDROM Autoplay in Windows7?

7 posts in this topic

Consider this scenario... :)

I set the dword value "Autorun" in HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\cdrom\Parameters to 0. After reboot, my DVD drive is disabled and in device manager it says "The driver cannot start".

I tried it on several computers, same everywhere. Isn't it stupid that it checks the value, but can work with only one possible parameter?

I want this so badly to work (disable CDROM autoplay) I can taste it. :ph34r: The reason is it finally calms my HDD light on the case down. Then I can work on any other reasons for blinking. Is it possible?

GL

* Edit: changed the word "Autorun" to "Autoplay"

Edited by GrofLuigi
0

Share this post


Link to post
Share on other sites

If I well understand you would try to disable Autorun?

Using this reg file do the job:

Disable Autorun


Windows Registry Editor Version 5.00

; NoCDBurning
; ClearRecentDocsOnExit
; Keep NTFS permissions when copying (ForceCopyAclwithFile)
; Disable Autorun (NoDriveTypeAutoRun):
; => value:dword:000000b5 => for CD-Rom
; => value:dword:000000ff(255) => for all drives

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\Explorer]
;"NoCDBurning"=dword:00000000
;"ClearRecentDocsOnExit"=dword:00000001
;"ForceCopyAclwithFile"=dword:00000001
"NoDriveTypeAutoRun"=dword:000000b5
;"NoDriveTypeAutoRun"=dword:000000ff(255)

Remove the valeur to activate Autorun !

http://en.wikipedia.org/wiki/AutoRun

HTH

*Edit: It seems it is added with Windows 8:

http://msdn.microsof...7(v=vs.85).aspx

http://techdows.com/2011/09/windows-8-turns-off-power-to-optical-drive-when-there-is-no-media.html

0

Share this post


Link to post
Share on other sites

I think it's called Autoplay and it's controlled solely by the reg value I posted above. It's on a deeper (driver?) level then your first two items posted (by the way, I always disable that other Autorun* on Explorer level with NoDriveTypeAutoRun=ff and other tweaks). This Autorun (Autoplay) i'm talking about is always polling the optical drive and with the reg value I posted above can be stopped on XP, Server2003 (don't know about Vista), but on 7 it always shows the behavior described in my first post. Tried on Win7 RTM, SP1, x86, x64, IDE drive, SATA, drive... Always.

The last two things you posted are for win8, of course, and don't apply.

* "that other Autorun" = explorer seeking for autorun.inf on the root of the drive.

0

Share this post


Link to post
Share on other sites

HonorAutoRunSetting should also be set, besides NoDriveTypeAutoRun (KB967715):

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\Explorer]
"HonorAutoRunSetting"=dword:00000001
"NoDriveTypeAutoRun"=dword:000000ff

0

Share this post


Link to post
Share on other sites

HonorAutoRunSetting should also be set, besides NoDriveTypeAutoRun (KB967715):

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\Explorer]
"HonorAutoRunSetting"=dword:00000001
"NoDriveTypeAutoRun"=dword:000000ff

Yeah, but that's "that other Autorun" which is looking for autorun.inf. Microsoft isn't helping too much with the confusion either (in the past the two terms were used interchangably). I'm talking about the registry value in my first post, which is obviously at a driver level. As I said, the drive light shows it's polling the CD drive. So I want it to stop polling, which "the other autorun" can't do.

GL

0

Share this post


Link to post
Share on other sites

I have done all of them, even @sys:doesnotexist :)

Please notice that my registry entry, which I found with Process Monitor...

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\cdrom\Parameters]

Autorun=dword:0

...is different than the most usually mentioned entry

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Cdrom]

Autorun=dword:0

...which doesn't work on 7 (in the sense that it doesn't stop the polling), but also doesn't break the CDRom driver.

Additionally, Win7 also looks for the following key:

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Cdrom\Parameters\Parameters]

...Which I've just created, so in the next boot tracing I'll see what it will look for underneath. It smells like a bug.

GL

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.