Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account


Photo

Windows 8 RP Unattended


  • Please log in to reply
2 replies to this topic

#1
AnimaliX

AnimaliX

    Junior

  • Members
  • Pip
  • 93 posts
Windows 8 RP as Primary OS? a few tips, tweaks and notes


I decided that Windows 8 RP set as the primary OS, so I can adapt well to the arrival of RTM.
And because everything like are set by through the "one-click style" commandline, here are a few things in which we W8 differ from W7.

note: My UAC is disabled by default from Autounattend.xml


some tips and notes:

0\ BOOT DIRECTLY INTO DESKTOP :) - this is perhaps the easiest way to boot directly to desktop (note: I don't like utility tweakers)
http://www.kapilarya...onsumer-preview
works with all editions W8 and probably with RTM also :)

create file something.scf
[Shell]
Command=2
IconFile=Explorer.exe,3
[Taskbar]
Command=ToggleDesktop
You can put this into "Run" section in registry or simple to "startup" folder

1\ The first thing that struck me is an instant delete without confirmation (can be set manually, but I do not know whether it is simply through the registry) - really unpleasant thing and it is good to remember to set right after installation

2\ File associations are due to Metro solved differently than in W7 and the same path in the registry not associated defaults programs and when you first run the file must manually select the program from the list.
If I understand properly associations are now in section HKEY_USERS\SID and therefore can not be set directly from the registry, because SID is every system install different (I think)

for example this way not working properly for me any longer
"Open with" list of programs exists, but MPC must be selected manualy at first start file

[HKEY_CURRENT_USER\Software\Classes\Applications\mpc-hc.exe\shell\open\command]
@="\"C:\\Media Player Classic - Home Cinema\\mpc-hc.exe\" \"%1\""
[HKEY_CURRENT_USER\Software\Classes\Applications\MediaInfo.exe\shell\open\command]
@="\"C:\\MediaInfo\\MediaInfo.exe\" \"%1\""

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.avi\OpenWithList]
"a"="mpc-hc.exe"
"b"="MediaInfo.exe"
"MRUList"="ab"
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.avi\UserChoice]
"Progid"="Applications\\mpc-hc.exe"

I also tried put association directly into HKEY_CLASSES_ROOT or HKCU\Software\Classes with no result

note: I do not know it is only Release Preview thing, but in a much larger portion of the registry is to avoid the possibility of modification (can be solved by setting the rights or automatically through SetACL)
So if you also advises the automated installation and configuration through registers is good at first set Permissions.

it is possible that I'm wrong in something, and can be solved more easily
these are the observations of week use



SERVICES
regarding the configuration of the services I have found only>
http://www.blackvipe...configurations/

Here I copied only the changed services from Black Viper list

:Application Management (manual)
sc config AppMgmt start= disabled
:Bluetooth Support Service (manual)
sc config bthserv start= disabled
:BranchCache (manual)
sc config PeerDistSvc start= disabled
:Certificate Propagation (manual)
sc config CertPropSvc start= disabled
:Distributed Link Tracking Client (auto)
sc config TrkWks start= disabled
:Hyper-V Data Exchange Service (auto)
sc config vmickvpexchange start= disabled
:IP Helper (auto)
sc config iphlpsvc start= disabled
:Microsoft iSCSI Initiator Service (manual)
sc config MSiSCSI start= disabled
:Netlogon (manual)
sc config Netlogon start= disabled
:Network Access Protection Agent (manual)
sc config napagent start= disabled
:Offline Files (auto)
sc config CscService start= disabled
:Parental Controls (manual)
sc config WPCSvc start= disabled
:Remote Procedure Call (RPC) Locator (manual)
sc config RpcLocator start= disabled
:Remote Registry (manual)
sc config RemoteRegistry start= disabled
:Smart Card Removal Policy (manual)
sc config SCPolicySvc start= disabled
:SNMP Trap (manual)
sc config SNMPTRAP start= disabled
:Storage Service (manual)
sc config StorSvc start= disabled
:Windows Biometric Service (manual)
sc config WbioSrvc start= disabled
:Windows Connect Now - Config Registrar (manual)
sc config wcncsvc start= disabled
:Windows Media Player Network Sharing Service (manual)
sc config WMPNetworkSvc start= disabled
:Windows Search (auto)
sc config WSearch start= disabled


and here is part of my Autounattend.xml
created in WSIM 6.2.8400

<?xml version="1.0" encoding="utf-8"?>
<unattend xmlns="urn:schemas-microsoft-com:unattend">
    <servicing>
        <package action="configure">
            <assemblyIdentity name="Microsoft-Windows-Foundation-Package" version="6.2.8400.0" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="" />
            <selection name="Internet-Explorer-Optional-amd64" state="false" />
            <selection name="MediaPlayback" state="false" />
            <selection name="Microsoft-Windows-MobilePC-LocationProvider-INF" state="false" />
            <selection name="MicrosoftWindowsPowerShellV2Root" state="false" />
            <selection name="MSRDC-Infrastructure" state="false" />
            <selection name="Printing-XPSServices-Features" state="false" />
            <selection name="SearchEngine-Client-Package" state="false" />
            <selection name="WindowsGadgetPlatform" state="false" />
            <selection name="Xps-Foundation-Xps-Viewer" state="false" />
            <selection name="Windows-Defender-Default-Definitions" state="false" />
        </package>
        <package action="configure">
            <assemblyIdentity name="Microsoft-Windows-ProfessionalEdition" version="6.2.8400.0" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="" />
            <selection name="Microsoft-Hyper-V-ClientEdition-Package" state="false" />
            <selection name="Microsoft-Hyper-V-Common-Drivers-Package" state="false" />
            <selection name="Microsoft-Hyper-V-Guest-Integration-Drivers-Package" state="false" />
            <selection name="Microsoft-Hyper-V-Server-Drivers-Package" state="false" />
            <selection name="Microsoft-Windows-Anytime-Upgrade-Package" state="false" />
            <selection name="Microsoft-Windows-Printing-XPSServices-Package" state="false" />
        </package>
    </servicing>

notes:
A. if you not set TimeZone default is Pacific time


excuse my crazy English :P

Edited by AnimaliX, 06 July 2012 - 11:08 AM.



How to remove advertisement from MSFN

#2
chlje

chlje

    Newbie

  • Members
  • 26 posts
  • OS:none specified
  • Country: Country Flag
good post :) I tested the services portion it is safe for me home user, tks

#3
AnimaliX

AnimaliX

    Junior

  • Members
  • Pip
  • 93 posts
i found this "Skip Metro Suite"
works with W8RTM and its based on service.. but if you unpack installator and use only ToggleDesktop.exe in startup, you no need any running services :)

Posted Image

http://winaero.com/c...omment.news.103

Edited by AnimaliX, 01 November 2012 - 10:27 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users



How to remove advertisement from MSFN