Welcome to MSFN

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


Sign in to follow this  
Followers 0
mobious99

system reserved partition drive letter

15 posts in this topic

has anyone found a way to get the system reserved partition to create w/o assigning a drive letter to it?

I'm trying to get the install so that it looks like a standard windows install and cannot for the life of me figure this out.

I've even tried this on the volume - in the pre and post configuration.

diskpart

sel disk 0

sel vol 1

attributes vol set nodefaultdriveletter

0

Share this post


Link to post
Share on other sites

How are you installing? Are you using an answer file?

0

Share this post


Link to post
Share on other sites

I'm using an answer file, and then capturing the image with gimagex.

I've only been capturing the windows partition.

0

Share this post


Link to post
Share on other sites

Ok, so you have an image now and need to deploy it, is that where you are getting this problem? Are you using Gimagex or Setup to deploy your image?

0

Share this post


Link to post
Share on other sites

I'm using imagex to do the deploy.

here's how I'm doing it

- boot into winpe

- map drive

- run diskpart script - standard script from microsoft

select disk 0

clean

create partition primary size=300

select partition 1

format fs=ntfs label="System Reserved"

assign letter=S

active

create partition primary size=102400

select partition 2

format fs=ntfs label="Windows" quick

assign letter=W

active

exit

- Then apply the wim file to the windows partition

imagex /apply f:\2008r2\2008r2ent.wim 1 w:\

- Then run these commands to make the device bootable

bcdboot w:\windows /s w:

bootsect /nt60 w:

after that re-boot and off I go.

0

Share this post


Link to post
Share on other sites

Don't assign the System Reserved a drive letter at all with your diskpart script.

And you can't set 2 partitions to be active, so remove the active on the "W" volume.

0

Share this post


Link to post
Share on other sites

I took out the drive letter for the system reserved and it's still assigning one on bootup.

it's just strange that diskpart script is right from microsoft.

the w: drive changes to c: on bootup.

0

Share this post


Link to post
Share on other sites

Is your image generalized?

0

Share this post


Link to post
Share on other sites

yes the image is.

I only capture the windows partition not the system reserved partition, I'm thinking about doing that next and then recreating the boot files.

I've also tried not assigning a drive through diskpart and the drive is still getting created.

0

Share this post


Link to post
Share on other sites

change your line:

create partition primary size=300

to:

create partition msr size=300
0

Share this post


Link to post
Share on other sites

The MSR setting is only used in a GPT type format. The user's posted diskpart script does not mention switching to GPT mode. I'm fairly certain that Diskpart is smart enough to throw an error if you try to make an MSR partition on an MBR disk.

0

Share this post


Link to post
Share on other sites

The MSR setting is only used in a GPT type format. The user's posted diskpart script does not mention switching to GPT mode. I'm fairly certain that Diskpart is smart enough to throw an error if you try to make an MSR partition on an MBR disk.

You right this is only for GPT and don't work with MBR.

So i guess while the Windows Setup create the system reserved it also set a new registry setting for the new Windows installation, that prevents a drive letter.

cheers.gif

0

Share this post


Link to post
Share on other sites

I actually tried something today

- imaged a 2008r2 device

- removed the drive letter

- rebooted

- boots no problem.

no idea why this is adding a drive letter.

0

Share this post


Link to post
Share on other sites

I'm going to add this to my startup script

rem remove system reserved drive letter

diskpart /s removehiddent.txt

removehidden.txt has the following lines in it..

SEL VOL 0

REMOVE LETTER=D

Where d: is the drive that always gets assigned to the system reserved partition.

It's got to be something sysprep / winpe is doing because when I boot off my winpe cd I see two drive letters.

0

Share this post


Link to post
Share on other sites

It's got to be something sysprep / winpe is doing because when I boot off my winpe cd I see two drive letters.

That is normal to see the System Reserved get a drive letter in WinPE when booting on a system with an existing OS.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.