• Announcements

    • xper

      MSFN Sponsorship and AdBlockers!   07/10/2016

      Dear members, MSFN is made available via subscriptions, donations and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, become a site sponsor and ads will be disabled automatically and by subscribing you get other sponsor benefits.
Nomen

Can't get win-98 to remember folder-view options

19 posts in this topic

Everything was ok as of about a week ago (I had "details" view, and no "view as web-page") but something happened (don't know what) and since then the system always reverts to "view as web-page" and "large icons" upon startup regardless what I do to change it.

So I moved the file WEBVW.DLL and all the .htt files (and some desktop.ini files) I could find out of the way so that win-98 can't find them, and that solved the "view as web-page" issue.

I want explorer to show "details" but it is defaulting to "large icons". I've tried every combination in Folder Options but nothing sticks when the system is re-booted.

This system is broken in so far as it's running an Nvidia driver (4.14.10.8198) for the past few months that prevents the system from shutting down properly, so I've been using "restart in MS-DOS mode" which the system shuts down to the point of showing a black screen at which point I switch the power off and that accomplishes the shut-down. So what-ever mess this creates with any system files should be considered in formulating an answer to "why can't I get Details file-view to stick"...

Can the "VTCP.386" update (236926usa8.exe) or 243199US8.EXE (ndis.vxd) play a role here?

0

Share this post


Link to post
Share on other sites
Everything was ok as of about a week ago (I had "details" view, and no "view as web-page") but something happened (don't know what) and since then the system always reverts to "view as web-page" and "large icons" upon startup regardless what I do to change it.

It sounds like the registry has been changed [somehow] and the explorer settings revert to some altered condition upon reboot.

Have you tried "scanreg /restore" to see if a previous working registry version will fix the problem? A more experienced member should offer advice regarding any planned actions and their potential outcomes.

As in any recommendation it's wise to back-up your settings first, back-up your hard-drive to an external archive, and only attempt fixes AFTER doing the proper research. Don't take anyone's word, mine included, without doing proper background checks to be certain you won't muck up your machine any more than it already is.

As far as the Nvidia drivers causing improper shutdowns, are you running a minimum configuration where the loaded prog's and app's are reduced to their absolute fewest number? I've found the fewer things running in the system tray the better, and most BSOD are the result of conflicting drivers or an overloaded system. Ever since I pared down the "Startup" apps and removed lots of commands in the "Run" and "RunServices" keys in the registry that weren't absolutely necessary I have yet to see a BSOD.

It may not sound important to others, but I like running my machines with close to 95% resources free [start - Accessories - System Tools - System Information].

0

Share this post


Link to post
Share on other sites

Have a look at this thread. Especially my Post #4.

I've done that many times already.

I open "my computer".

Click View -> select Details.

Click View (again) -> select Folder Options. Folder-Options dialog window opens.

Radio Button is already set to "Custom, based on settings you choose".

Select View tab.

Click the "Like Current Folder" button.

Get the "Set all the folders on your computer to match the current folder's view settings (except for toolbars)?" message.

Click the Yes button.

Click the OK button on the Folder Options dialog window to make it go away.

Close "my computer" (explorer) window. Open it again - and all drives and folder contents ARE displayed with Details view. Close "my computer" and open it again. View is STILL set to Details. Great.

Restart the computer, open "my computer" and I'm back to large icon view.

0

Share this post


Link to post
Share on other sites

The problem may be related to your inability to shutdown properly. Some data may not be saved in the Registry.

Try disabling or uninstalling your Nvidia Driver, rebooting, making your folder changes, rebooting, then restoring your Video Driver.

0

Share this post


Link to post
Share on other sites

Another possibility: check whether you have a NoSaveSettings with value 1 under each of the following registry keys...

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

HKEY_USERS\.Default\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Program Manager\Restrictions

HKEY_USERS\.Default\Software\Microsoft\Windows NT\CurrentVersion\Program Manager\Restrictions

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

If you do, change that value from 1 to 0.

0

Share this post


Link to post
Share on other sites

Another possibility: check whether you have a NoSaveSettings with value 1 under each of the following registry keys...

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

HKEY_USERS\.Default\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

In the above 3 locations, the value NoSaveSettings was present, and was already set to 0.

HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

The value NoSaveSettings was not present in that location. I added it and set it to 0. (edit: adding this key had no effect).

HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Program Manager\Restrictions

HKEY_USERS\.Default\Software\Microsoft\Windows NT\CurrentVersion\Program Manager\Restrictions

In both of those locations, I don't have a sub-path or tree for "Program Manager". The only path that exists under CurrentVersion is AppCompatFlags.

Edited by Nomen
0

Share this post


Link to post
Share on other sites

Well, this being the case, I think RLoew's suggestion is the best thing to try next.

0

Share this post


Link to post
Share on other sites

Logging off and logging back on shuts down then restarts Explorer. This is the way to get the ShellIconCache to update. It should also update the desktop.ini files where the individual folder settings are saved. Easy to try....

0

Share this post


Link to post
Share on other sites

Logging off and logging back on shuts down then restarts Explorer. This is the way to get the ShellIconCache to update.

But wouldn't a shut-down and restart also do the same thing?

It should also update the desktop.ini files where the individual folder settings are saved. Easy to try....

What if I "hid" some desktop.ini files by renaming them? Specifically 3 of them located in \windows, \windows\system, \windows\system32?

(I have a handful that aren't re-named, located in \fonts, \favorites, c:\my documents, and c:\program files. Should there be one in EVERY directory?)

And moved all the .htt files and webvw.dll?

Does win-98 re-generate any desktop.ini or htt files that it's looking for if it finds them missing, or re-generate them when you change folder-view settings?

0

Share this post


Link to post
Share on other sites

The problem may be related to your inability to shutdown properly. Some data may not be saved in the Registry.

Try disabling or uninstalling your Nvidia Driver, rebooting, making your folder changes, rebooting, then restoring your Video Driver.

The driver I'm using did seem to function correctly when I select Shutdown-Restart, but didn't work for Shutdown-shutdown or restart in DOS mode. I tried to deactivate the driver by removing the "exists in all profiles" checkmark in device manager - but that didn't seem to do anything. (?)

Last night I installed the earlier driver (77.72) and all shut-down modes do seem to work properly. But even still, windows explorer defaults to large-icon view upon re-start.

I really don't have any idea as to how the desktop.ini and the htt files are supposed to work -I thought that maybe mine were messed up so I moved or re-named them thinking that windows would simply re-generate new ones. Am I wrong about that?

What about webvw.dll? Can win-98 function without that file in terms of remembering my Details-view setting?

0

Share this post


Link to post
Share on other sites

I don't know the solution, but it's a bit similar to a long running problem I have where Explorer and standard file dialogs keep reverting to a default sort of Z-A by filename.

I recall finding a suggestion to set the sort in an Explorer window to what you want, then close it by clicking the close button while holding Ctrl. Maybe it has to be the last open Explorer window, too. I don't think it'll help, it doesn't help me (at least not long term), but worth a shot.

0

Share this post


Link to post
Share on other sites

The CTRL trick works wonders here too :thumbup

0

Share this post


Link to post
Share on other sites

TmEE: To solve something similar to the OP's problem, or the simpler case of default sort? And does it stick long term?

0

Share this post


Link to post
Share on other sites

I want all my folders to have same kind of view settings and item sorting and so far it works nicely. Sometimes I get things reverting so I set my view settings again and do CTRL trick and things are back to normal again.

As for OP, his care seems peculiar, and something I have not personally gone through so I cannot think of anything useful either... I just chimed in that CTRL trick has worked very nicely for me.

0

Share this post


Link to post
Share on other sites

Pressing (and holding) the control key while closing the explorer window does nothing for me. If I configure the folder-view to be what I want (details view, and NO web-page view) and select "like current folder" and then hold the control key while closing the window, the system does not remember my view settings upon the next re-start.

0

Share this post


Link to post
Share on other sites

Just ignore me if I'm not helping .....

I also like to see folder details rather than icons on win98. I dunno why, but the only way I can ever make that stick (after say, a clean install).. is to set a folder to the view I want ....then go to control panel... folder options (or whereever it is there in that neighborhood) and then UN-check "remember folder view" (or whatever that is there where you can also check whether to see hidden files etc).

Seems that win98se then is fine in calling up my folder details view from then on... which is strange because I've basically told windows to NOT remember the folder views.

Don't know why that is, but it's a subconscious thing for me now to always un-check that box in folder options. Stuff then stays the way I want.

0

Share this post


Link to post
Share on other sites

I'm not sure if this is related to my continuing problem with win-98se not remembering my folder-view settings, but when I use explorer (my computer) to browse to my c:\program files directory, I get what looks like a listing of font (ttf) files. Exactly the same thing as if I browsed to the c:\windows\fonts directory. The program files directory looks normal if I bring it up in a DOS window. Running scandisk from dos doesn't change or fix this (it found no errors on the drive). Any ideas?

Remember, I've been messing with htt and desktop.ini files (moving them, deleting them, etc) in an effort to fix the folder-view issue. Would be nice to find a good description of how critical these files are to win-98, and if there's any in-built function to restore / rebuild these files to their "normal" or default structure.

0

Share this post


Link to post
Share on other sites

Back in 1999 when I got introduced to computing with Windows 98 first edition, not knowing any better, when I had a problem I would just reinstall 98 on top of 98. As time went on I realized there were easier ways to fix minor issues. I don't know if this would work in your case but you sound desperate.

Even though I used a full OEM CD the installation routine worked like an upgrade with the option to back up the previous installation.

I believe the htt and desktop.ini files will be replaced with fresh copies with a time/date stamp of the installation time. I don't think these files were the cause of the initial problem however. It was probably some registry issue.

I don't suppose it would do any good if you are using a non-English copy of Windows but I could upload copies of desktop.ini and the htt files from my 98SE computer. They have not been modified since the installation date of 8 February 2005.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.