Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account


Photo

Issue with Windows 2008 R2 Unattended installation for Japanese Langua


  • Please log in to reply
18 replies to this topic

#1
Vengada

Vengada
  • Member
  • 6 posts
  • OS:Server 2008 x64
  • Country: Country Flag
Hi,

Need Guidance about how to overcome the unattended installation for Windows 2008 R2 for Japanese Language.

We are performing the unattended installation of Windows 2008 R2 using the tool called as CSP. which generate the answer File automatically asking for the few inputs like Language, time Zone, answer key, Windows Server Name, etc...

Since we need for japanese installation, i just downloaded the Japanese Operating System of windows server 2008 R2, and the tool generated the answer file.

When i ran the answer File, i was shocked to see that the installation is in English for Japanese Operating System. So i tired altering the answer file by changing the Input Locale to the Japanese.

<SetupUILanguage>
<UILanguage>0411</UILanguage> <!-- @@LANGUAGE_CODE -->
</SetupUILanguage>
<!--
InputLocale default set to 0409:00000409 match en-US,
see link for other language values
http://technet.micro.../dd744319(WS.10).aspx
-->
<InputLocale>0411:00000411</InputLocale> <!-- @@LANGUAGE_CODE -->
<UserLocale>0411</UserLocale> <!-- @@LANGUAGE_CODE -->
<UILanguage>0411</UILanguage> <!-- @@LANGUAGE_CODE -->
<SystemLocale>0411</SystemLocale> <!-- @@LANGUAGE_CODE -->
</component>

Even after changing the input locale also, we found that the installation is in English. Can any one guide me what i need to do exactly, in order to obtain the installation in Japanese.
<component name="Microsoft-Windows-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.micro...fig/2002/State" xmlns:xsi="http://www.w3.org/20...hema-instance">
<UserData>
<AcceptEula>true</AcceptEula>
<!--
Optional FullName, Organization.
WillShowUI for ComputerName, ProductKey default to OnError
-->
<FullName>xxx</FullName> <!-- @@FULL_NAME -->
<Organization>xxx</Organization> <!-- @@ORGANIZATION_NAME -->
<ProductKey>
<!--
Default Key is "nokey" and "Never" WillShowUI
This works for Windows Server 2008 R2 trial ISOs
For Windows Server 2008 a key,
publically available in the KMS docs:

can be used to pass the winPE edit
When using a valid key, for auto
registration see the specialize pass below
and set SkipAutoActivation to false
-->
<WillShowUI>Never</WillShowUI> <!-- @@PRODUCT_SHOW_ERROR -->
<!-- no Product Key provided -->
</ProductKey>
</UserData>
<ImageInstall>
<OSImage>
<WillShowUI>OnError</WillShowUI>
<InstallToAvailablePartition>true</InstallToAvailablePartition>
<InstallFrom>
<MetaData>
<Key>/IMAGE/Name</Key>
<!-- Value string must match ISO media content -->
<Value>Windows Longhorn SERVERENTERPRISE</Value> <!-- @@WIN_ISO_MEDIA_INSTALL_OPTION -->
</MetaData>
</InstallFrom>
</OSImage>
</ImageInstall>
</component>
</settings>

<settings pass="specialize">
<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.micro...fig/2002/State" xmlns:xsi="http://www.w3.org/20...hema-instance">
<!--
NOTE: Networking is handled via post install scripting : IP static or DHCP, DNS, etc.
Adding xml networking components is not advisable.
-->

<!-- ComputerName can contain no more than 15 characters -->
<ComputerName>Administrator</ComputerName> <!-- @@COMPUTER_NAME -->
</component>

<component name="Microsoft-Windows-Security-Licensing-SLC-UX" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.micro...fig/2002/State" xmlns:xsi="http://www.w3.org/20...hema-instance">
<!-- SkipAutoActivation true/false, needs to be "false" for activation -->
<SkipAutoActivation>true</SkipAutoActivation> <!-- @@SKIP_AUTO_ACTIVATION -->
</component>

</settings>

<settings pass="oobeSystem">

<component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.micro...fig/2002/State" xmlns:xsi="http://www.w3.org/20...hema-instance">
<Display>
<HorizontalResolution>1024</HorizontalResolution>
<VerticalResolution>768</VerticalResolution>
<ColorDepth>16</ColorDepth>
</Display>
<AutoLogon>
<Enabled>true</Enabled>
<LogonCount>3</LogonCount>
<Username>Administrator</Username>
<Password>
<!-- AutoLogon Administrator Password ADMIN-PW default: "unsecure" -->
<Value>xxxxxxx</Value> <!-- @@ADMIN_PW -->
</Password>
</AutoLogon>
<FirstLogonCommands>
<SynchronousCommand wcm:action="add">
<!-- Do Not change the CommandLine or Order value -->
<CommandLine>%WINDIR%\System32\cmd /c D:\postinstall\LinMin.cmd</CommandLine>
<Order>1</Order>
<Description>Post Install Scripting Trigger</Description>
</SynchronousCommand>
</FirstLogonCommands>
<OOBE>
<HideEULAPage>true</HideEULAPage>
<SkipMachineOOBE>true</SkipMachineOOBE>
<SkipUserOOBE>false</SkipUserOOBE>
</OOBE>
<!-- TimeZone default: "Pacific Standard Time" -->
<TimeZone>Japan Standard Time</TimeZone> <!-- @@TIME_ZONE -->
<UserAccounts>
<AdministratorPassword>
<!-- Administrator Password ADMIN-PW default: "unsecure" -->
<Value>Passw0rd</Value> <!-- @@ADMIN_PW -->
</AdministratorPassword>
</UserAccounts>
</component>

</settings>

</unattend>

Thanks,

Edited by Vengada, 30 July 2012 - 11:04 PM.



How to remove advertisement from MSFN

#2
Tripredacus

Tripredacus

    K-Mart-ian Legend

  • Super Moderator
  • 9,716 posts
  • OS:Server 2012
  • Country: Country Flag

Donator

The InputLocale is correct, but I don't know why you have the numbers for the rest.

<InputLocale>0411:00000411</InputLocale> 
<SystemLocale>ja-JP</SystemLocale> 
<UILanguage>ja-JP</UILanguage> 
<UserLocale>ja-JP</UserLocale>

UserLocale [technet]
MSFN RULES | GimageX HTA for PE 3.x | lol probloms
msfn2_zpsc37c7153.jpg

#3
johnhc

johnhc

    MSFN Junkie

  • Member
  • PipPipPipPipPipPipPipPipPip
  • 3,362 posts
  • OS:Windows 7 x64
  • Country: Country Flag
Tripredacus, I think the numbers are OK. At lease Windows System Image Manager accepts them.
Vengada, I suspect that the same information is needed in the oobeSystem pass as well as the windowsPE pass. My answer file (W7) has both. Perhaps the setup is in Japanese and the installed system is defaulting to English. Enjoy, John.

#4
johnhc

johnhc

    MSFN Junkie

  • Member
  • PipPipPipPipPipPipPipPipPip
  • 3,362 posts
  • OS:Windows 7 x64
  • Country: Country Flag
EDIT: Deleted. System hung then put my reply in a second time when I clicked Add again.

Edited by johnhc, 30 July 2012 - 09:19 AM.


#5
Vengada

Vengada
  • Member
  • 6 posts
  • OS:Server 2008 x64
  • Country: Country Flag
Hi,

Thanks for the reply.

Do you want to set this tag also to ja-jp for installing in Japanese

<settings pass="oobeSystem"> which u want to be changed to

<settings pass="ja-jp">

Also let me if anything else need to be changed for the installation to happen in Japanese

#6
johnhc

johnhc

    MSFN Junkie

  • Member
  • PipPipPipPipPipPipPipPipPip
  • 3,362 posts
  • OS:Windows 7 x64
  • Country: Country Flag
Vengada, I am not an expert but am reporting what works for me. This is the code in my answer file:
<settings pass="oobeSystem">

        <component name="Microsoft-Windows-International-Core" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

            <SystemLocale>en-US</SystemLocale>

            <UILanguage>en-US</UILanguage>

            <UserLocale>0409:00000409</UserLocale>

        </component>
As you can see, the JA-JP should be fine but as I said, 0411 is accepted by Windows System Image Manager and I assume it will be OK for Setup (but I have not tried it). I was hoping one of the real xml experts would respond and help you. What I said makes sense, but I cannot determine what else might be missing. I do recommend that you run Windows System Image Manager against your answer file and see if it finds any problems. Did the initial phases of your install show English or Japanese? My debug steps for the answer file is to do test installs on a Virtual Machine (I use VMware Player - FREE). I suggest you give a VM a try before you hit the HW. It would be quick to try 0411 vs JA-JP, for example. Also look at the unattend.chm (C:\Program Files\Windows AIK\Docs\CHMs) help file for the details on the xml code for the answer file. BTW, if you have additional problems/questions, please attach your complete answer file, of course with your private data obscured (PWs, Key, etc). The one above is missing some parts. Enjoy, John.

#7
Vengada

Vengada
  • Member
  • 6 posts
  • OS:Server 2008 x64
  • Country: Country Flag
John,

Thats my full answer file.

#8
myselfidem

myselfidem

    Member

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,559 posts
  • OS:Windows 7 x64
  • Country: Country Flag
As johnhc suggested, attach your full answer file, please!

Cheers
For Windows 7 OS: SetProductKey.rar (fr-FR/en-US. Integrate keys).

#9
Tripredacus

Tripredacus

    K-Mart-ian Legend

  • Super Moderator
  • 9,716 posts
  • OS:Server 2012
  • Country: Country Flag

Donator

John,

Thats my full answer file.


Either use the attachment system to attach the XML to your post, or paste your answer file in CODE tags. Copying plain-text off the forum can usually lead to formatting errors when pasted into Notepad, among other things. CODE tags help in that respect, but doesn't beat attaching the file directly.
MSFN RULES | GimageX HTA for PE 3.x | lol probloms
msfn2_zpsc37c7153.jpg

#10
johnhc

johnhc

    MSFN Junkie

  • Member
  • PipPipPipPipPipPipPipPipPip
  • 3,362 posts
  • OS:Windows 7 x64
  • Country: Country Flag
Vengada, that does not look like a valid answer file. It does not start out properly. I have attached mine with modifications. I have replaced information I do not want public with ????. The product key is the default one, so it is in the public anyway. My file probably has lots of stuff you do not need or want. Also remember that the answer file must be named as mine is - AutoUnattend.xml. Good luck and enjoy, John.

Attached Files



#11
Vengada

Vengada
  • Member
  • 6 posts
  • OS:Server 2008 x64
  • Country: Country Flag
-
Here with attaching the full answer file. let me know what all needs to be altered in the answer file.

Thanks.

#12
Vengada

Vengada
  • Member
  • 6 posts
  • OS:Server 2008 x64
  • Country: Country Flag
Attaching the answer file.

Attached Files



#13
myselfidem

myselfidem

    Member

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,559 posts
  • OS:Windows 7 x64
  • Country: Country Flag
Maybe you can try this one. I made some changes.
For Windows 7 OS: SetProductKey.rar (fr-FR/en-US. Integrate keys).

#14
Vengada

Vengada
  • Member
  • 6 posts
  • OS:Server 2008 x64
  • Country: Country Flag
Hi,

Used the Same XML Answer File which u shared, when i tired to deploy it in the VM using the TOOL CSP.

Its throwing the error " Windows setup couldn't set the display language.

Pls refer the screenshot attached.

If i change the UI Language , to 0411:000000411 in XML File. the installation stops with the user response to select "NEXT"

Kindly refer the screenshot after modification.

If i manually select NEXT the installation proceeds, and it completes successfully in Japanese.

So is there any passing we need to do, in XML to select NEXT , or is there any other option that can be done, let us know.

Thanks.

Attached Files



#15
myselfidem

myselfidem

    Member

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,559 posts
  • OS:Windows 7 x64
  • Country: Country Flag
I'm trying now to download Windows Server 2008 ja-JP and use this new answer file.

*Edit: I made a new one. I see an error with SPP-UX

Edited by myselfidem, 06 August 2012 - 12:38 PM.

For Windows 7 OS: SetProductKey.rar (fr-FR/en-US. Integrate keys).

#16
maxXPsoft

maxXPsoft

    MSFN Master

  • Developer
  • 2,880 posts
  • OS:Windows 7 x64
  • Country: Country Flag
I assume you did download an iso with a name like this? ja_windows_server_2008_r2_with_sp1_x64_dvd_617387.iso
I seen errors with missing lines and corrected the xml. I removed certain things in windowsPE
<SetupUILanguage>
                <UILanguage>ja-JP</UILanguage>
            </SetupUILanguage>
            <InputLocale>0411:00000411</InputLocale>
            <SystemLocale>ja-JP</SystemLocale>
            <UILanguage>ja-JP</UILanguage>

but can be used in oobeSystem
<SystemLocale>ja-JP</SystemLocale>
            <UILanguage>ja-JP</UILanguage>
            <UserLocale>ja-JP</UserLocale>

Try this one
Download ++> Windows 7 + 8 Unattended DVD + App Installer + Services Disabler + Load All Button + XML Creator
Jump2Reg - Registry: - Oct 4, 2013 - Version 3.0.4 - 98, ME, NT, 2K, XP, VISTA, Seven, Windows 8+ and 32 or 64 bit

XP Unattended CD/DVD creator - Version 4.1.7
Sample xml + Setupcomplete + Add Right click .wim Windows 7 or Windows 8/8.1

#17
johnhc

johnhc

    MSFN Junkie

  • Member
  • PipPipPipPipPipPipPipPipPip
  • 3,362 posts
  • OS:Windows 7 x64
  • Country: Country Flag
Vengada, one too many zeros in second number of "0411:000000411". Please run Windows System Image Manager on your AutoUnattend.xml file before you try an installation. maxXPsoft is an excellent XML advisor - give his a try and let us know the outcome. Enjoy, John.

#18
myselfidem

myselfidem

    Member

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,559 posts
  • OS:Windows 7 x64
  • Country: Country Flag
I made some tests but always Windows asking to give a key using Windows Server 2008...But the installation is in Japanese with the values given.
No window asking to set Japanese UI language appears. The Japanese is set with the answer file.

I will try with Windows Server 2008 R2 as I found a download link:

Windows Server 2008 R2 SP1 Download Officially from Microsoft's Server

Edited by myselfidem, 06 August 2012 - 12:29 PM.

For Windows 7 OS: SetProductKey.rar (fr-FR/en-US. Integrate keys).

#19
myselfidem

myselfidem

    Member

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,559 posts
  • OS:Windows 7 x64
  • Country: Country Flag
I made new tests successfully with Windows Server 2008 R2 SP1 on Oracle VM VirtualBox.
I downloaded: "7601.17514.101119-1850_x64fre_server_eval_ja-jp-GRMSXEVAL_JA_DVD.iso" file.
However you need to check your Autounattend.xml file with WSIM to see if there is errors and correct them.

The image name I chose is: "Windows Server 2008 R2 SERVERENTERPRISE"

Using the Autounattend.xml attached works and the silent installation for Japanese works fine without asking for the language UI or key to install...

You can use imagex.exe to read all the image names inside install.wim file.

You can try to download a new time the iso image! ;)

Images Windows Server 2008

*Edit: I think you don't use a full Japanese version Windows Server 2008 R2
Windows 2008 R2 Answer File for Unattended Installation

Open and check inside the folder: sources\lang.ini "Available UI Languages"
Inside the tested version I tried I can read (full Japanese):

[Available UI Languages]
ja-JP = 3

[Fallback Languages]
ja-JP = en-us

*Edit 2: How to add a language pack (inside install.wim and boot.wim images): Select correctly the language packs SP0 or SP1

Understanding Multilingual Deployments

Create a Distribution Share for a Multilingual Image

Walkthrough: Add Multilingual Support to Windows Setup

Windows Server 2008 R2 Multilingual User Interface Language Packs

Attached Files


Edited by myselfidem, 07 August 2012 - 01:35 PM.

For Windows 7 OS: SetProductKey.rar (fr-FR/en-US. Integrate keys).




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users



How to remove advertisement from MSFN