Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account



Photo

Win 8 AutoUnattend.xml OOBE


  • Please log in to reply
1 reply to this topic

#1
LiveFreeDead

LiveFreeDead
  • Member
  • 1 posts
  • Joined 07-August 12
  • OS:none specified
  • Country: Country Flag
Hello, I've been working on automating my Windows 8 and haven't been able to find information regarding the "Use Express Settings" Section of OOBE, I'd really like to automate this step so my install is able to get to Metro/Desktop to install the silent Applications.

http://technet.micro...y/hh825039.aspx

I've read the above link and not found any extra options to work with the new Windows 8 features in OOBE.

Here is my working AutoUnattend.xml in case anyone is interested in one that "nearly" works properly (just lacking Auto OOBE stuff).

<?xml version="1.0" encoding="utf-8"?>
<unattend xmlns="urn:schemas-microsoft-com:unattend">
    <settings pass="windowsPE">
        <component name="Microsoft-Windows-International-Core-WinPE" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="NonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <SetupUILanguage>
                <UILanguage>en-US</UILanguage>
            </SetupUILanguage>
            <InputLocale>en-US</InputLocale>
            <UserLocale>en-US</UserLocale>
            <UILanguage>en-US</UILanguage>
            <SystemLocale>en-US</SystemLocale>
        </component>
        <component name="Microsoft-Windows-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="NonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <UserData>
                <AcceptEula>true</AcceptEula>
                <ProductKey>
                    <Key>XXXXX-XXXXX-XXXXX-XXXXX-XXXXX</Key>
                    <WillShowUI>OnError</WillShowUI>
                </ProductKey>
                <Organization>Home</Organization>
                <FullName>Computer</FullName>
            </UserData>
        </component>
    </settings>
    <settings pass="oobeSystem">
        <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="NonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <AutoLogon>
                <Enabled>true</Enabled>
                <LogonCount>1</LogonCount>
                <Username>Administrator</Username>
            </AutoLogon>
            <FirstLogonCommands>
                <SynchronousCommand wcm:action="add">
                    <Description>Post Setup OEM</Description>
                    <Order>100</Order>
                    <CommandLine>cmd /c %WINDIR%\Setup\Scripts\FirstLogon.cmd</CommandLine>
                </SynchronousCommand>
            </FirstLogonCommands>
            <OOBE>
                <HideEULAPage>true</HideEULAPage>
                <NetworkLocation>Home</NetworkLocation>
                <ProtectYourPC>1</ProtectYourPC>
                <HideOnlineAccountScreens>true</HideOnlineAccountScreens>
                <HideLocalAccountScreen>true</HideLocalAccountScreen>
                <HideWirelessSetupInOOBE>true</HideWirelessSetupInOOBE>
            </OOBE>
            <TimeZone>Tasmania Standard Time</TimeZone>
            <UserAccounts>
                <LocalAccounts>
                    <LocalAccount wcm:action="add">
                        <Description>Default Administrator Account</Description>
                        <DisplayName>Administrator</DisplayName>
                        <Group>Administrators</Group>
                        <Name>Administrator</Name>
                    </LocalAccount>
                </LocalAccounts>
            </UserAccounts>
        </component>
        <component name="Microsoft-Windows-International-Core" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <InputLocale>en-AU</InputLocale>
            <SystemLocale>en-AU</SystemLocale>
            <UILanguage>en-AU</UILanguage>
            <UILanguageFallback>en-US</UILanguageFallback>
            <UserLocale>en-AU</UserLocale>
        </component>
    </settings>
    <settings pass="specialize">
        <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="NonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <ComputerName>PCNAME</ComputerName>
        </component>
        <component name="Microsoft-Windows-Deployment" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
            <RunSynchronous>
                <RunSynchronousCommand wcm:action="add">
                    <Order>3</Order>
                    <Description>Enable FirstLogon As Admin</Description>
                    <Path>reg add &quot;HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers&quot; /v &quot;%WINDIR%\Setup\Scripts\FirstLogon.cmd&quot; /t REG_SZ /d &quot;RUNASADMIN&quot; /f</Path>
                </RunSynchronousCommand>
                <RunSynchronousCommand wcm:action="add">
                    <Order>4</Order>
                    <Description>Comp Flags for setupcomplete.cmd</Description>
                    <Path>reg add &quot;HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\AppCompatFlags\Layers&quot; /v &quot;%WINDIR%\Setup\Scripts\setupcomplete.cmd&quot; /t REG_SZ /d RUNASADMIN /f</Path>
                </RunSynchronousCommand>
                <RunSynchronousCommand wcm:action="add">
                    <Description>Enable Admin Account</Description>
                    <Order>5</Order>
                    <Path>net user administrator /active:yes</Path>
                </RunSynchronousCommand>
            </RunSynchronous>
        </component>
    </settings>
    <cpi:offlineImage cpi:source="wim:f:/build8/win8x64/sources/install.wim#Windows 8 Pro" xmlns:cpi="urn:schemas-microsoft-com:cpi" />
</unattend>


It would also be nice to disable the OOBE Tutorial, I've seen it once now and think I've figured out how to use windows 8 :D

so if anyone knows how to bypass the Customize Settings section that has been added to Windows 8? I just want to use/set it to Express Settings by default not have that screen stop Windows from continuing to boot until I pick something, silent until the desktop/Metro.

Edited by LiveFreeDead, 07 August 2012 - 11:36 AM.



How to remove advertisement from MSFN

#2
MrJinje

MrJinje

    Toolâ„¢ Developer

  • Developer
  • 1,051 posts
  • Joined 14-October 09
  • OS:Server 2012R2
  • Country: Country Flag
I believe you got some help over at MDL. Let me know if I am wrong and you still need help




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users