• Announcements

    • xper

      MSFN Sponsorship and AdBlockers!   07/10/2016

      Dear members, MSFN is made available via subscriptions, donations and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, become a site sponsor and ads will be disabled automatically and by subscribing you get other sponsor benefits.
mattiasnyc

Need help with data recovery on HDD

52 posts in this topic

Went to boot my computer and it wouldn't go past POST. BIOS couldn't find OS or drive. This was as I mentioned the OS drive and I didn't touch it prior to shutting down. I never initialize drives "willy nilly". The words "initialize", "erase", "format" etc throw up red flags in my brain and I've yet to be dumb enough to clean a drive from data. I'm plenty dumb in other ways to make up for it though.

Then I went to the thread called " The Solution for Seagate 7200.11 HDDs" and went through the instructions and "unbricked" it. The symptoms of my drive conformed to the ones the "unbricking" would potentially solve.

The drive then spun up properly and got detected by the OS. After that I tried absolutely nothing else but instead posted in this thread.

I'm guessing "file based recovery" is some sort of time consuming scan where the software tries to intelligently piece together what binary constitutes a file, and what type of file that would be... Would that be the next step?

Thanks again for your help and patience.

0

Share this post


Link to post
Share on other sites

Went to boot my computer and it wouldn't go past POST. BIOS couldn't find OS or drive. This was as I mentioned the OS drive and I didn't touch it prior to shutting down. I never initialize drives "willy nilly". The words "initialize", "erase", "format" etc throw up red flags in my brain and I've yet to be dumb enough to clean a drive from data. I'm plenty dumb in other ways to make up for it though.

Yes, OK, but were BSY or LBA0 symptoms?

Then I went to the thread called " The Solution for Seagate 7200.11 HDDs" and went through the instructions and "unbricked" it. The symptoms of my drive conformed to the ones the "unbricking" would potentially solve.

Which EXACT commands did you send to it in the Hyperterminal (or whatever you used)?

The drive then spun up properly and got detected by the OS. After that I tried absolutely nothing else but instead posted in this thread.

Yes, the issue here is that your drive behaves "strangely".

The MBR CODE is there, exactly where it should be, but the data in it have been "00ed". <- this is "queer", usually either the "whole" MBR is there or it has been completely (not just 16 bytes of it) 00ed.

Also, it seems like all the sectors you accessed are all 00's (wiped).

I am suspecting that - for *any* reason - the disk has gone in some kind of "loop" :w00t: and - besides the MBR - only "provides" the same bunch of 00ed sectors :unsure: , no matter which sector you try to access.

I'm guessing "file based recovery" is some sort of time consuming scan where the software tries to intelligently piece together what binary constitutes a file, and what type of file that would be... Would that be the next step?

Yep, that is the idea, that has a big caveat, though.

Provided that the disk is not all 00's, any file that was contiguous should normally be retrieved without issues, whilst any file that was fragmented will most probably result as either corrupted or "partial".

The "reference" tool is PHOTOREC (the companion of TESTDISK):

http://www.cgsecurity.org/wiki/PhotoRec

(it is not just for photos)

Thanks again for your help and patience.

No prob. :)

Let's try again to see if some data can actually be read on that disk.

Open the disk in Tiny Hexer and search, starting from sector 0 the hex 4D5A90 (which equates to "MZ<nop>", i.e. the header for executable files, one of the most common filetypes on a "system" disk).

If you don't find a hit within (say) first 50000 sectors it is likely that there is the "all 00's issues.

Are you trying to access the "original, unbricked" disk or the clone of it? (can it be, if the latter, that the cloning failed?)

jaclaz

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.