Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account


Photo

Exchange 2010 and OWA external


  • Please log in to reply
5 replies to this topic

#1
anthonyaudi

anthonyaudi

    Member

  • Members
  • PipPip
  • 146 posts
Hello guy's I'm not 100% sure if this is the right forum to be posting this in it is server related so I will post it here.

I recently installed Server 2008 R2 with Exchange 2010.

Everything works fine so I'm now at the step of getting OWA to work.

OWA works fine from the internal. I put https://localhost/owa and it goes to OWA fine.

From the outside I contacted the guys who manage my DNS and I had them create a pointer to my external ip. When I ping my new pointer it resolves to my static IP. So I know that is working.

When I go to https://externaladdress/owa I am returned with the following message

404 Not Found
The requested URL /owa was not found on this server.

So I'm not sure what the problem could be?

I enabled Outlook Anywhere.

Active Sync seems to be enabled also.

Port 443 seems to be open on my server (I don't manage the firewall) but I can open a command prompt and do "telnet localhost 443" and it logs in.

I assume it is a certificate error.

When I try to create a self sign certificate in exchange management console everything goes fine until I have to complete the pending request.

When I try to complete the pending request it asks to find the .cer file which I have no idea where it would be.

So I'm stuck there.

By default Exchange 2010 comes with the Default Certificate. I don't know if I have to create another one for the External because the default certificate asks me to put the External URL for OWA.

Any help would be greatly appreciated.

Thanks!


How to remove advertisement from MSFN

#2
Tripredacus

Tripredacus

    K-Mart-ian Legend

  • Super Moderator
  • 9,502 posts
  • OS:Server 2012
  • Country: Country Flag

Donator

OWA works fine from the internal. I put https://localhost/owa and it goes to OWA fine.

From the outside I contacted the guys who manage my DNS and I had them create a pointer to my external ip. When I ping my new pointer it resolves to my static IP. So I know that is working.

When I go to https://externaladdress/owa I am returned with the following message

404 Not Found
The requested URL /owa was not found on this server.


Well before you bother with DNS or Firewall... those ARE working. We know this because you are getting a response from the webserver: the 404 error. There is a problem in your webserver (is it IIS?) ... maybe others can answer, but my quick thing would be to test all the addresses.

First. you tried both "localhost" and the external address ONLY from the Exchange Server? Try these:

- from server: Internal IP
- from another computer on the same internal subnet as the server: Internal IP, External IP
- from another computer outside the subnet or network: External IP

#3
anthonyaudi

anthonyaudi

    Member

  • Members
  • PipPip
  • 146 posts
Hello thanks for the reply.
The sever works with the internal IP and the DNS name
it also works from another PC (internal IP and DNS name)
The outside machines cannot connect to the external IP . I receive that error.

The only thing I can think of for IIS would be it is not configured? But by default Exchange 2010 sets these things up for you when you install it. What also doesn't make sense to me is when I put the internal IP with /owa it get redirected to the OWA home page.
When I do this with the external IP I get the above error (cannot find /OWA on this server)

I am thinking it is a firewall rule because I am thinking that when we put this external address it is being directed to another server that Exchange is not installed on.

Edited by anthonyaudi, 22 August 2012 - 06:56 AM.


#4
Tripredacus

Tripredacus

    K-Mart-ian Legend

  • Super Moderator
  • 9,502 posts
  • OS:Server 2012
  • Country: Country Flag

Donator

I am thinking it is a firewall rule because I am thinking that when we put this external address it is being directed to another server that Exchange is not installed on.


Well you can easily test this out by making a change to your 404 page. Then try to hit the site and see if your change is shown, or if you see what you saw before.

#5
anthonyaudi

anthonyaudi

    Member

  • Members
  • PipPip
  • 146 posts
How would I do that?

#6
Tripredacus

Tripredacus

    K-Mart-ian Legend

  • Super Moderator
  • 9,502 posts
  • OS:Server 2012
  • Country: Country Flag

Donator

How would I do that?


In IIS, under your website name (or Default Web Site), go to Error Pages. You can then either specify a custom one, or it will tell you where the current one is located. Its an .htm file. ;)




1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users



How to remove advertisement from MSFN