Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account



Photo

Power options changing themselves


  • Please log in to reply
6 replies to this topic

#1
doveman

doveman

    Advanced Member

  • Member
  • PipPipPip
  • 391 posts
  • Joined 22-August 05
I set my power options to Balanced, Turn off the Display - Never, Sleep after 30 mins. Every now and then when I check them they've changed to Turn off the Display - 20 mins, Sleep - Never.

I've got no idea what could be causing this and it's very annoying. I even ran a registry change monitor for a while in an attempt to catch whatever was doing it but it never happened whilst I was doing that.

Has anyone got any ideas how to fix this or find out what's causing it?

I'm running WIndows 7 x64 with Avira Antivir and Comodo Firewall.


How to remove advertisement from MSFN

#2
CharlotteTheHarlot

CharlotteTheHarlot

    MSFN Master

  • Member
  • PipPipPipPipPipPipPipPip
  • 2,054 posts
  • Joined 24-September 07
  • OS:none specified
  • Country: Country Flag
I've had this exact problem mentioned by several customers. Of course it never happens while I have their computer, only when they take it home.

My guess is that it is some screensaver or other application that interfaces with Power options.

I've gotten into the habit of setting the power options and then saving it as a custom power profile (with their name in it) so that they can simply select it when the problem occurs. This quickly reinstates all the saved options at once (they do not need to poke around all the sub-choices).

... Let him who hath understanding reckon the Number Of The Beast ...


#3
doveman

doveman

    Advanced Member

  • Member
  • PipPipPip
  • 391 posts
  • Joined 22-August 05
It may be some application (I don't have any screensavers installed) but I can't think what. That's why I tried monitoring for any registry changes to catch it but didn't manage to unfortunately.

Whilst selecting a custom profile might be easier than adjusting the settings, it's not really a suitable solution for me as I'm fed up with the display turning off after 20 minutes when I'm watching video with Mediaportal, so I really need to find out what's causing this and fix it.

#4
iamtheky

iamtheky

    Friend of MSFN

  • Member
  • PipPipPipPipPip
  • 866 posts
  • Joined 11-November 08
group policy? If present, you can either undo the previous settings that are causing this, or if not set some policy and maybe that will persist.
iamtheKy

#5
doveman

doveman

    Advanced Member

  • Member
  • PipPipPip
  • 391 posts
  • Joined 22-August 05

group policy? If present, you can either undo the previous settings that are causing this, or if not set some policy and maybe that will persist.


I'm not really sure how to do that. All the guides I've looked at refer to Computer Management/Policies/Administrative Templates/System/Power Management but I don't have Policies when I open gpedit.msc and for me it's Computer Management/Administrative Templates/System/Power Management. Certainly under that everything is "Not Configured".

#6
iamtheky

iamtheky

    Friend of MSFN

  • Member
  • PipPipPipPipPip
  • 866 posts
  • Joined 11-November 08
So if you set as policy the behavior you want:

Specify the Unattended Sleep Timeout (plugged in) , enabled, and set to 0.

If you enable this policy setting, you must provide a value, in seconds, indicating how much idle time should elapse before Windows automatically transitions to sleep when left unattended. If you specify 0 seconds, Windows will not automatically transition to sleep.


Does it still timeout?
iamtheKy

#7
doveman

doveman

    Advanced Member

  • Member
  • PipPipPip
  • 391 posts
  • Joined 22-August 05

So if you set as policy the behavior you want:

Specify the Unattended Sleep Timeout (plugged in) , enabled, and set to 0.

If you enable this policy setting, you must provide a value, in seconds, indicating how much idle time should elapse before Windows automatically transitions to sleep when left unattended. If you specify 0 seconds, Windows will not automatically transition to sleep.


Does it still timeout?


Well the profile as I configured it is to sleep after 30mins and never turn off the display. So I can set "Specify the Unattended Sleep Timeout (plugged in)" to 30 mins and "Turn off the Display" to 0 and see if that stops it changing. The problem with that is I might want to switch from Balanced to High Performance profile (this is one of the things that Gamebooster does when switching to Gaming Mode, mainly because it disables CPU power saving so stops it changing P-States) and with the settings fixed in Group Policy like this, they won't be able to change when I switch profile.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users