Win9xFreak

Windows ME driver help!

13 posts in this topic

Does anyone here know where I could find an Ethernet driver for Windows ME???

I searched the internet for many but I could not find one that would allow me to connect to the internet.

Can someone help me???

Edited by Win9xFreak
0

Share this post


Link to post
Share on other sites

You need to identify the device brand.

0

Share this post


Link to post
Share on other sites

One detail I forgot to mention:

I dual-booted ME and XP and on Windows XP I installed a nVidia ethernet controller (or something like that) so I guess that would be the brand. (I think...)

0

Share this post


Link to post
Share on other sites

Riddle me this, Batman...

On the XP in Device Manager, does it say EXACTLY what it is? There is NO SUCH THING a "Generic nVidia" (or something like that)...

0

Share this post


Link to post
Share on other sites

Anyone know where I could get a nvidia nforce ethernet driver? I would like to connect to the internet with windows ME if possible.

0

Share this post


Link to post
Share on other sites

Does it show up at all in the Device Manager? If so, what does Properties say? (maybe an "Unknown Device" is showing up?)

0

Share this post


Link to post
Share on other sites

And, before anything, which motherboard, processor, video card and how much RAM?

0

Share this post


Link to post
Share on other sites

No unknown device shown in device manager. Just Dial-Up Adapter and 2 NDIS 1394 Net Adapters. Not sure what motherboard or video card I have, but I have an Intel Pentium D and 512 mb of RAM.

Edited by Win9xFreak
0

Share this post


Link to post
Share on other sites

Pentium D means nVidia 4 series chipset... there are no Win 9x/ME Ethernet drivers at all for that chipset family, AFAIK, I regret to say. You're on a wild goose chase.

0

Share this post


Link to post
Share on other sites

Thanks, I was getting annoyed that I couldn't find a driver. Also, is there a Sound Blaster Audigy 2 driver for ME? I don't have sound on ME either. :(

0

Share this post


Link to post
Share on other sites

Look up for the file SBA2_EAX4DRV_031031.exe for the Audigy 2.

0

Share this post


Link to post
Share on other sites

Thanks to everyone for all their help. I knew that I made the right choice by coming here. So thank you all. :thumbup :thumbup :thumbup :thumbup

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.