• Announcements

    • xper

      MSFN Sponsorship and AdBlockers!   07/10/2016

      Dear members, MSFN is made available via subscriptions, donations and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, become a site sponsor and ads will be disabled automatically and by subscribing you get other sponsor benefits.
MagicAndre1981

Trace why Windows 8 boots, shutsdown or hibernates slowly

371 posts in this topic

Hello,

I am having trouble with a slow boot on a Sony vaio SA laptop using an SSD and I am also getting a slow resume speed.

I have attached my start up log any ideas?

James

Edited by encephalartos
0

Share this post


Link to post
Share on other sites

you made a normal boot.


<timing bootDoneViaExplorer="21912" bootDoneViaPostBoot="35612"

Windows boots in 21.9s to the Startscreen/desktop and is fully booted in 25.6s.

I can see that the service Function discovery takes over 9s to start:


<serviceTransition name="FDResPub" group="" transition="start" totalTransitionTimeDelta="9809

Have you tried the fast startup? this should solve the long service start issue, the suspend/resume is much faster.

0

Share this post


Link to post
Share on other sites

I have looked around online and done what I can and it looks like fast boot is enabled so could it be my system that does not like it?

James

0

Share this post


Link to post
Share on other sites

you used the wrong command. Your command did a normal boot. Use the fastStartup command at the end of the guide. Also make sure fastStartup is enabled in the power option.

0

Share this post


Link to post
Share on other sites

it is much faster, not only a little.


<timing bootDoneViaExplorer="10350" bootDoneViaPostBoot="22950" postBootDisturbance="2600"

Windows boots in 10.4s to the UI and is fully booted in 12.9s.

the longest delay is resuming the VSNService, which takes 4.7s and causes most of the time your system takes to resume (9.8s)


<interval name="SystemResume" startTime="27042" endTime="36819" duration="9777">

<suspendservices start="5897760" duration="4723872" totalChildrenDuration="4723719">
<service start="5918982" duration="4644958" name="VSNService" />

Do you need this special VAIO Utility? if not disable it.

0

Share this post


Link to post
Share on other sites

Thanks you very much for your time,

the vaio boot thing controls most of my butters and stamina/speed switch so I would need to see what happens when i disable it

0

Share this post


Link to post
Share on other sites

Can you help me why my windows 8 boot slow when I enabled Fast Boot. I use acer aspire 4755G with 8gb ram and SSD 120GB

Boot XML - https://skydrive.live.com/redir?resid=14FCB212EC558DF5!418&authkey=!AFQZY6147Bl3ZaI

Hibernate XML - https://skydrive.live.com/redir?resid=14FCB212EC558DF5!419&authkey=!AA2UcSBybl-ZWVA

Shutdown XML - https://skydrive.live.com/redir?resid=14FCB212EC558DF5!417&authkey=!ACG8Vl0kqkF-q1g

Thanks before

0

Share this post


Link to post
Share on other sites

looks like the reading of the hibernation file is slow:


hiberread="77696000"

your Hitachi Travelstar 5K250 160GB is not the fastest HDD.

0

Share this post


Link to post
Share on other sites

looks like the reading of the hibernation file is slow:


hiberread="77696000"

your Hitachi Travelstar 5K250 160GB is not the fastest HDD.

Oh yeah, those HDD is my secondary Drive and I installed at HDD Caddy, I got it from my old laptop. My Primary is SSD Team Xtreem S3 120GB and I install windows 8 in SSD.

Maybe I will try to tweak hibermate settings :-/ (size to 100%)

0

Share this post


Link to post
Share on other sites

<unexpectedLonglived>

<process name="smss.exe" startTime="5376" endTime="-1" lifetime="-1"/>

<process name="csrss.exe" startTime="426505" endTime="-1" lifetime="-1"/>

<process name="csrss.exe" startTime="428346" endTime="-1" lifetime="-1"/>

is this normal?

0

Share this post


Link to post
Share on other sites

is this normal?

yes, those are 3 critical Windows processes which run all the time. Ignore this.

0

Share this post


Link to post
Share on other sites

is this normal?

yes, those are 3 critical Windows processes which run all the time. Ignore this.

I was asking because my fresh install of Windows 8 takes 5+ minutes or so to boot.

summary_boot.xml

0

Share this post


Link to post
Share on other sites

SMSSInit is very slow.

<interval name="SMSSInit" startTime="5376" endTime="429690" duration="424314">

I need the ETL file to see more. Why are you not using the new fast startup?

0

Share this post


Link to post
Share on other sites

SMSSInit is very slow.

<interval name="SMSSInit" startTime="5376" endTime="429690" duration="424314">

I need the ETL file to see more. Why are you not using the new fast startup?

The fast startup option in the power options? I am using it.

My ETL is 100mb

post-367845-0-62349100-1354819474_thumb.

Edited by asdfdsa
0

Share this post


Link to post
Share on other sites

you have disk IO. Check if Autochk.exe is the cause (click on the left icon next to the disk io graph)

If you use fast boot, run the faststartup xbootmgr command at the end of the guide. You did the normal "old-school" boot.

0

Share this post


Link to post
Share on other sites

you have disk IO. Check if Autochk.exe is the cause (click on the left icon next to the disk io graph)

If you use fast boot, run the faststartup xbootmgr command at the end of the guide. You did the normal "old-school" boot.

All I got from the graph was ' System Processes (4) '

Also I renamed Autochk.exe, but there was no difference in the boot time.

Edited by asdfdsa
0

Share this post


Link to post
Share on other sites

compress the ETL file, upload it to SkyDrive or Dropbox and send me the link.

0

Share this post


Link to post
Share on other sites

the trace shows autochk runs at this time. Delete the autochk entry from BootExecute in the registry and run chkdsk yourself.

0

Share this post


Link to post
Share on other sites

the trace shows autochk runs at this time. Delete the autochk entry from BootExecute in the registry and run chkdsk yourself.

Again there was little to no difference in boot time.

Any idea why smss.exe would be taking so long?

0

Share this post


Link to post
Share on other sites

smss.exe runs so long because autochk runs during boot (smss:BootExecute)

0

Share this post


Link to post
Share on other sites

smss.exe runs so long because autochk runs during boot (smss:BootExecute)

I stopped autochk from running, there is no difference in boot time.

0

Share this post


Link to post
Share on other sites

this time InitializeRegistry takes so much time.

Add +Registry+REG_HIVE to the command (after POWER) and -stackwalk RegQueryKey+RegDeleteKey+RegCreateKey+RegOpenKey+RegSetValue+RegDeleteValue+RegQueryValue+RegCloseKey+RegCloseKey

xbootmgr -trace boot -traceFlags BASE+CSWITCH+DRIVERS+POWER+Registry+REG_HIVE -stackwalk RegQueryKey+RegDeleteKey+RegCreateKey+RegOpenKey+RegSetValue+RegDeleteValue+RegQueryValue+RegCloseKey -resultPath C:\TEMP

this activates registry data collection.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.