Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account


Photo

DISM Error during Win PE Optimization

- - - - -

  • Please log in to reply
5 replies to this topic

#1
BigDawgFelton

BigDawgFelton

    Newbie

  • Member
  • 11 posts
  • OS:Windows 7 x86
  • Country: Country Flag
Hey Guys,

I have build a WinPE image from the WinPE Builder from this site. I have done all of my customizations to the image and am ready for optimization. I keep getting an error in DISM on just this one image. Others are working fine. I have booted to the image, done what the image is intended to do an then tried to apply the profile but it is not working. Can anyone please help?

This is the error that I am seeing that I am assuming is causing the process to fail, but I don't know what it means or why it is happening.




2012-09-04 14:58:04, Error DISM Windows PE Image Manager: PID=2760 Required file not found: \programdata\microsoft\windows\wer - CPEImageManager::ApplyProfile
2012-09-04 14:58:04, Error DISM DISM.EXE: PE Provider processed the command line but failed. HRESULT=80004005


How to remove advertisement from MSFN

#2
Tripredacus

Tripredacus

    K-Mart-ian Legend

  • Super Moderator
  • 9,699 posts
  • OS:Server 2012
  • Country: Country Flag

Donator

Hey Guys,

I have build a WinPE image from the WinPE Builder from this site.


There are multiple PE builders here. Which one specifically?
MSFN RULES | GimageX HTA for PE 3.x | lol probloms
msfn2_zpsc37c7153.jpg

#3
BigDawgFelton

BigDawgFelton

    Newbie

  • Member
  • 11 posts
  • OS:Windows 7 x86
  • Country: Country Flag
It was actually the Make_PE program that "wimb" had posted. I tested a base image produced from the program using the media version without any of my customizations and this also didn't work. I saw the same error. It must be something with the way that particular image is created.

#4
Tripredacus

Tripredacus

    K-Mart-ian Legend

  • Super Moderator
  • 9,699 posts
  • OS:Server 2012
  • Country: Country Flag

Donator

I'm not sure I've ever applied a profile (on purpose) to a Make_PE3. You are using Windows 7 PE, and WAIK for Windows 7 correct?
MSFN RULES | GimageX HTA for PE 3.x | lol probloms
msfn2_zpsc37c7153.jpg

#5
wimb

wimb

    Senior Member

  • Developer
  • 677 posts
I think you can only use /Apply-Profiles for the case of pe3_x86 type and not for 7pe_x86 type ISO

The difference between 7pe and pe3
- 7pe is made without using AIK and is made from Recovery boot image winre.wim on Win 7 drive or from boot.wim on DVD
- pe3 is made using AIK for Win7 and is made from winpe.wim boot image present in AIK
- 7pe contains Recovery software in folder sources which is missing in pe3
- pe3 option NO Reduce of size has /Enable-profiling which allows to make Optimization profile (see WinPE.chm help in WAIK)


http://www.911cd.net...showtopic=23931

Edited by wimb, 06 September 2012 - 01:19 AM.


#6
BigDawgFelton

BigDawgFelton

    Newbie

  • Member
  • 11 posts
  • OS:Windows 7 x86
  • Country: Country Flag
I (Think) I am using the make_pe3 program that was for the ISO but i'm not sure. I created the .wim file and just pulled it out of the directory it was created to and started modifying it. How can I tell which version I am using?




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users



How to remove advertisement from MSFN