Kelsenellenelvian

Languages, Themes, Manuals & Mods

185 posts in this topic

However, it seems to solve the little slight leftward movement it's needed also to change inside:

themewizardtemplate_tooltips.htm

Move </div> to line 503 and </div> to line 525 like this:

<div id="TextPaddingValue" class="opTxt" style="width:3em;"></div>

<div id="TransparencyValue" class="opTxt" style="width:3em;"></div>

Thanks and regards

*Edit:

Move </div> to line 10 inside aboutwpitemplate_changelog.htm

<div id="ChangeLog" class="opTxt" style="width:100%; height:225px; overflow:auto;"></div>

Edited by myselfidem
0

Share this post


Link to post
Share on other sites

About icon inside WPI Installer, I suggest as test to try to change inside the file, to display the wpi.ico:

Installer.hta change:


<script type="text/javascript">
document.write('<script type="text/javascript"' +
('<HTA:APPLICATION ID="oWPI_Installer"' +
' application="yes"' +
' singleInstance="yes"' +
' applicationName="Windows Post-Install Wizard Installer"' +
' version="'+ShortVersion+'"' +
' icon=""' +
' border="dialog"' +
' borderStyle="normal"' +
' innerBorder="no"' +
' caption="yes"' +
' sysMenu="no"' +
' contextMenu="no"' +
' minimizeButton="no"' +
' maximizeButton="no"' +
' navigable="yes"' +
' scroll="no"' +
' scrollFlat="no"' +
' selection="no"' +
' showInTaskBar="yes"' +
' windowState="normal"' +
' />') +
' </' + 'script>');
</script>

Icon used downloading the Avatar.png on the web site (changing to WPI.ico with GIMP):

Installer window

Tested and works fine!

The icon will be fixed inside Installer and it seems start is faster !

Thanks to check if it's OK.

Regards

WPI Installer icon

*Edit: french manual updated (added Comparison operator ===)

http://www.mediafire.com/#6696bficr91ar

*Edit: script updated

*Edit2: However, the window Installer can be resized using the script above!

Edited by myselfidem
0

Share this post


Link to post
Share on other sites

Had the language file been updated? Send me please English lang file in PM and i'll update Ukrainian one.

0

Share this post


Link to post
Share on other sites

I would suggest to add "function getProductKey" inside WPI to know the Windows key!

I found the code here (at the bottom of the web page):

JS/VB Product Key Viewer (THANK YOU RPGFAN!)

1 - Adding inside wmi.js (from line 349); [or maybe inside core.js and wmi.js ?] :


function getProductKey()
{
position="wmi.js";
whatfunc="getProductKey()"; // Thanks to TheTeenScripter

var shell = new ActiveXObject("WScript.shell");
var DigiProdId = shell.RegRead("HKLM\\Software\\Microsoft\\Windows NT\\CurrentVersion\\DigitalProductId");
DigiProdId = DigiProdId.toArray();

var binaryKey = new Array();
for(i=52;i<67;i++)
{
binaryKey[binaryKey.length] = DigiProdId[i];
}
var digits = new Array('B','C','D','F','G','H','J','K','M','P','Q','R','T','V','W','X','Y','2','3','4','6','7','8','9');
var decodedKey = new Array(); // Will be 25 characters at the end

for (var i = 24; i >= 0; i--) {
var k = 0;
for (var j = binaryKey.length - 1; j >= 0; j--) {
k = (k << 8) + binaryKey[j];
binaryKey[j] = (k / 24) & 255; //The "& 255" converts the
k %= 24; //value to a byte.
}
decodedKey.unshift(digits[k]);
}
var ProductKey = "";
for(i=0;i<decodedKey.length;i++)
{
ProductKey += decodedKey[i];
if(Math.floor((i+1)/5) == (i+1)/5 && i != decodedKey.length-1)
{
ProductKey += "-";
}
}
return ProductKey;
}

2 - Inside information.js (line 119):

MyComputerGrid.addRow(gId++,getText(lblProductKey)+','+getProductKey()+'');

3 - Inside global_lang.js (line 321):

var lblProductKey=[];

4 - Inside global.js (line 198):

var SystemEnclosureType, ProductKey;

5 - Inside lang_en.js (at the bottom: line 1102)

lblProductKey[lang]              = ['Product Key'];

On line 1100 inside lang_en.js (missing ; at last):

lblNumberOfCores[lang]          = ['Number Of Cores']; 

Tested and works fine!

Thanks and regards

Edited by myselfidem
0

Share this post


Link to post
Share on other sites

As previously made by Francesco, we can fix a bug using Dependencies (adding a blank line):

http://www.msfn.org/...mmand-selected/

Adding inside configwizard.js on line 833:


if ((document.getElementById("uid").disabled) || (document.getElementById("cmd1").disabled))
Alert("",getText(txtMustAddCommand),"",3,-1,0,0);;

The alert box will appear now (and no more text on the top-left window !)

Tested and works fine! Thanks to check if it's OK.

Regards

Alert Box Dependencies Image

Maybe it would be useful to change also the message box and add (for example):

lang_en.js (line 972):

txtMustAddCommand[lang] = ['You must add a program name (UID) and also a command entry through the \'Add\' button before being able to perform this opreation'];

Regards

*Edit: post updated

Edited by myselfidem
0

Share this post


Link to post
Share on other sites

Bug Fix about Downloading files with WPI using Windows 7 or Windows 8:

Manage BITS (Background Intelligent Transfer Service) with Windows PowerShell

Using Windows PowerShell to Create BITS Transfer Jobs (Windows)

Previous versions of Windows provided command-line management of BITS using the BITSAdmin.exe tool. In Windows 7, BITSAdmin.exe is deprecated. Instead, you should use the Windows PowerShell cmdlets.

To download successfully ({DOWNLOAD}) a file from Internet using Windows 7 or Windows 8, we must add some changes inside installer.js:

From line 1338 we can add:


if (getOSver()=="Win7" || getOSver()=="Win8")
cmdLine='Powershell Start-BitsTransfer -Source '+URL+' -Destination "%TEMP%\\'+Filename+'" -TransferType Download';
fsoCmd=true;

if (getOSver()=="2K" || getOSver()=="XP" || getOSver()=="Vista")

Tested successfully:

http://www.msfn.org/...ost__p__1028736

Thanks and regards

*Edit: post and command updated!

Edited by myselfidem
0

Share this post


Link to post
Share on other sites

@Kels

What do you think about adding some useful infos inside wpi.css to customize Theme, like this:

wpi.css (partial infos):



.navTxt /* text icons on the left: Options, Configuration... */
{
font-family: tahoma;
font-weight: bold;
color: #ffffff;
font-size: 16pt;
}

.timerHeader /* text over the counter */
{
font-family: arial;
color: #ffffff;
font-weight: bold;
font-style: normal;
font-size: 10pt;
}

.timer /* digital counter */
{
font-family: arial;
color: #ffffff;
font-weight: bold;
font-style: normal;
font-size: 24pt;
}

Thanks and regards

Edited by myselfidem
0

Share this post


Link to post
Share on other sites

line 173 replaced with its true meaning.. also I began to translate manual for Turkish, hope I translate it as soon as possible.

lang_tr.js

0

Share this post


Link to post
Share on other sites

About Edition ID for Windows XP.

Result: NOT_FOUND with my Windows XP localized french version.

But, changing inside wmi.js (from line 115) to:


if (szOSVerCache=="XP")
{
szEditionIDCache=objItem.Caption;
}

Tested and works fine! I think it's OK for all localized Windows XP version!

Thanks to check if it's OK.

Image Windows XP Edition

Regards

*Edit: post updated

Edited by myselfidem
0

Share this post


Link to post
Share on other sites

Note: about function getSysPCType() inside wmi.js:

There is no result on Windows XP ("Unspecified"):

Win32_ComputerSystem class (Windows)

PCSystemType

Data type: uint16

Access type: Read-only

Type of the computer in use, such as laptop, desktop, or Tablet.

Windows Server 2003, Windows XP, Windows 2000, Windows NT 4.0, and Windows Me/98/95: This property is not available.

Maybe we can add a comment inside wmi.js (on line 1209):

// This property is not available for: Windows Server 2003, Windows XP, Windows 2000, Windows NT 4.0, and Windows Me/98/95.

Thanks and regards.

Edited by myselfidem
0

Share this post


Link to post
Share on other sites

Inside wmi.js we can add on line 940:

if (objItem.MediaType.toUpperCase().indexOf("DVD WRITER") != -1 || objItem.PNPDeviceID.toUpperCase().indexOf("DVD") != -1)

Adding the second part we can see all values also with Windows XP. CD\DVD Burner was not detected before on XP, but only on Windows 7.

Tested on my computer with dualboot (Windows XP and Windows 7) and works fine!

Thanks and regards

Edited by myselfidem
0

Share this post


Link to post
Share on other sites

I suggest to add a new function for WPI.

1 - Detect KeyboardLayout inside wmi.js (from line 348) :


function getKeyboardLayout()
{
position="wmi.js";
whatfunc="getKeyboardLayout()";

try
{
objWMIService=GetObject("winmgmts:\\\\" + "." + "\\root\\CIMV2");
colItems=objWMIService.ExecQuery("SELECT * FROM Win32_OperatingSystem", "WQL", wbemFlagReturnImmediately | wbemFlagForwardOnly);

enumItems=new Enumerator(colItems);
objItem=enumItems.item();
KeyboardLayout=objItem.Locale;
}
catch(ex)
{
}

return KeyboardLayout;
}

Add inside global.js


// wmi.js
var KeyboardLayout;

Add inside global_lang.js


var lblKeyboardLayout=[];

Add inside information.js (on line 119):


MyComputerGrid.addRow(gId++,getText(lblKeyboardLayout)+','+getKeyboardLayout()+'');

Add inside lang_en.js


lblKeyboardLayout[lang] = ['Keyboard Layout'];

2 - To display properly Language, location and keybordlayout, I suggest to change:

Inside core.js

Change // %OSLANG% to:


// %OSLANG%
var LCID;

CreateLocalArray();
try
{
objWMIService=GetObject("winmgmts:\\\\" + "." + "\\root\\CIMV2");
colItems=objWMIService.ExecQuery("SELECT * FROM Win32_OperatingSystem", "WQL", wbemFlagReturnImmediately | wbemFlagForwardOnly);

enumItems=new Enumerator(colItems);
objItem=enumItems.item();
LCID=objItem.Locale;

for (var x=0; x<arrOSLang.length; x++)
{
if (arrOSLang[x].LCID==LCID)
{
oslang=arrOSLang[x].TLA;
oslocale=arrOSLang[x].Locale;
break;
}
}
}
catch(ex)
{
oslang="ENU";
oslocale="English - United States";
}

// Environment variable for batch file
setEnvVar("HDD",hdd,false);
setEnvVar("CDDRV",cddrv,false);
setEnvVar("WPIPATH",wpipath,false);
setEnvVar("ROOT",root,false);
setEnvVar("OSLANG",oslang,false);
setEnvVar("OSLOCALE",oslocale,false);
}

And remove inside core.js:


function DecToHex(d)
{
position="core.js";
whatfunc="DecToHex()";

var hD="0123456789abcdef";
var h=hD.substr(d&15,1);

while(d>15)
{
d>>=4;
h=hD.substr(d&15,1)+h;
}

return h;
}

Image Computer Information

Tested and works fine for me!

Example:

config.js


pn=1;
prog[pn]=['Ashampoo'];
uid[pn]=['ASHAMPOO'];
ordr[pn]=[1];
dflt[pn]=['yes'];
forc[pn]=['no'];
bit64[pn]=['no'];
cat[pn]=['Applications'];
pfro[pn]=['no'];
cmds[pn]=['{OS=Win8%comma%Win7%comma%Vista%comma%XP} "%wpipath%\\Install\\abs6_free.exe"'];
cond[pn]=['getOSlang()=="FRS"'];
pn++;

WPI_Log.txt


Fichier journal de l'installation WPI

Début de l'installation: mardi 12 février 2013 13:42:47

Information WPI:
Version=8.6.5
Exécutable utilisé=true
Version d'Internet Explorer=9.0
Connexion Internet=true

Système d'exploitation
Version du Système=6.1
Système d'exploitation=Win7
Version actuelle=7601
ID Edition=Ultimate Edition
Service Pack=1

Architecture
Nom de l'Architecture=GenuineIntel
Chaîne du Nom de l'Architecture=Intel(R) Pentium(R) 4 CPU 3.00GHz
ID Architecture=x86 Family 15 Model 4 Stepping 1
Nombre de Processeurs=1
MHz=3000
Type d'Architecture=x86
Bits Architecture=32

Fichier Configuration=C:\WPI_v8.6.5\UserFiles\config.js
Fichier Options=C:\WPI_v8.6.5\UserFiles\useroptions.js
Fichier Réseau=C:\WPI_v8.6.5\UserFiles\networkoptions.js
Fichier Thème=C:\WPI_v8.6.5\UserFiles\themeoptions.js
Fichier Options Fenêtre=C:\WPI_v8.6.5\UserFiles\windowoptions.js

// Window tab
Resolution=1024
MainWindowWidth=800
MainWindowHeight=600
MainWindowX=-1
MainWindowY=-1
InstallerWindowX=25
InstallerWindowY=25

// General tab
NumCols=3
// ---
Timer=true
Seconds=59
StartBeepAtSecs=10
// ---
Language='fr'
// ---
DefaultInstallPath='default'
CustomInstallPath=['']
// ---
AbortInstallIfFailure=false
ExecuteCommandIfFailure=['']
ContinueWhereFailed=false

// Features tab
ShowDownloadOutput=false
DisableInstallCombobox=false
ShowExtraButtons=true
DoNotShowIfCD=true
USSFSilentMode=false
VerifyInstallHDD=false
AllowCheckForInternet=false
LoadDesktopBeforeInstall=false
ReOpenAfterInstall=false
DisableCatCheckBoxes=false
SortWithinCats=false
DisableOnDepsNotMet=true
AlwaysUseScrollBar=true
DontSplitCats=true
InstallByCategory=true
ReallyForce=false
DisableIfDoGray=false
InstallFonts=false
ShowCommandInInstaller=false
ShowInstallerImages=false
AlwaysShowOutputWindow=false
EjectCDWhenDone=false
DoNotShowIfUSB=false
DisableHotKeys=false
MaintainAutoLogonCount=false

// Tools tab
MonitorResolution=0
MonitorDepth=0
MonitorRefresh=0
// ---
ExecuteBeforeEnabled=false
ExecuteBeforebit64=false
ExecuteBefore=['']
ExecuteAfterEnabled=false
ExecuteAfterbit64=false
ExecuteAfter=['']
// ---
RestartComputer=false
RestartType=0
RestartSeconds=30
DoNotLoadDesktop=true
// ---
LogInstallation=true
LogPath=['%systemdrive%\WPI_Log.txt'];
TimeStampLogFile=false

// Audio tab
PlayAudioInInstaller=false
InstallAudio=['']
Volume=75
Shuffle=false
CopyAudioFolder=false
CopyAudioPath=['C:\Audio']
DeleteAudioFolder=false

// Sounds tab
SndWPIStartCB=true
SndWPIStart=['"%wpipath%\Audio\SoundsScheme\Alert.wav"'];
SndInstallStartCB=true
SndInstallStart=['"%wpipath%\Audio\SoundsScheme\AtBeginning.wav"'];
SndInstallSuccessCB=false
SndInstallSuccess=['"%wpipath%\Audio\SoundsScheme\Yes.wav"'];
SndInstallFailCB=false
SndInstallFail=['"%wpipath%\Audio\SoundsScheme\No.wav"'];
SndInstallFinishCB=false
SndInstallFinish=['"%wpipath%\Audio\SoundsScheme\AtEnd.wav"'];

// Style tab
Theme='Win7'
Skin='SkyBlue'
BgPicture=''
// ---
LayoutStyle=3
// ---
ShowToolTips=true

Variables Globales:
%OSLANG%=FRS
%WPIPATH%=C:\WPI_v8.6.5
%ROOT%=C:
%CDROM%=
%USB%=
%DOSPATH%=
%SYSTEMDRIVE%=C:
%WINDIR%=C:\Windows
%PROGRAMFILES%=C:\Program Files
%TEMP%=C:\Users\Antoine\AppData\Local\Temp
%SYSDIR%=C:\Windows\System32
%ALLUSERSPROFILE%=C:\ProgramData
%USERPROFILE%=C:\Users\Antoine
%APPDATA%=C:\Users\Antoine\AppData\Roaming
%COMMONPROGRAMFILES%=C:\Program Files\Common Files

Liste des programmes à installer:
Ashampoo

1 Eléments, 1 Commandes

-----

mardi 12 février 2013 13:42:49
Programme: Ashampoo
ID unique: ASHAMPOO
Ordre: 000001
Catégorie: Applications
mardi 12 février 2013 13:43:13 - cmd1 Succès (Code de retour 0): "C:\WPI_v8.6.5\Install\abs6_free.exe"
mardi 12 février 2013 13:43:14 - Installation terminée.

-----

Nombre d'installations échouées: 0

Installation terminée: mardi 12 février 2013 13:43:14

Thanks to check if it's OK!

Regards

Edited by myselfidem
0

Share this post


Link to post
Share on other sites

To enable DragAndDrop inside Configuration Tab, we can add inside configwizard.js:

Line 185; about: function CreateNavigation()

NavGrid.enableDragAndDrop(true); 

Line 228; about: function CreateConfigurations()

ConfigurationsGrid.enableDragAndDrop(true); 

Thanks to check if it's OK!

Tested and works fine for me.

Regards

Image Enable Drag And Drop

Note: To keep the new order we must change the number(s) manually!

Edited by myselfidem
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.