Welcome to MSFN

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


Sign in to follow this  
Followers 0
vinifera

DWM crap performance

9 posts in this topic

I'm bit lost

I have good machine to run win7

CPU dual core AMD Athlon (X2 5050e)

3 GB ddr2 RAM

and high end GPU GeForce 7950 GT

yet with DWM on, explorer takes 2 secs to open

browsing through folders lags

going into pictures folders and enabling thumbnails takes up to 15 seconds to show them

with DWM off, everything is instant, 1 to 2 seconds

shouldn't the effect be reversed ?

shouldn't the system with GPU usage (which is superior than CPU) be faster ?

(at least in drawing/showing things)

Edited by vinifera
0

Share this post


Link to post
Share on other sites

make a xperf trace and share it (zip it fist to reduce the size).

0

Share this post


Link to post
Share on other sites

without doing all that stuff :P

could it be because my GPU is direct x 9

and I remember that Vista's DWM (longhorn) was actually dx9

but since win7 emulates dx9 unlike 10 and 11

cant it be coz of my gpu being dx9 and win7 emulation of it ?

0

Share this post


Link to post
Share on other sites

Windows 7 doesn't emulate DirectX 9. Make the trace otherwise I can't see what is the cause. Btw, your "high end" GPU is much slower than today low end card or IGPs :D

0

Share this post


Link to post
Share on other sites

it still beats the DWM requirement :P

as it was GeForce 5/Radeon 9500 for it to work as I remember :P

Edited by vinifera
0

Share this post


Link to post
Share on other sites

I would recommend the OP get an XPerf trace, otherwise all we're doing here is guessing. A 7950 isn't the greatest card, but in the Vista days it was capable of getting a 5.9 WEI score, depending on how much vRAM was in the card and what it was clocked at. DWM should run fine on that card on a single monitor with a resolution of 1920x1200 or less, honestly.

0

Share this post


Link to post
Share on other sites

Again, make 2 traces (one with and one without DWM running). If possible use the Win8 WPT version and run the WRPUI and select "CPU usage" and in scenario "video glitches".

0

Share this post


Link to post
Share on other sites

have you made the requested traces?

0

Share this post


Link to post
Share on other sites

believe it or not, I didn't have time :P

kinda rush last 2 weeks and I always planned to do it :(

I'll report back when I do

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.