• Announcements

    • xper

      MSFN Sponsorship and AdBlockers!   07/10/2016

      Dear members, MSFN is made available via subscriptions, donations and advertising revenue. The use of ad-blocking software hurts the site. Please disable ad-blocking software or set an exception for MSFN. Alternatively, become a site sponsor and ads will be disabled automatically and by subscribing you get other sponsor benefits.
Sign in to follow this  
Followers 0
djebulon

Problem with my Seagate Barracuda 7200.11

2 posts in this topic

Hello :)

I have a 1To Seagate barracuda 7200.11 DD and since several weeks, it seems broken.

ST31000333AS

Firmware : SD35

At the beginning I thought it was a BSY state problem and I bought a USB2RS232 converter to manage to fix it.

When I tried to use the hyperterminal following the post :

but without disconnecting the PCB card from the drive for the BSY state problem, I obtained :

ASCII Diag mode

F3 T>/2

F3 2>Z

LED:000000CE FAddr:0025DF1F

LED:000000CC FAddr:0025B7CF

Rst 0x20M

which seems to be the problem preventing the command to be sent to the firmware during the terminal session.

But after disconnecting the PCB card and trying to spin up the drive I obtained :

ASCII Diag mode

F3 T/2

F3 2>Z

Spin Down Complete

Elapsed Time 0.131 msecs

F3 2>U

DiagError 00006008

Spin Error

Elapsed Time 6 mins 44 secs

R/W Status 2 R/W Error 84150180

F3 2>

And the DD didn't spin up.

I only heard a bzzzt ...bzzzt..................................bzzzt ..bzzzt sound as if the drive begins to spin up but switches off after 1 or 2 seconds repeating this sequence again and again.

I tried to make it spin again slightly shaking the drive.. And it worked once (I could access to the data), but as I didn't have another drive to transfer the data (almost 1 To), the drive went in a standby state and didn't start again....

I tried to clean the connectors between the PCB and the drive too (both of them).

I don't know what to do in order to find the real problem of this drive and if their is a solution to fix it.

Does someone can give me an advice ?

thank you in advance :)

0

Share this post


Link to post
Share on other sites

And the DD didn't spin up.

I only heard a bzzzt ...bzzzt..................................bzzzt ..bzzzt sound as if the drive begins to spin up but switches off after 1 or 2 seconds repeating this sequence again and again.

I tried to make it spin again slightly shaking the drive.. And it worked once (I could access to the data), but as I didn't have another drive to transfer the data (almost 1 To), the drive went in a standby state and didn't start again....

I tried to clean the connectors between the PCB and the drive too (both of them).

I don't know what to do in order to find the real problem of this drive and if their is a solution to fix it.

Does someone can give me an advice ?

thank you in advance :)

What you described is "typical".

To spin up the disk motor needs a (relatively) high amount of current.

More often then not, for any reason, including "dirty" or bent contacts or screws not re-tightened firmly or firmly enough, the motor simply doesn't get enough current, particularly if for any other reason the bearing has become, even slightly "sticked".

Verify contacts are not bent, clean them (with isopropyl alcohol and/or a specific electric contact cleaner), clean also the screws AND the PCB pads around the screw holes where the screws make contact.

Make sure that you re-tighten firmly (but do not overdo it) the screws.

Before giving the spin-up command put the disk in a vertical position (resting on one of the "long" sides).

While giving the spin up command try to apply a VERY SLIGHT "percussive maintenance", by lifting the disk a couple of centimeters at the "front" (i.e, making it "hinge" on the side the connector is) and letting it fall on the desk (do put some paper or fabric towels under the disk side) or holding it vertically with your right hand, hit with it in a short (no more than 10÷15 cm) vertical swirl the face-up palm of your left hand.

Of course (and as always) you do the above at your own full risk, and YMMV. :ph34r:

Be warned that what actually happens when a disk does not spin up is that a lot of current is "drawn" from the motor but (in the case of a bad contact of the screws) there is not "enough" ground, and when a lot of current is around and the ground isn't enough, this current must go *somewhere* and it is not rare that an electronic component on the PCB gets an overcurrent and simply (and silently) blows.

No way to know if this actually happened.

If the bearing is actually stuck, you won't be able to "free" it this way.

Compare with:

(AND links within)

jaclaz

Edited by jaclaz
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.