Jump to content

Welcome to MSFN Forum
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. This message will be removed once you have signed in.
Login to Account Create an Account


Photo

Windows 2000 install issues. Help?

- - - - -

  • Please log in to reply
72 replies to this topic

#1
Win98

Win98

    Junior

  • Members
  • Pip
  • 80 posts
  • OS:98SE
  • Country: Country Flag
Alright, Im trying to install windows 2000 on one of my computers. On my 2 laptops, I go to install, and setup gets stuck on "Setup is installing windows 2000" and sit there endlessly. On my Desktop, it would bluescreen somewhere near the beginning of the instilation (Before the "Setup is starting windows 2k") so I toyed around with the Bios and changed AHCI to IDE, and it gets to the format screen, it looks like its formatting fine, but when it gets to 100% i get "Setup was unable to format your drive. It may be damaged", which I know its not, because I have Windows 7 installed on it, and it runs fine. Is there anything else I need to change, or any speical drivers I need to get it past either of those points? Thanks!

Laptop specs:
Toshiba satellite, Athlon x2 2.0ghz (32bit) 3gb ram.
Laptop2: Lenovo z565, Phenom x2 3.0ghz 6gb ram (Ill reduce it since 2k cant handle that)
Desktop
HP Pavillion 2.8ghz athlon x2, 8gb ram (Ill do the same with this)

Thanks!


How to remove advertisement from MSFN

#2
Tommy

Tommy

    Brooke's Tommy honey <3

  • Members
  • PipPipPip
  • 442 posts
  • OS:98SE
  • Country: Country Flag
This might be irrelevant, but is there any service packs slipstreamed into your media? If it's just plain Windows 2000, there might be incompatibilities. It's just a guess at this point though. Also, did you try formatting it with the Windows 7 disk first? It's also possible that Windows 7 is preventing Windows 2000 from functioning properly during the installation.

Also, are there any OSs installed on the laptops? Did you set the laptops to IDE (if possible). I've found a rare case where you needed to load the SATA drivers during the installation. I worked on a laptop that required the drivers slipstreamed into the installation media. Hope this new information helps!

Edited by SearanoX, 26 September 2012 - 09:07 PM.


#3
tomasz86

tomasz86

    www.windows2000.tk

  • Members
  • PipPipPipPipPipPipPipPip
  • 2,497 posts
  • OS:XP Pro x86
  • Country: Country Flag
As always, when installing Win2k on a newer hardware it's recommended to prepare a fully updated source (at least all official updates should be slipstreamed). Even if the media comes with SP4 integrated it is still very old (SP4 was released in 2003...).

With the new versions of BWC kernel / UURollup & PAE enabled you can use up to 8 GB of RAM under Win2k Pro.

Lastly, instead of switching to IDE mode in BIOS I would just recommend integrating proper SATA drivers.

Edited by tomasz86, 26 September 2012 - 10:27 PM.


#4
Win98

Win98

    Junior

  • Members
  • Pip
  • 80 posts
  • OS:98SE
  • Country: Country Flag
It is SP4. I formatted in windows 7...Tried NTFS, and Fat32 and neither worked. On my toshiba laptop, I just have 7 installed, and on the Lenovo, I have XP and 7. There is no IDE option on either of the laptops, just the desktop..
I dont know where to get the sata drivers, or where to put them on the disc. ( Could I make a separate disc, and do the F6 thing at the start of the setup, or does it only support floppy discs?)

Tomasz,, What sources or update do you mean, and how would i slipstream them to the disc? For the 8gb ram thing, do you have a link to download the program to enable that? I will try to find the SATA drivers, and attempt to learn how to integrate them.. Ive never had to do any of this stuff under 98SE, but then again it doesn't like sata.

Edited by Win98, 27 September 2012 - 04:13 PM.


#5
Win98

Win98

    Junior

  • Members
  • Pip
  • 80 posts
  • OS:98SE
  • Country: Country Flag
Well, I cant find any SATA drivers anywhere, so i guess im stuck for now..

#6
tomasz86

tomasz86

    www.windows2000.tk

  • Members
  • PipPipPipPipPipPipPipPip
  • 2,497 posts
  • OS:XP Pro x86
  • Country: Country Flag
@Win98
Could you give more details about your desktop? At the moment it's impossible to tell what kind of motherboard is used there. If you don't know it exactly then you can just run an application like Speccy and upload the report from it.

As for the fully updated source, please check this post for details.

Edited by tomasz86, 29 September 2012 - 11:26 AM.


#7
Win98

Win98

    Junior

  • Members
  • Pip
  • 80 posts
  • OS:98SE
  • Country: Country Flag
I would really like to install it on my laptop (Because I use it a lot more), and im away from the desktop until tomorrow, when I get home. I tried to download the HFSLIP, but when I tried to go to the download page, it says it doesnt exist, so I dont know if i clicked the wrong link for it, or what. Thanks!

Edit: I got it to download, and ive got the folders unpacked.

This is my motherboard: Posted Image

Uploaded with ImageShack.us

Edited by Win98, 29 September 2012 - 11:39 PM.


#8
tomasz86

tomasz86

    www.windows2000.tk

  • Members
  • PipPipPipPipPipPipPipPip
  • 2,497 posts
  • OS:XP Pro x86
  • Country: Country Flag
After you've downloaded and unpacked the archive you can just run the script and wait until it has finished. This may take up to 30-40 minutes on a slower machine (from my experience disk speed is the most important). The updated source will be located in an automatically created SOURCESS folder.

Is the screen shot from your laptop? You will probably need one of the BlackWingCat's drivers. Download ati1208raid2k.cab, unpack it and use files from the SB8xx folder. You can just use nLite to add this driver to your source (the updated one from SOURCESS).

Edited by tomasz86, 30 September 2012 - 01:04 AM.


#9
Win98

Win98

    Junior

  • Members
  • Pip
  • 80 posts
  • OS:98SE
  • Country: Country Flag
So after ive run it once and its made the folders, I run it again and it puts the files into them? Alright. Ill give it a try..

Yes, that is a screenshot of my laptop. Ill download that.

Thanks!

#10
tomasz86

tomasz86

    www.windows2000.tk

  • Members
  • PipPipPipPipPipPipPipPip
  • 2,497 posts
  • OS:XP Pro x86
  • Country: Country Flag
I forgot to mention that you also need to copy your Windows 2000 source files into the SOURCE folder before running the script :blushing:

The files to integrate are already present in the other folders, aren't they?

Edited by tomasz86, 30 September 2012 - 08:23 AM.


#11
Win98

Win98

    Junior

  • Members
  • Pip
  • 80 posts
  • OS:98SE
  • Country: Country Flag
I really have no idea what im doing when it comes to the HFSLIP.... Im a bit lost...

When i try to use nlite to slip the cab file you told me to download, it says unsupported file for some reason, even though it says cab files are supported... Odd.

#12
tomasz86

tomasz86

    www.windows2000.tk

  • Members
  • PipPipPipPipPipPipPipPip
  • 2,497 posts
  • OS:XP Pro x86
  • Country: Country Flag
Even if you don't know too much about HFSLIP / nLite it shouldn't be very difficult. These are the steps you need to do:

  • Download "HFSLIP_ia.7z" from my website and unpack it to a location without spaces, ex. "C:\HFSLIP_ia".
  • Inside "C:\HFSLIP_ia" create a folder called "SOURCE" ("C:\HFSLIP_ia\SOURCE") and copy your Windows 2000 source files (I386, etc.) there.
  • Run the script ("hfslip-1.7.10_beta_J_v10.cmd") using the default settings and wait until it's finished. A new folder called "SOURCESS" with the updated source will be created. This step MUST be done under Windows NT 5.x (2000/XP/2003).
  • Download "ati1208raid2k.cab" and unpack it anywhere.
  • Run nLite, choose "C:\HFSLIP_ia\SOURCESS" as source and integrate the driver (make sure that textmode integration is selected) from "ati1208raid2k\SB8xx".
  • Create a new ISO image with nLite, burn it on a CD (or prepare a bootable USB stick or a HDD based installation, etc.) and install the system.

Edited by tomasz86, 30 September 2012 - 10:31 PM.


#13
Win98

Win98

    Junior

  • Members
  • Pip
  • 80 posts
  • OS:98SE
  • Country: Country Flag
Thanks! I got it to install on my desktop, which is awesome, but it still gets stuck at the same place on my laptops... I'll just use this for a while. Now the only issue I have is finding a ATI radeon HD 4200 driver for 2k (Not quite sure they made one, and all 3 of my computers have this card)

#14
tomasz86

tomasz86

    www.windows2000.tk

  • Members
  • PipPipPipPipPipPipPipPip
  • 2,497 posts
  • OS:XP Pro x86
  • Country: Country Flag
First of all, let's focus on the desktop:

  • Download and install the latest daily version of UURollup. You can find it in the Archive (navigate to "Windows2000\UnofficialUpdatesRollup\Daily"). Download and unpack it, go to "update" and run "update.exe".
  • Download the official AMD drivers from here. Try to install them using the official installer. If it doesn't work then unpack the installer and try to install them using the Device Manager and pointing to "Packages\Drivers\Display\XP_INF" in the unpacked installer folder.
  • Can you see the whole 8 GB of RAM in the system? If not then open "%systemdrive%\boot.ini" (it's hidden by default and may be set to read-only) and change the line (it will be a little bit different depending on your setup):

    multi(0)disk(0)rdisk(0)partition(1)\WINNT="Microsoft Windows 2000 Advanced Server" /FASTDETECT
    to

    multi(0)disk(0)rdisk(0)partition(1)\WINNT="Microsoft Windows 2000 Advanced Server" /PAE /FASTDETECT
    I'd also recommend adding /3GB so the final line should say:

    multi(0)disk(0)rdisk(0)partition(1)\WINNT="Microsoft Windows 2000 Advanced Server" /PAE /3GB /FASTDETECT
    Reboot and check the result. In case the system doesn't start press F8 and choose "VGA mode".
  • Report the results.

Now, as for the laptops, there may be a problem with installation and it may be necessary to use some tricks. First please:

  • Run Speccy on each of them but this time don't do any screen shots but rather click on "File" and choose "Save Snapshot". After that upload the two snapshots so that I can download and check them directly.
  • Have you got access to the disks in the two laptops? What I mean is - are you able to easily take them out and connect to your desktop? I'm asking because sometimes it's pretty complicated depending on the notebook model.

Edited by tomasz86, 02 October 2012 - 01:47 AM.


#15
Win98

Win98

    Junior

  • Members
  • Pip
  • 80 posts
  • OS:98SE
  • Country: Country Flag
I did this (Except i used "Windows2000-UURollup-v10c-x86-ENU.exe" instead of daily, because there is no daily(Scratch that).) I downloaded and unpacked it, everything went fine, I restarted my computer and what not, and it was slow, and 1/2 of my applications wouldnt open.

As for the graphics, I had already tried that driver, but was looking for another because in the middle of the installation, the installer just disappears.. I dont know if the UUrollup would fix it, and i didn't get a chance to unpack the installer and do it manually, because device manager, along with control panel wouldn't open.

Edit: As for the graphics driver, when i unpack it and do it manually, it says that windows was unable to find a driver for the device.. And, the UUrollup did it again, so once again, Reinstalling.

Thanks!

Edited by Win98, 02 October 2012 - 10:46 PM.


#16
Win98

Win98

    Junior

  • Members
  • Pip
  • 80 posts
  • OS:98SE
  • Country: Country Flag
Alright, I feel like a complete id*** (Why does it sensor this word?)-- I thought by archive you meant the page with all of the UUrollup downloads and what not... Didnt get that I was supposed to "Windows 2000 archive" link, and go through that... Im going to see if this fixes it! I feel retarded..

Ok, I got the correct thing installed, and it lets me get the graphics installer past where i could get it before, BUT the screen resolution is messed up and i cant get to any of the keys to tell it to install, AND its doing just like the other stuff did- I cant use device manager (Doesnt open anything when i click it), I cant move things on my desktop, ect... Why does this happen?

(Sorry to double post)

Edited by Win98, 02 October 2012 - 11:05 PM.


#17
tomasz86

tomasz86

    www.windows2000.tk

  • Members
  • PipPipPipPipPipPipPipPip
  • 2,497 posts
  • OS:XP Pro x86
  • Country: Country Flag

I did this (Except i used "Windows2000-UURollup-v10c-x86-ENU.exe" instead of daily, because there is no daily.) I downloaded and unpacked it, everything went fine, I restarted my computer and what not, and it was slow, and 1/2 of my applications wouldnt open.

Well, this means that you did NOT follow the instructions :w00t: :ph34r:

There is a reason why I asked you to install the daily version:

  • UURollup-v10c is already integrated in the source ("HFSLIP_ia.7z").
  • UURollup-v10c uses the WildBill's kernel which may not be enough to run these graphic drivers.
  • UURollup-v10c does not support PAE on Win2k Pro so you can't use 8 GB RAM with it.
  • The daily version of UURollup uses the BlackWingCat's kernel together with a lot of other new files. They add many more APIs and other functionalities.
That's why I asked you to install the daily version, not the stable one. How come you're saying that there's no daily? :unsure: Try here (download the latest one).

Edit: Don't even look at UURollup (Global) !!!

Edited by tomasz86, 02 October 2012 - 10:39 PM.


#18
tomasz86

tomasz86

    www.windows2000.tk

  • Members
  • PipPipPipPipPipPipPipPip
  • 2,497 posts
  • OS:XP Pro x86
  • Country: Country Flag

Ok, I got the correct thing installed, and it lets me get the graphics installer past where i could get it before, BUT the screen resolution is messed up and i cant get to any of the keys to tell it to install, AND its doing just like the other stuff did- I cant use device manager (Doesnt open anything when i click it), I cant move things on my desktop, ect... Why does this happen?

How about checking one of the older drivers?

http://support.amd.c...deonaiw_xp.aspx

You could try the latest of the 11.x versions and if it works then go up one by one (12.1, 12.2, etc.) to see which work and which don't work.

#19
Win98

Win98

    Junior

  • Members
  • Pip
  • 80 posts
  • OS:98SE
  • Country: Country Flag
I tried to follow the instructions, it just didnt come across my mind that i was supposed to do that...

I found the daily.. But still, after installing it, the OS is unusable (Is there a way for me to uninstall or remove the files, so that I don't have to reinstall again), because I cant open anything, move files, use device manager, ect..

I'll try one of the older drivers, but i'm not sure the one I have doesn't work with it, because i cant use device manager, and the screen resolution is messed up, and i cant continue the installation, because i cant see what to click

This is what I mean: Posted Image

Uploaded with ImageShack.us

Sorry for the crappy picture..

Edited by Win98, 03 October 2012 - 06:09 AM.


#20
tomasz86

tomasz86

    www.windows2000.tk

  • Members
  • PipPipPipPipPipPipPipPip
  • 2,497 posts
  • OS:XP Pro x86
  • Country: Country Flag
Does the problem occur after you install the daily version of UURollup or after trying to install the graphics driver? :unsure:

#21
Win98

Win98

    Junior

  • Members
  • Pip
  • 80 posts
  • OS:98SE
  • Country: Country Flag
After the Daily UURollup. I have no other software (besides 7zip) installed.

Edited by Win98, 03 October 2012 - 08:15 AM.


#22
tomasz86

tomasz86

    www.windows2000.tk

  • Members
  • PipPipPipPipPipPipPipPip
  • 2,497 posts
  • OS:XP Pro x86
  • Country: Country Flag
Very strange :blink:

I've never seen this kind of error before. The system you're using is the one installed from an ISO created using the script from "HFSLIP_ia.7z", right?

Could you try to uninstall the daily version of UURollup and tell me if the situation is back to normal? You can uninstall it using the Add/Remove Programs applet or just go to your Windows directory and there will be a UURollup folder starting with "$" (it's hidden by default). There's an uninstaller inside.

#23
Win98

Win98

    Junior

  • Members
  • Pip
  • 80 posts
  • OS:98SE
  • Country: Country Flag
Yes, This is the ISO created with the HFSLIP.

Uninstall programs doesnt open correctly, and nothing appears when the windows directory is opened.. Ill boot another hard drive and delete it manually from the other OS.

Edit: Alright, I got to the directory, and i uninstalled it, and everything works normal now...

I looked in the installer log for it, and there was an error towards the end. Below are pictures of the error, and some of what it does with the UURollup installed.

http://imageshack.us/g/1/9793011/

Thanks!

Edited by Win98, 03 October 2012 - 04:54 PM.


#24
tomasz86

tomasz86

    www.windows2000.tk

  • Members
  • PipPipPipPipPipPipPipPip
  • 2,497 posts
  • OS:XP Pro x86
  • Country: Country Flag
I must say that this looks very strange. It looks as if USP5.1 wasn't integrated properly by HFSLIP. Could you tell me what version of IE is installed in the system? Also if you open the properties window of My Computer, is there any info related to USP5.1 displayed?

#25
Win98

Win98

    Junior

  • Members
  • Pip
  • 80 posts
  • OS:98SE
  • Country: Country Flag
IE 5 was installed, and I believe that your update brings it up to 6, and in the computer properties, there wasn't anything related to USP5.1. It said SP4.

So, I decided to start from scratch.. Redownloaded HFSLIP_ia,7z, and went through the procedure. Everything looked to complete fine, integrated the raid driver, made into an ISO, and when i go to install, when i get to the point "Setup is copying files", it tells me that some files are missing (Cant remember off of the top of my head, and i'm not going to try to re-install tonight to see because i need to sleep). I tried the process again on a different computer, and still got the same missing files (Im using a flash drive to install, By the way.). When i would press esc to skip those certain files (There were at least 50 of them),it finished copying the files it could locate, it rebooted like it should, but when it gets past the windows 2000 boot screen it sits on a flashing _ for eternity. Not sure why it the files were missing, but they are.. (I'm starting to think that this OS doesn't like me)

Edit: The files missing are kbdbe.dll, kbdbene.dll,kbdbr.dll, ect..

Edited by Win98, 04 October 2012 - 05:57 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users



How to remove advertisement from MSFN